summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/librvp')
-rw-r--r--net-im/librvp/Manifest2
-rw-r--r--net-im/librvp/librvp-0.9.6.ebuild30
-rw-r--r--net-im/librvp/librvp-0.9.7.ebuild30
-rw-r--r--net-im/librvp/metadata.xml12
4 files changed, 74 insertions, 0 deletions
diff --git a/net-im/librvp/Manifest b/net-im/librvp/Manifest
new file mode 100644
index 000000000000..a79a0e724582
--- /dev/null
+++ b/net-im/librvp/Manifest
@@ -0,0 +1,2 @@
+DIST librvp-0.9.6.tar.gz 464935 SHA256 c57747cd3c3628ff189ce1f30c3a027ad2a0f222cc7615a259124e646fb488e0
+DIST librvp-0.9.7.tar.gz 478014 SHA256 c674ad76a4c4b91088b2012b197964cec549edd74a88a53490bd7eda735ffd46
diff --git a/net-im/librvp/librvp-0.9.6.ebuild b/net-im/librvp/librvp-0.9.6.ebuild
new file mode 100644
index 000000000000..f8d737ca350e
--- /dev/null
+++ b/net-im/librvp/librvp-0.9.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit multilib
+
+DESCRIPTION="An RVP (Microsoft Exchange Instant Messaging) plugin for Pidgin"
+HOMEPAGE="http://www.waider.ie/hacks/workshop/c/rvp/"
+SRC_URI="http://www.waider.ie/hacks/workshop/c/rvp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin[gtk]"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_configure() {
+ econf --with-gaim-plugin-dir=/usr/$(get_libdir)/pidgin \
+ --with-gaim-data-dir=/usr/share/pixmaps/pidgin
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "install failure"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}
diff --git a/net-im/librvp/librvp-0.9.7.ebuild b/net-im/librvp/librvp-0.9.7.ebuild
new file mode 100644
index 000000000000..30ba9f896541
--- /dev/null
+++ b/net-im/librvp/librvp-0.9.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit multilib
+
+DESCRIPTION="An RVP (Microsoft Exchange Instant Messaging) plugin for Pidgin"
+HOMEPAGE="http://www.waider.ie/hacks/workshop/c/rvp/"
+SRC_URI="http://www.waider.ie/hacks/workshop/c/rvp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin[gtk]"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_configure() {
+ econf --with-gaim-plugin-dir=/usr/$(get_libdir)/pidgin \
+ --with-gaim-data-dir=/usr/share/pixmaps/pidgin
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "install failure"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}
diff --git a/net-im/librvp/metadata.xml b/net-im/librvp/metadata.xml
new file mode 100644
index 000000000000..282b3407ee83
--- /dev/null
+++ b/net-im/librvp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This is an RVP (Microsoft Exchange Instant Messaging) plugin for
+ Gaim 1.x and Pidgin. It's based on some work done at Lucent and
+ available through http://www.bell-labs.com/project/wwexptools/
+ </longdescription>
+</pkgmetadata>