summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/dhcp')
-rw-r--r--net-misc/dhcp/Manifest2
-rw-r--r--net-misc/dhcp/dhcp-4.4.2_p1-r2.ebuild285
-rw-r--r--net-misc/dhcp/dhcp-4.4.3-r1.ebuild294
-rw-r--r--net-misc/dhcp/files/dhcp-4.4.0-bind-disable.patch22
-rw-r--r--net-misc/dhcp/files/dhcp-4.4.2-fno-common.patch34
-rw-r--r--net-misc/dhcp/files/dhcp-4.4.2-variable-name.patch25
6 files changed, 0 insertions, 662 deletions
diff --git a/net-misc/dhcp/Manifest b/net-misc/dhcp/Manifest
index a6b776f66394..565f763ef590 100644
--- a/net-misc/dhcp/Manifest
+++ b/net-misc/dhcp/Manifest
@@ -1,3 +1 @@
-DIST dhcp-4.4.2-P1.tar.gz 9898311 BLAKE2B 7cc40dfbe578bee13c7dd7868a25d0d88358bf82b02539e933a4eba06039a43f0d99b3ef6ce811b60ed3a991b222844f4a5bd9e597c11d83b09ff551ba0380a6 SHA512 924e8b44f288361dbe837987869e57b929c73cb5e4af37cb2d7b19bca5ea8594048fb41c0792fede003188185f61b25befbc2ccda42f1f68e6b6bc22ef44b040
DIST dhcp-4.4.3-P1.tar.gz 10081055 BLAKE2B 6cc16f7472efb1e1f6b7a83cafd9a81a16f10af7361da079c48a5eff0d9e310f475dcc82e984c20936c64867183402d00d26e5366e75bf7463ec2aea4a6f68a4 SHA512 d14dc44d1c015780ae19769816cb01015959927a1ad7a3e84b89e0463253aaf46451af88e3260347196373906d5b438c7c616fee45ec3f128aa82af6702b7154
-DIST dhcp-4.4.3.tar.gz 10078953 BLAKE2B d88570760cc00bd72d1e9c2e76c7a7b9f07cadfbe044220a43ee33fc201c217725c3909a386ae11f28346920dacb0313d78193a9e3d7eac9757384b4fe762597 SHA512 4472d6794af80b482560956cee6895889cc1aca39980f851faf56824627e95731f2983cf7c7454bc3decb0a12c874fcbd29bd6c5a9695412def6bc14c6df17e0
diff --git a/net-misc/dhcp/dhcp-4.4.2_p1-r2.ebuild b/net-misc/dhcp/dhcp-4.4.2_p1-r2.ebuild
deleted file mode 100644
index 6b2cf7158832..000000000000
--- a/net-misc/dhcp/dhcp-4.4.2_p1-r2.ebuild
+++ /dev/null
@@ -1,285 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit systemd toolchain-funcs flag-o-matic tmpfiles
-
-MY_PV="${PV//_alpha/a}"
-MY_PV="${MY_PV//_beta/b}"
-MY_PV="${MY_PV//_rc/rc}"
-MY_PV="${MY_PV//_p/-P}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="ISC Dynamic Host Configuration Protocol (DHCP) client/server"
-HOMEPAGE="https://www.isc.org/dhcp"
-SRC_URI="ftp://ftp.isc.org/isc/dhcp/${MY_P}.tar.gz
- ftp://ftp.isc.org/isc/dhcp/${MY_PV}/${MY_P}.tar.gz"
-
-LICENSE="MPL-2.0 BSD SSLeay GPL-2" # GPL-2 only for init script
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="+client ipv6 ldap selinux +server ssl vim-syntax"
-
-DEPEND="
- acct-group/dhcp
- acct-user/dhcp
- client? (
- kernel_linux? (
- ipv6? ( sys-apps/iproute2 )
- sys-apps/net-tools
- )
- )
- ldap? (
- net-nds/openldap:=
- ssl? ( dev-libs/openssl:= )
- )"
-RDEPEND="${DEPEND}
- selinux? ( sec-policy/selinux-dhcp )
- vim-syntax? ( app-vim/dhcpd-syntax )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- # handle local bind hell
- cd "${S}"/bind
- unpack ./bind.tar.gz
-}
-
-PATCHES=(
- # Gentoo patches - these will probably never be accepted upstream
- # Fix some permission issues
- "${FILESDIR}/${PN}-3.0-fix-perms.patch"
-
- # Enable dhclient to equery NTP servers
- "${FILESDIR}/${PN}-4.3.6-dhclient-ntp.patch"
- "${FILESDIR}/${PN}-4.3.6-dhclient-resolvconf.patch"
-
- # Enable dhclient to get extra configuration from stdin
- "${FILESDIR}/${PN}-4.2.2-dhclient-stdin-conf.patch"
- "${FILESDIR}/${PN}-4.3.6-nogateway.patch" #265531
- "${FILESDIR}/${PN}-4.3.6-quieter-ping.patch" #296921
- "${FILESDIR}/${PN}-4.4.0-always-accept-4.patch" #437108
- "${FILESDIR}/${PN}-4.3.6-iproute2-path.patch" #480636
- "${FILESDIR}/${PN}-4.2.5-bindtodevice-inet6.patch" #471142
- "${FILESDIR}/${PN}-4.3.3-ldap-ipv6-client-id.patch" #559832
-
- # Possible upstream candidates
- "${FILESDIR}/${PN}-4.4.2-fno-common.patch" #710194
- "${FILESDIR}/${PN}-4.4.2-variable-name.patch" #752402
-)
-
-src_prepare() {
- default
-
- # Brand the version with Gentoo
- sed -i \
- -e "/VERSION=/s:'$: Gentoo-${PR}':" \
- configure || die
-
- # Change the hook script locations of the scripts
- sed -i \
- -e 's,/etc/dhclient-exit-hooks,/etc/dhcp/dhclient-exit-hooks,g' \
- -e 's,/etc/dhclient-enter-hooks,/etc/dhcp/dhclient-enter-hooks,g' \
- client/scripts/* || die
-
- # No need for the linux script to force bash #158540
- sed -i -e 's,#!/bin/bash,#!/bin/sh,' client/scripts/linux || die
-
- # Quiet the freebsd logger a little
- sed -i -e '/LOGGER=/ s/-s -p user.notice //g' client/scripts/freebsd || die
-
- # Remove these options from the sample config
- sed -i -r \
- -e "/(script|host-name|domain-name) /d" \
- client/dhclient.conf.example || die
-
- if use client && ! use server ; then
- sed -i -r \
- -e '/^SUBDIRS/s:\<(dhcpctl|relay|server)\>::g' \
- Makefile.in || die
- elif ! use client && use server ; then
- sed -i -r \
- -e '/^SUBDIRS/s:\<client\>::' \
- Makefile.in || die
- fi
-
- # Only install different man pages if we don't have en
- if [[ " ${LINGUAS} " != *" en "* ]]; then
- # Install Japanese man pages
- if [[ " ${LINGUAS} " == *" ja "* && -d doc/ja_JP.eucJP ]]; then
- einfo "Installing Japanese documention"
- cp doc/ja_JP.eucJP/dhclient* client || die
- cp doc/ja_JP.eucJP/dhcp* common || die
- fi
- fi
- # Now remove the non-english docs so there are no errors later
- rm -r doc/ja_JP.eucJP || die
-
- # make the bind build work - do NOT make "binddir" local!
- binddir="${S}/bind"
- cd "${binddir}" || die
- cat <<-EOF > bindvar.tmp
- binddir=${binddir}
- GMAKE=${MAKE:-gmake}
- EOF
- eapply -p2 "${FILESDIR}"/${PN}-4.4.0-bind-disable.patch
- # Only use the relevant subdirs now that ISC
- #removed the lib/export structure in bind.
- sed '/^SUBDIRS/s@=.*$@= isc dns isccfg irs samples@' \
- -i bind-*/lib/Makefile.in || die
-}
-
-src_configure() {
- # bind defaults to stupid `/usr/bin/ar`
- tc-export AR BUILD_CC
- export ac_cv_path_AR=${AR}
-
- # this is tested for by the bind build system, and can cause trouble
- # when cross-building; since dhcp itself doesn't make use of libcap,
- # simply disable it.
- export ac_cv_lib_cap_cap_set_proc=no
-
- # Use FHS sane paths ... some of these have configure options,
- # but not all, so just do it all here.
- local e="/etc/dhcp" r="/var/run/dhcp" l="/var/lib/dhcp"
- cat <<-EOF >> includes/site.h
- #define _PATH_DHCPD_CONF "${e}/dhcpd.conf"
- #define _PATH_DHCLIENT_CONF "${e}/dhclient.conf"
- #define _PATH_DHCPD_DB "${l}/dhcpd.leases"
- #define _PATH_DHCPD6_DB "${l}/dhcpd6.leases"
- #define _PATH_DHCLIENT_DB "${l}/dhclient.leases"
- #define _PATH_DHCLIENT6_DB "${l}/dhclient6.leases"
- #define _PATH_DHCPD_PID "${r}/dhcpd.pid"
- #define _PATH_DHCPD6_PID "${r}/dhcpd6.pid"
- #define _PATH_DHCLIENT_PID "${r}/dhcpclient.pid"
- #define _PATH_DHCLIENT6_PID "${r}/dhcpclient6.pid"
- #define _PATH_DHCRELAY_PID "${r}/dhcrelay.pid"
- #define _PATH_DHCRELAY6_PID "${r}/dhcrelay6.pid"
- EOF
-
- # Breaks with -O3 because of reliance on undefined behaviour
- # bug #787935
- append-flags -fno-strict-aliasing
-
- # bug #720806, bug #801592
- if use ppc || use arm || use hppa || [[ ${CHOST} == i486* ]] ; then
- append-libs -latomic
- fi
-
- local myeconfargs=(
- --enable-paranoia
- --enable-early-chroot
- --sysconfdir=${e}
- --with-randomdev=/dev/random
- $(use_enable ipv6 dhcpv6)
- $(use_with ldap)
- $(use ldap && use_with ssl ldapcrypto || echo --without-ldapcrypto)
- LIBS="${LIBS}"
- )
- econf "${myeconfargs[@]}"
-
- # configure local bind cruft. symtable option requires
- # perl and we don't want to require that #383837.
- cd bind/bind-*/ || die
- local el
- eval econf \
- $(for el in $(awk '/^bindconfig/,/^$/ {print}' ../Makefile.in) ; do if [[ ${el} =~ ^-- ]] ; then printf ' %s' ${el//\\} ; fi ; done | sed 's,@\([[:alpha:]]\+\)dir@,${binddir}/\1,g') \
- --with-randomdev=/dev/random \
- --disable-symtable \
- --without-make-clean
-}
-
-src_compile() {
- # build local bind cruft first
- emake -C bind/bind-*/lib install
- # then build standard dhcp code
- emake AR="$(tc-getAR)"
-}
-
-src_install() {
- default
-
- dodoc README RELNOTES doc/{api+protocol,IANA-arp-parameters}
- docinto html
- dodoc doc/References.html
-
- if [[ -e client/dhclient ]] ; then
- # move the client to /
- dodir /sbin
- mv "${ED}"/usr/sbin/dhclient "${ED}"/sbin/ || die
-
- exeinto /sbin
- if use kernel_linux ; then
- newexe "${S}"/client/scripts/linux dhclient-script
- else
- newexe "${S}"/client/scripts/freebsd dhclient-script
- fi
- fi
-
- if [[ -e server/dhcpd ]] ; then
- if use ldap ; then
- insinto /etc/openldap/schema
- doins contrib/ldap/dhcp.*
- dosbin contrib/ldap/dhcpd-conf-to-ldap
- fi
-
- newinitd "${FILESDIR}"/dhcpd.init5 dhcpd
- newconfd "${FILESDIR}"/dhcpd.conf2 dhcpd
- newinitd "${FILESDIR}"/dhcrelay.init3 dhcrelay
- newconfd "${FILESDIR}"/dhcrelay.conf dhcrelay
- newinitd "${FILESDIR}"/dhcrelay.init3 dhcrelay6
- newconfd "${FILESDIR}"/dhcrelay6.conf dhcrelay6
-
- newtmpfiles "${FILESDIR}"/dhcpd.tmpfiles dhcpd.conf
- systemd_dounit "${FILESDIR}"/dhcpd4.service
- systemd_dounit "${FILESDIR}"/dhcpd6.service
- systemd_dounit "${FILESDIR}"/dhcrelay4.service
- systemd_dounit "${FILESDIR}"/dhcrelay6.service
- systemd_install_serviced "${FILESDIR}"/dhcrelay4.service.conf
- systemd_install_serviced "${FILESDIR}"/dhcrelay6.service.conf
-
- sed -i "s:#@slapd@:$(usex ldap slapd ''):" "${ED}"/etc/init.d/* || die #442560
- fi
-
- # the default config files aren't terribly useful #384087
- local f
- for f in "${ED}"/etc/dhcp/*.conf.example ; do
- mv "${f}" "${f%.example}" || die
- done
- sed -i '/^[^#]/s:^:#:' "${ED}"/etc/dhcp/*.conf || die
-
- diropts -m0750 -o dhcp -g dhcp
- keepdir /var/lib/dhcp
-}
-
-pkg_preinst() {
- # Keep the user files over the sample ones. The
- # hashing is to ignore the crappy defaults #384087.
- local f h
- for f in dhclient:da7c8496a96452190aecf9afceef4510 dhcpd:10979e7b71134bd7f04d2a60bd58f070 ; do
- h=${f#*:}
- f="/etc/dhcp/${f%:*}.conf"
- if [ -e "${EROOT}"${f} ] ; then
- case $(md5sum "${EROOT}"${f}) in
- ${h}*) ;;
- *) cp -p "${EROOT}"${f} "${ED}"${f};;
- esac
- fi
- done
-}
-
-pkg_postinst() {
- if use server ; then
- tmpfiles_process dhcpd.conf
- fi
-
- if [[ -e "${ROOT}"/etc/init.d/dhcp ]] ; then
- ewarn
- ewarn "WARNING: The dhcp init script has been renamed to dhcpd"
- ewarn "/etc/init.d/dhcp and /etc/conf.d/dhcp need to be removed and"
- ewarn "and dhcp should be removed from the default runlevel"
- ewarn
- fi
-}
diff --git a/net-misc/dhcp/dhcp-4.4.3-r1.ebuild b/net-misc/dhcp/dhcp-4.4.3-r1.ebuild
deleted file mode 100644
index 9db36ddb42da..000000000000
--- a/net-misc/dhcp/dhcp-4.4.3-r1.ebuild
+++ /dev/null
@@ -1,294 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit systemd toolchain-funcs flag-o-matic tmpfiles
-
-MY_PV="${PV//_alpha/a}"
-MY_PV="${MY_PV//_beta/b}"
-MY_PV="${MY_PV//_rc/rc}"
-MY_PV="${MY_PV//_p/-P}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="ISC Dynamic Host Configuration Protocol (DHCP) client/server"
-HOMEPAGE="https://www.isc.org/dhcp"
-SRC_URI="ftp://ftp.isc.org/isc/dhcp/${MY_P}.tar.gz
- ftp://ftp.isc.org/isc/dhcp/${MY_PV}/${MY_P}.tar.gz"
-
-LICENSE="MPL-2.0 BSD SSLeay GPL-2" # GPL-2 only for init script
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="+client ipv6 ldap selinux +server ssl vim-syntax"
-
-DEPEND="
- acct-group/dhcp
- acct-user/dhcp
- client? (
- kernel_linux? (
- ipv6? ( sys-apps/iproute2 )
- sys-apps/net-tools
- )
- )
- ldap? (
- net-nds/openldap:=
- ssl? ( dev-libs/openssl:= )
- )"
-RDEPEND="${DEPEND}
- selinux? ( sec-policy/selinux-dhcp )
- vim-syntax? ( app-vim/dhcpd-syntax )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- # handle local bind hell
- cd "${S}"/bind
- unpack ./bind.tar.gz
-}
-
-PATCHES=(
- # Gentoo patches - these will probably never be accepted upstream
- # Fix some permission issues
- "${FILESDIR}/${PN}-3.0-fix-perms.patch"
-
- # Enable dhclient to equery NTP servers
- "${FILESDIR}/${PN}-4.3.6-dhclient-ntp.patch"
- "${FILESDIR}/${PN}-4.3.6-dhclient-resolvconf.patch"
-
- # Enable dhclient to get extra configuration from stdin
- "${FILESDIR}/${PN}-4.2.2-dhclient-stdin-conf.patch"
- # bug #265531
- "${FILESDIR}/${PN}-4.3.6-nogateway.patch"
- # bug #296921
- "${FILESDIR}/${PN}-4.3.6-quieter-ping.patch"
- # bug #437108
- "${FILESDIR}/${PN}-4.4.0-always-accept-4.patch"
- # bug #480636
- "${FILESDIR}/${PN}-4.3.6-iproute2-path.patch"
- # bug #471142
- "${FILESDIR}/${PN}-4.2.5-bindtodevice-inet6.patch"
- # bug #559832
- "${FILESDIR}/${PN}-4.3.3-ldap-ipv6-client-id.patch"
-
- # Possible upstream candidates
-)
-
-src_prepare() {
- default
-
- # Brand the version with Gentoo
- sed -i \
- -e "/VERSION=/s:'$: Gentoo-${PR}':" \
- configure || die
-
- # Change the hook script locations of the scripts
- sed -i \
- -e 's,/etc/dhclient-exit-hooks,/etc/dhcp/dhclient-exit-hooks,g' \
- -e 's,/etc/dhclient-enter-hooks,/etc/dhcp/dhclient-enter-hooks,g' \
- client/scripts/* || die
-
- # No need for the linux script to force bash #158540
- sed -i -e 's,#!/bin/bash,#!/bin/sh,' client/scripts/linux || die
-
- # Quiet the freebsd logger a little
- sed -i -e '/LOGGER=/ s/-s -p user.notice //g' client/scripts/freebsd || die
-
- # Remove these options from the sample config
- sed -i -r \
- -e "/(script|host-name|domain-name) /d" \
- client/dhclient.conf.example || die
-
- if use client && ! use server ; then
- sed -i -r \
- -e '/^SUBDIRS/s:\<(dhcpctl|relay|server)\>::g' \
- Makefile.in || die
- elif ! use client && use server ; then
- sed -i -r \
- -e '/^SUBDIRS/s:\<client\>::' \
- Makefile.in || die
- fi
-
- # Only install different man pages if we don't have en
- if [[ " ${LINGUAS} " != *" en "* ]]; then
- # Install Japanese man pages
- if [[ " ${LINGUAS} " == *" ja "* && -d doc/ja_JP.eucJP ]]; then
- einfo "Installing Japanese documention"
- cp doc/ja_JP.eucJP/dhclient* client || die
- cp doc/ja_JP.eucJP/dhcp* common || die
- fi
- fi
- # Now remove the non-english docs so there are no errors later
- rm -r doc/ja_JP.eucJP || die
-
- # make the bind build work - do NOT make "binddir" local!
- binddir="${S}/bind"
- cd "${binddir}" || die
- cat <<-EOF > bindvar.tmp
- binddir=${binddir}
- GMAKE=${MAKE:-gmake}
- EOF
- eapply -p2 "${FILESDIR}"/${PN}-4.4.3-bind-disable.patch
- # Only use the relevant subdirs now that ISC
- #removed the lib/export structure in bind.
- sed '/^SUBDIRS/s@=.*$@= isc dns isccfg irs samples@' \
- -i bind-*/lib/Makefile.in || die
-}
-
-src_configure() {
- # bind defaults to stupid `/usr/bin/ar`
- tc-export AR BUILD_CC
- export ac_cv_path_AR=${AR}
-
- # this is tested for by the bind build system, and can cause trouble
- # when cross-building; since dhcp itself doesn't make use of libcap,
- # simply disable it.
- export ac_cv_lib_cap_cap_set_proc=no
-
- # Use FHS sane paths ... some of these have configure options,
- # but not all, so just do it all here.
- local e="/etc/dhcp" r="/var/run/dhcp" l="/var/lib/dhcp"
- cat <<-EOF >> includes/site.h
- #define _PATH_DHCPD_CONF "${e}/dhcpd.conf"
- #define _PATH_DHCLIENT_CONF "${e}/dhclient.conf"
- #define _PATH_DHCPD_DB "${l}/dhcpd.leases"
- #define _PATH_DHCPD6_DB "${l}/dhcpd6.leases"
- #define _PATH_DHCLIENT_DB "${l}/dhclient.leases"
- #define _PATH_DHCLIENT6_DB "${l}/dhclient6.leases"
- #define _PATH_DHCPD_PID "${r}/dhcpd.pid"
- #define _PATH_DHCPD6_PID "${r}/dhcpd6.pid"
- #define _PATH_DHCLIENT_PID "${r}/dhcpclient.pid"
- #define _PATH_DHCLIENT6_PID "${r}/dhcpclient6.pid"
- #define _PATH_DHCRELAY_PID "${r}/dhcrelay.pid"
- #define _PATH_DHCRELAY6_PID "${r}/dhcrelay6.pid"
- EOF
-
- # Breaks with -O3 because of reliance on undefined behaviour
- # bug #787935
- append-flags -fno-strict-aliasing
-
- # bug #720806, bug #801592
- if use ppc || use arm || use hppa || [[ ${CHOST} == i486* ]] ; then
- append-libs -latomic
- fi
-
- local myeconfargs=(
- --enable-paranoia
- --enable-early-chroot
- --sysconfdir=${e}
- --with-randomdev=/dev/random
- $(use_enable ipv6 dhcpv6)
- $(use_with ldap)
- $(use ldap && use_with ssl ldapcrypto || echo --without-ldapcrypto)
- LIBS="${LIBS}"
- )
- econf "${myeconfargs[@]}"
-
- # configure local bind cruft. symtable option requires
- # perl and we don't want to require that. bug #383837.
- cd bind/bind-*/ || die
- local el
- eval econf \
- $(for el in $(awk '/^bindconfig/,/^$/ {print}' ../Makefile.in) ; do if [[ ${el} =~ ^-- ]] ; then printf ' %s' ${el//\\} ; fi ; done | sed 's,@\([[:alpha:]]\+\)dir@,${binddir}/\1,g') \
- --with-randomdev=/dev/random \
- --disable-symtable \
- --without-make-clean
-}
-
-src_compile() {
- # Build local bind cruft first
- emake -C bind/bind-*/lib install
- # then build standard dhcp code
- emake AR="$(tc-getAR)"
-}
-
-src_install() {
- default
-
- dodoc README RELNOTES doc/{api+protocol,IANA-arp-parameters}
- docinto html
- dodoc doc/References.html
-
- if [[ -e client/dhclient ]] ; then
- # Move the client to /
- dodir /sbin
- mv "${ED}"/usr/sbin/dhclient "${ED}"/sbin/ || die
-
- exeinto /sbin
- if use kernel_linux ; then
- newexe "${S}"/client/scripts/linux dhclient-script
- else
- newexe "${S}"/client/scripts/freebsd dhclient-script
- fi
- fi
-
- if [[ -e server/dhcpd ]] ; then
- if use ldap ; then
- insinto /etc/openldap/schema
- doins contrib/ldap/dhcp.*
- dosbin contrib/ldap/dhcpd-conf-to-ldap
- fi
-
- newinitd "${FILESDIR}"/dhcpd.init5 dhcpd
- newconfd "${FILESDIR}"/dhcpd.conf2 dhcpd
- newinitd "${FILESDIR}"/dhcrelay.init3 dhcrelay
- newconfd "${FILESDIR}"/dhcrelay.conf dhcrelay
- newinitd "${FILESDIR}"/dhcrelay.init3 dhcrelay6
- newconfd "${FILESDIR}"/dhcrelay6.conf dhcrelay6
-
- newtmpfiles "${FILESDIR}"/dhcpd.tmpfiles dhcpd.conf
- systemd_dounit "${FILESDIR}"/dhcpd4.service
- systemd_dounit "${FILESDIR}"/dhcpd6.service
- systemd_dounit "${FILESDIR}"/dhcrelay4.service
- systemd_dounit "${FILESDIR}"/dhcrelay6.service
- systemd_install_serviced "${FILESDIR}"/dhcrelay4.service.conf
- systemd_install_serviced "${FILESDIR}"/dhcrelay6.service.conf
-
- sed -i "s:#@slapd@:$(usex ldap slapd ''):" "${ED}"/etc/init.d/* || die #442560
- fi
-
- # the default config files aren't terribly useful #384087
- local f
- for f in "${ED}"/etc/dhcp/*.conf.example ; do
- mv "${f}" "${f%.example}" || die
- done
- sed -i '/^[^#]/s:^:#:' "${ED}"/etc/dhcp/*.conf || die
-
- diropts -m0750 -o dhcp -g dhcp
- keepdir /var/lib/dhcp
-}
-
-pkg_preinst() {
- # Keep the user files over the sample ones. The
- # hashing is to ignore the crappy defaults #384087.
- local f h
- for f in dhclient:da7c8496a96452190aecf9afceef4510 dhcpd:10979e7b71134bd7f04d2a60bd58f070 ; do
- h=${f#*:}
- f="/etc/dhcp/${f%:*}.conf"
- if [ -e "${EROOT}"${f} ] ; then
- case $(md5sum "${EROOT}"${f}) in
- ${h}*) ;;
- *) cp -p "${EROOT}"${f} "${ED}"${f};;
- esac
- fi
- done
-}
-
-pkg_postinst() {
- if use server ; then
- tmpfiles_process dhcpd.conf
- fi
-
- if use client ; then
- ewarn "The client and relay functionality will be removed in the next release!"
- ewarn "Upstream have decided to discontinue this functionality."
- fi
-
- if [[ -e "${EROOT}"/etc/init.d/dhcp ]] ; then
- ewarn
- ewarn "WARNING: The dhcp init script has been renamed to dhcpd"
- ewarn "/etc/init.d/dhcp and /etc/conf.d/dhcp need to be removed and"
- ewarn "and dhcp should be removed from the default runlevel"
- ewarn
- fi
-}
diff --git a/net-misc/dhcp/files/dhcp-4.4.0-bind-disable.patch b/net-misc/dhcp/files/dhcp-4.4.0-bind-disable.patch
deleted file mode 100644
index b74255ca4e97..000000000000
--- a/net-misc/dhcp/files/dhcp-4.4.0-bind-disable.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- dhcp-4.4.0/bind/Makefile.in
-+++ dhcp-4.4.0/bind/Makefile.in
-@@ -37,6 +37,7 @@
- @BIND_ATF_TRUE@all: bind1 atf bind2
-
- bind1:
-+disable:
- # Extract the source from the tarball, if it hasn't been already.
- @if test -d ${bindsrcdir} ; then \
- echo ${bindsrcdir} already unpacked... ; \
-@@ -60,6 +61,7 @@
- fi
-
- atf:
-+disable:
- # Build and copy the ATF support if not yet installed.
- @if test -d ./atf ; then \
- echo ATF support already installed ; \
---- dhcp-4.4.0/bind/test
-+++ dhcp-4.4.0/bind/test
-@@ -0,0 +1 @@
-+--disable-kqueue --disable-epoll --disable-devpoll --without-openssl --without-libxml2 --enable-exportlib --with-gssapi=no --enable-threads=no @BINDCONFIG@ --includedir=${binddir}/include --libdir=${binddir}/lib
diff --git a/net-misc/dhcp/files/dhcp-4.4.2-fno-common.patch b/net-misc/dhcp/files/dhcp-4.4.2-fno-common.patch
deleted file mode 100644
index 5d0b7bdd5352..000000000000
--- a/net-misc/dhcp/files/dhcp-4.4.2-fno-common.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- a/client/dhclient.c
-+++ b/client/dhclient.c
-@@ -83,8 +83,6 @@
- static const char url [] = "For info, please visit https://www.isc.org/software/dhcp/";
- #endif /* UNIT_TEST */
-
--u_int16_t local_port = 0;
--u_int16_t remote_port = 0;
- #if defined(DHCPv6) && defined(DHCP4o6)
- int dhcp4o6_state = -1; /* -1 = stopped, 0 = polling, 1 = started */
- #endif
---- a/relay/dhcrelay.c
-+++ b/relay/dhcrelay.c
-@@ -95,9 +95,6 @@
- forward_untouched, /* Forward without changes. */
- discard } agent_relay_mode = forward_and_replace;
-
--u_int16_t local_port;
--u_int16_t remote_port;
--
- /* Relay agent server list. */
- struct server_list {
- struct server_list *next;
---- a/server/mdb.c
-+++ b/server/mdb.c
-@@ -67,8 +67,6 @@
-
- int numclasseswritten;
-
--omapi_object_type_t *dhcp_type_host;
--
- isc_result_t enter_class(cd, dynamicp, commit)
- struct class *cd;
- int dynamicp;
diff --git a/net-misc/dhcp/files/dhcp-4.4.2-variable-name.patch b/net-misc/dhcp/files/dhcp-4.4.2-variable-name.patch
deleted file mode 100644
index 9f5085dd5e23..000000000000
--- a/net-misc/dhcp/files/dhcp-4.4.2-variable-name.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 261c84d91d1b4581df9f7f0ec031908299de7726 Mon Sep 17 00:00:00 2001
-From: Mark Andrews <marka@isc.org>
-Date: Thu, 19 Dec 2019 09:27:44 +1100
-Subject: [PATCH] fix variable name in conditional block
-
----
- lib/isc/stats.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/lib/isc/stats.c b/lib/isc/stats.c
-index 5bce3c1100..a7ab97ce53 100644
---- a/bind/bind-9.11.14/lib/isc/stats.c
-+++ b/bind/bind-9.11.14/lib/isc/stats.c
-@@ -297,7 +297,7 @@ setcounter(isc_stats_t *stats,
- isc_atomic_store((int32_t *)&stats->counters[counter].lo,
- (uint32_t)(value & 0xffffffff));
- # else
-- stats->counters[counter] = val;
-+ stats->counters[counter] = value;
- # endif
- #endif
- }
---
-GitLab
-