summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/traydevice')
-rw-r--r--sys-fs/traydevice/Manifest3
-rw-r--r--sys-fs/traydevice/metadata.xml5
-rw-r--r--sys-fs/traydevice/traydevice-1.5.2.ebuild45
-rw-r--r--sys-fs/traydevice/traydevice-1.5.ebuild46
-rw-r--r--sys-fs/traydevice/traydevice-1.6.2-r1.ebuild38
-rw-r--r--sys-fs/traydevice/traydevice-1.6.2.ebuild38
6 files changed, 175 insertions, 0 deletions
diff --git a/sys-fs/traydevice/Manifest b/sys-fs/traydevice/Manifest
new file mode 100644
index 000000000000..0586da9caa5b
--- /dev/null
+++ b/sys-fs/traydevice/Manifest
@@ -0,0 +1,3 @@
+DIST traydevice-1.5.2.tar.gz 24379 SHA256 e3d703d04c7b91b552332334c7fdbec9317eed8367dd733b9f45d24239c94393
+DIST traydevice-1.5.tar.gz 24234 SHA256 15af177049797d3536196899960b749529fdaffdd29ec4335f1dd6ec0e610ea3
+DIST traydevice-1.6.2.tar.gz 29238 SHA256 abeb4573d52a2111b0512e5cb2b728431151ed6b91b94dafbe42b872688deccb SHA512 19523c502a58aed9e1ea3c52970438a7119d9f4895527777b6c5c4167d44e917b23ca4cb7c1916f7eb7ff8c539d3c72cc1b70712affaa32a9eaa344ec8e92634 WHIRLPOOL 891a3b397d1b10dd143042da4fc048e8cbbcfba492b396a0ddc03d91e1d992fcdad963e0997e4530ba8276d4fd812dc4b699282c8f9d9e9c9d36751af3d8d11e
diff --git a/sys-fs/traydevice/metadata.xml b/sys-fs/traydevice/metadata.xml
new file mode 100644
index 000000000000..540f810e069d
--- /dev/null
+++ b/sys-fs/traydevice/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>
diff --git a/sys-fs/traydevice/traydevice-1.5.2.ebuild b/sys-fs/traydevice/traydevice-1.5.2.ebuild
new file mode 100644
index 000000000000..17d8fe0201d4
--- /dev/null
+++ b/sys-fs/traydevice/traydevice-1.5.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="A little desktop application displaying systray icon for UDisks"
+HOMEPAGE="http://savannah.nongnu.org/projects/traydevice/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/dbus-python
+ dev-python/lxml
+ dev-python/pyxdg
+ sys-fs/udisks:0"
+DEPEND="app-text/docbook2X"
+
+src_prepare() {
+ sed -i \
+ -e 's:docbook2man:docbook2man.pl:' \
+ setup.py || die
+
+ distutils_src_prepare
+}
+
+src_compile() { :; }
+
+src_install() {
+ distutils_src_install \
+ --prefix=/usr \
+ --install-data=/usr/share/${PN} \
+ --install-man=/usr/share/man
+
+ rm -f "${D}"/usr/share/${PN}/*.txt
+}
diff --git a/sys-fs/traydevice/traydevice-1.5.ebuild b/sys-fs/traydevice/traydevice-1.5.ebuild
new file mode 100644
index 000000000000..ecf4f67a0dbe
--- /dev/null
+++ b/sys-fs/traydevice/traydevice-1.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="A little desktop application displaying systray icon for UDisks"
+HOMEPAGE="http://savannah.nongnu.org/projects/traydevice/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/dbus-python
+ dev-python/lxml
+ dev-python/pyxdg
+ sys-fs/udisks:0"
+DEPEND="app-text/docbook2X"
+
+src_prepare() {
+ sed -i \
+ -e 's:docbook2man:docbook2man.pl:' \
+ setup.py || die
+
+ distutils_src_prepare
+}
+
+src_compile() { :; }
+
+src_install() {
+ distutils_src_install \
+ --root="${D}" \
+ --prefix=/usr \
+ --install-data=/usr/share/${PN} \
+ --install-man=/usr/share/man
+
+ rm -f "${D}"/usr/share/${PN}/*.txt
+}
diff --git a/sys-fs/traydevice/traydevice-1.6.2-r1.ebuild b/sys-fs/traydevice/traydevice-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..c51df187a77f
--- /dev/null
+++ b/sys-fs/traydevice/traydevice-1.6.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="A little desktop application displaying systray icon for UDisks"
+HOMEPAGE="http://savannah.nongnu.org/projects/traydevice/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ sys-fs/udisks:2"
+DEPEND="app-text/docbook2X"
+
+src_compile() { :; }
+
+python_install() {
+ distutils-r1_python_install \
+ --prefix=/usr \
+ --install-data=/usr/share/${PN} \
+ --install-man=/usr/share/man \
+ --docbook2man=docbook2man.pl
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ rm -f "${ED}"/usr/share/${PN}/doc/*.txt
+}
diff --git a/sys-fs/traydevice/traydevice-1.6.2.ebuild b/sys-fs/traydevice/traydevice-1.6.2.ebuild
new file mode 100644
index 000000000000..7e6e828bb02c
--- /dev/null
+++ b/sys-fs/traydevice/traydevice-1.6.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 3.*"
+
+inherit distutils
+
+DESCRIPTION="A little desktop application displaying systray icon for UDisks"
+HOMEPAGE="http://savannah.nongnu.org/projects/traydevice/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/dbus-python
+ dev-python/lxml
+ dev-python/pyxdg
+ sys-fs/udisks:2"
+DEPEND="app-text/docbook2X"
+
+src_compile() { :; }
+
+src_install() {
+ distutils_src_install \
+ --prefix=/usr \
+ --install-data=/usr/share/${PN} \
+ --install-man=/usr/share/man \
+ --docbook2man=$(type -p docbook2man.pl)
+
+ rm -f "${D}"/usr/share/${PN}/*.txt
+}