summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-12-26 18:59:03 +0100
committerMartin Väth <martin@mvath.de>2016-12-26 18:59:03 +0100
commit0e40666fe890a09a4981723d6f92da66017917e1 (patch)
tree4d8507d445440fa52e0a95bbe1391b1b4af50193
parentapp-eselect/eselect-net: New ebuild from scratch (diff)
downloadmv-0e40666fe890a09a4981723d6f92da66017917e1.tar.gz
mv-0e40666fe890a09a4981723d6f92da66017917e1.tar.bz2
mv-0e40666fe890a09a4981723d6f92da66017917e1.zip
avidemux: Filter problematic flags. Remove old
-rw-r--r--media-libs/avidemux-core/avidemux-core-2.6.12-r1.ebuild120
-rw-r--r--media-libs/avidemux-core/avidemux-core-2.6.15.ebuild4
-rw-r--r--media-libs/avidemux-plugins/avidemux-plugins-2.6.12.ebuild166
-rw-r--r--media-libs/avidemux-plugins/avidemux-plugins-2.6.15.ebuild3
-rw-r--r--media-video/avidemux/avidemux-2.6.12-r1.ebuild138
-rw-r--r--media-video/avidemux/avidemux-2.6.15-r1.ebuild4
6 files changed, 11 insertions, 424 deletions
diff --git a/media-libs/avidemux-core/avidemux-core-2.6.12-r1.ebuild b/media-libs/avidemux-core/avidemux-core-2.6.12-r1.ebuild
deleted file mode 100644
index 05dc6a7c..00000000
--- a/media-libs/avidemux-core/avidemux-core-2.6.12-r1.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-RESTRICT="mirror"
-
-inherit cmake-utils eutils flag-o-matic
-
-SLOT="2.6"
-
-DESCRIPTION="Core libraries for media-video/avidemux"
-HOMEPAGE="http://fixounet.free.fr/avidemux"
-
-# Multiple licenses because of all the bundled stuff.
-LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
-IUSE="debug nls sdl system-ffmpeg vaapi vdpau video_cards_fglrx xv"
-KEYWORDS="~amd64 ~x86"
-
-MY_PN="${PN/-core/}"
-if [[ ${PV} == *9999* ]] ; then
- MY_P=$P
- KEYWORDS=""
- PROPERTIES="live"
- EGIT_REPO_URI="git://gitorious.org/${MY_P}2-6/${MY_P}2-6.git https://git.gitorious.org/${MY_P}2-6/${MY_P}2-6.git"
- EGIT_REPO_URI="https://github.com/mean00/${MY_P}2"
- inherit git-r3
-else
- MY_P="${MY_PN}_${PV}"
- SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}/${PV}/${MY_P}.tar.gz"
-fi
-
-# Trying to use virtual; ffmpeg misses aac,cpudetection USE flags now though, are they needed?
-DEPEND="
- !<media-video/avidemux-${PV}:${SLOT}
- dev-db/sqlite:3
- sdl? ( media-libs/libsdl:0 )
- system-ffmpeg? ( >=virtual/ffmpeg-9:0[mp3,theora] )
- xv? ( x11-libs/libXv:0 )
- vaapi? ( x11-libs/libva:0 )
- vdpau? ( x11-libs/libvdpau:0 )
- video_cards_fglrx? (
- || ( >=x11-drivers/ati-drivers-14.12-r3
- x11-libs/xvba-video:0 )
- )"
-RDEPEND="
- $DEPEND
- nls? ( virtual/libintl:0 )
-"
-DEPEND="
- $DEPEND
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
- !system-ffmpeg? ( dev-lang/yasm[nls=] )
-"
-
-S="${WORKDIR}/${MY_P}"
-BUILD_DIR="${S}/buildCore"
-
-DOCS=( AUTHORS README )
-
-src_prepare() {
- mkdir "${BUILD_DIR}" || die "Can't create build folder."
-
- #cmake-utils_src_prepare
-
- if use system-ffmpeg ; then
- # Preparations to support the system ffmpeg. Currently fails because it depends on files the system ffmpeg doesn't install.
- local error="Failed to remove ffmpeg."
-
- rm -rf cmake/admFFmpeg* cmake/ffmpeg* avidemux_core/ffmpeg_package buildCore/ffmpeg || die "${error}"
- sed -i -e 's/include(admFFmpegUtil)//g' avidemux/commonCmakeApplication.cmake || die "${error}"
- sed -i -e '/registerFFmpeg/d' avidemux/commonCmakeApplication.cmake || die "${error}"
- sed -i -e 's/include(admFFmpegBuild)//g' avidemux_core/CMakeLists.txt || die "${error}"
- else
- # Avoid existing avidemux installations from making the build process fail, bug #461496.
- sed -i -e "s:getFfmpegLibNames(\"\${sourceDir}\"):getFfmpegLibNames(\"${S}/buildCore/ffmpeg/source/\"):g" cmake/admFFmpegUtil.cmake \
- || die "Failed to avoid existing avidemux installation from making the build fail."
- fi
-
- # Add lax vector typing for PowerPC.
- if use ppc || use ppc64 ; then
- append-cflags -flax-vector-conversions
- fi
-
- # See bug 432322.
- use x86 && replace-flags -O0 -O1
-
- # Needed for gcc-6
- append-cxxflags $(test-flags-CXX -std=gnu++98)
- eapply_user
-}
-
-src_configure() {
- local mycmakeargs
- mycmakeargs=(
- -DAVIDEMUX_SOURCE_DIR="'${S}'"
- -DGETTEXT="$(usex nls)"
- -DSDL="$(usex sdl)"
- -DLIBVA="$(usex vaapi)"
- -DVDPAU="$(usex vdpau)"
- -DXVBA="$(usex video_cards_fglrx)"
- -DXVIDEO="$(usex xv)"
- )
-
- if use debug ; then
- mycmakeargs+=( -DVERBOSE=1 -DCMAKE_BUILD_TYPE=Debug -DADM_DEBUG=1 )
- fi
-
- CMAKE_USE_DIR="${S}"/avidemux_core cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile -j1
-}
-
-src_install() {
- # revert edit from src_prepare prior to installing
- sed -i -e "s:getFfmpegLibNames(\"${S}/buildCore/ffmpeg/source/\"):getFfmpegLibNames(\"\${sourceDir}\"):g" cmake/admFFmpegUtil.cmake
- cmake-utils_src_install -j1
-}
diff --git a/media-libs/avidemux-core/avidemux-core-2.6.15.ebuild b/media-libs/avidemux-core/avidemux-core-2.6.15.ebuild
index 411a54d3..438f69f5 100644
--- a/media-libs/avidemux-core/avidemux-core-2.6.15.ebuild
+++ b/media-libs/avidemux-core/avidemux-core-2.6.15.ebuild
@@ -91,6 +91,10 @@ src_prepare() {
# Needed for gcc-6
append-cxxflags $(test-flags-CXX -std=gnu++98)
+
+ # Filter problematic flags
+ filter-flags -fwhole-program -flto
+
eapply_user
}
diff --git a/media-libs/avidemux-plugins/avidemux-plugins-2.6.12.ebuild b/media-libs/avidemux-plugins/avidemux-plugins-2.6.12.ebuild
deleted file mode 100644
index b5192b73..00000000
--- a/media-libs/avidemux-plugins/avidemux-plugins-2.6.12.ebuild
+++ /dev/null
@@ -1,166 +0,0 @@
-# Copyright 2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-RESTRICT="mirror"
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils eutils flag-o-matic python-single-r1
-
-SLOT="2.6"
-
-DESCRIPTION="Plugins for media-video/avidemux"
-HOMEPAGE="http://fixounet.free.fr/avidemux"
-
-# Multiple licenses because of all the bundled stuff.
-LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
-IUSE="aac aften a52 alsa amr debug dts fontconfig fribidi jack lame libsamplerate cpu_flags_x86_mmx nvenc opengl opus oss pulseaudio qt4 vorbis truetype twolame xv xvid x264 x265 vdpau vpx"
-KEYWORDS="~amd64 ~x86"
-
-MY_PN="${PN/-plugins/}"
-if [[ ${PV} == *9999* ]] ; then
- MY_P=$P
- KEYWORDS=""
- PROPERTIES="live"
- EGIT_REPO_URI="git://gitorious.org/${MY_P}2-6/${MY_P}2-6.git https://git.gitorious.org/${MY_P}2-6/${MY_P}2-6.git"
- EGIT_REPO_URI="https://github.com/mean00/${MY_P}2"
- inherit git-r3
-else
- MY_P="${MY_PN}_${PV}"
- SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}/${PV}/${MY_P}.tar.gz"
-fi
-
-RDEPEND="
- ~media-libs/avidemux-core-${PV}:${SLOT}[vdpau?]
- ~media-video/avidemux-${PV}:${SLOT}[opengl?,qt4?]
- >=dev-lang/spidermonkey-1.5-r2:0=
- dev-libs/libxml2:2
- media-libs/libpng:0=
- virtual/libiconv:0
- aac? (
- media-libs/faac:0
- media-libs/faad2:0
- )
- aften? ( media-libs/aften:0 )
- alsa? ( >=media-libs/alsa-lib-1.0.3b-r2:0 )
- amr? ( media-libs/opencore-amr:0 )
- dts? ( media-libs/libdca:0 )
- fontconfig? ( media-libs/fontconfig:1.0 )
- fribidi? ( dev-libs/fribidi:0 )
- jack? (
- media-sound/jack-audio-connection-kit:0
- libsamplerate? ( media-libs/libsamplerate:0 )
- )
- lame? ( media-sound/lame:0 )
- nvenc? ( amd64? ( media-video/nvidia_video_sdk:0 ) )
- opus? ( media-libs/opus:0 )
- oss? ( virtual/os-headers:0 )
- pulseaudio? ( media-sound/pulseaudio:0 )
- truetype? ( media-libs/freetype:2 )
- twolame? ( media-sound/twolame:0 )
- x264? ( media-libs/x264:0= )
- x265? ( >=media-libs/x265-1.9 )
- xv? (
- x11-libs/libX11:0
- x11-libs/libXext:0
- x11-libs/libXv:0
- )
- xvid? ( media-libs/xvid:0 )
- vorbis? ( media-libs/libvorbis:0 )
- vpx? ( media-libs/libvpx:0 )
-"
-DEPEND="$RDEPEND
- ${PYTHON_DEPS}"
-
-S="${WORKDIR}/${MY_P}"
-
-REQUIRED_USE="!amd64? ( !nvenc )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.6.4-optional-pulse.patch
- "${FILESDIR}"/${PN}-abs.patch
-)
-
-src_prepare() {
- default
-}
-
-src_configure() {
- # Add lax vector typing for PowerPC.
- if use ppc || use ppc64 ; then
- append-cflags -flax-vector-conversions
- fi
-
- # See bug 432322.
- use x86 && replace-flags -O0 -O1
-
- # Needed for gcc-6
- append-cxxflags $(test-flags-CXX -std=gnu++98)
-
- processes="buildPluginsCommon:avidemux_plugins
- buildPluginsCLI:avidemux_plugins"
- use qt4 && processes+=" buildPluginsQt4:avidemux_plugins"
-
- for process in ${processes} ; do
- local build="${process%%:*}"
-
- local mycmakeargs
- mycmakeargs=(
- -DAVIDEMUX_SOURCE_DIR="'${S}'"
- -DPLUGIN_UI=$(echo ${build/buildPlugins/} | tr '[:lower:]' '[:upper:]')
- -DFAAC="$(usex aac)"
- -DFAAD="$(usex aac)"
- -DALSA="$(usex alsa)"
- -DAFTEN="$(usex aften)"
- -DOPENCORE_AMRWB="$(usex amr)"
- -DOPENCORE_AMRNB="$(usex amr)"
- -DLIBDCA="$(usex dts)"
- -DFONTCONFIG="$(usex fontconfig)"
- -DJACK="$(usex jack)"
- -DLAME="$(usex lame)"
- -DNVENC="$(usex nvenc)"
- -DOPUS="$(usex opus)"
- -DOSS="$(usex oss)"
- -DPULSEAUDIOSIMPLE="$(usex pulseaudio)"
- -DQT4="$(usex qt4)"
- -DFREETYPE2="$(usex truetype)"
- -DTWOLAME="$(usex twolame)"
- -DX264="$(usex x264)"
- -DX265="$(usex x265)"
- -DXVIDEO="$(usex xv)"
- -DXVID="$(usex xvid)"
- -DVDPAU="$(usex vdpau)"
- -DVORBIS="$(usex vorbis)"
- -DLIBVORBIS="$(usex vorbis)"
- -DVPXDEC="$(usex vpx)"
- )
-
- if use debug ; then
- mycmakeargs+=( -DVERBOSE=1 -DCMAKE_BUILD_TYPE=Debug -DADM_DEBUG=1 )
- fi
-
- mkdir "${S}"/${build} || die "Can't create build folder."
-
- CMAKE_USE_DIR="${S}"/${process#*:} BUILD_DIR="${S}"/${build} cmake-utils_src_configure
- done
-}
-
-src_compile() {
- for process in ${processes} ; do
- BUILD_DIR="${S}/${process%%:*}" cmake-utils_src_compile
- done
-}
-
-src_install() {
- for process in ${processes} ; do
- # cmake-utils_src_install doesn't respect BUILD_DIR
- # and there sometimes is a preinstall phase present.
- pushd "${S}/${process%%:*}" > /dev/null || die
- grep '^preinstall/fast' Makefile && emake DESTDIR="${D}" preinstall/fast
- grep '^install/fast' Makefile && emake DESTDIR="${D}" install/fast
- popd > /dev/null || die
- done
-
- #python_fix_shebang "${D}"
-}
diff --git a/media-libs/avidemux-plugins/avidemux-plugins-2.6.15.ebuild b/media-libs/avidemux-plugins/avidemux-plugins-2.6.15.ebuild
index 1f10d4a3..fe5a7eee 100644
--- a/media-libs/avidemux-plugins/avidemux-plugins-2.6.15.ebuild
+++ b/media-libs/avidemux-plugins/avidemux-plugins-2.6.15.ebuild
@@ -97,6 +97,9 @@ src_configure() {
# Needed for gcc-6
append-cxxflags $(test-flags-CXX -std=gnu++98)
+ # Filter problematic flags
+ filter-flags -fwhole-program -flto
+
processes="buildPluginsCommon:avidemux_plugins
buildPluginsCLI:avidemux_plugins"
if use qt4 || use qt5 ; then
diff --git a/media-video/avidemux/avidemux-2.6.12-r1.ebuild b/media-video/avidemux/avidemux-2.6.12-r1.ebuild
deleted file mode 100644
index 6e0ed63a..00000000
--- a/media-video/avidemux/avidemux-2.6.12-r1.ebuild
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-RESTRICT="mirror"
-
-PLOCALES="ca cs de el es fr it ja pt_BR ru sr sr@latin tr"
-
-inherit cmake-utils eutils flag-o-matic l10n
-
-SLOT="2.6"
-
-DESCRIPTION="Video editor designed for simple cutting, filtering and encoding tasks"
-HOMEPAGE="http://fixounet.free.fr/avidemux"
-
-# Multiple licenses because of all the bundled stuff.
-LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
-IUSE="debug opengl nls qt4 sdl vaapi vdpau video_cards_fglrx xv"
-KEYWORDS="~amd64 ~x86"
-
-if [[ ${PV} == *9999* ]] ; then
- MY_P=$P
- KEYWORDS=""
- PROPERTIES="live"
- EGIT_REPO_URI="https://github.com/mean00/avidemux2"
- inherit git-r3
-else
- MY_P="${PN}_${PV}"
- SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${MY_P}.tar.gz"
-fi
-
-DEPEND="
- ~media-libs/avidemux-core-${PV}:${SLOT}[nls?,sdl?,vaapi?,vdpau?,video_cards_fglrx?,xv?]
- opengl? ( virtual/opengl:0 )
- qt4? ( >=dev-qt/qtgui-4.8.3:4 )
- vaapi? ( x11-libs/libva:0 )
- video_cards_fglrx? (
- || ( >=x11-drivers/ati-drivers-14.12-r3
- x11-libs/xvba-video:0 )
- )"
-RDEPEND="$DEPEND"
-PDEPEND="~media-libs/avidemux-plugins-${PV}:${SLOT}[opengl?,qt4?]"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- #cmake-utils_src_prepare
-
- # Fix icon name -> avidemux-2.6.png
- sed -i -e "/^Icon/ s:${PN}:${PN}-2.6:" ${PN}2.desktop || die "Icon name fix failed."
-
- # The desktop file is broken. It uses avidemux2 instead of avidemux3
- # so it will actually launch avidemux-2.5 if it is installed.
- sed -i -e "/^Exec/ s:${PN}2:${PN}3:" ${PN}2.desktop || die "Desktop file fix failed."
- sed -i -re '/^Exec/ s:(avidemux3_)gtk:\1qt4:' ${PN}2.desktop || die "Desktop file fix failed."
-
- # Fix QA warnings that complain a trailing ; is missing and Application is deprecated.
- sed -i -e 's/Application;AudioVideo/AudioVideo;/g' ${PN}2.desktop || die "Desktop file fix failed."
-
- # Now rename the desktop file to not collide with 2.5.
- mv ${PN}2.desktop ${PN}-2.6.desktop || die "Collision rename failed."
-
- # Fix underlinking to work with gold linker
- sed -i -e 's/\( ADM_core6\)/ Xext\1/' avidemux/common/ADM_render/CMakeLists.txt || die "Couldn't fix underlinking"
-
- # Remove "Build Option" dialog because it doesn't reflect what the GUI can or has been built with. (Bug #463628)
- sed -i -e '/Build Option/d' avidemux/common/ADM_commonUI/myOwnMenu.h || die "Couldn't remove \"Build Option\" dialog."
- eapply_user
-}
-
-src_configure() {
- local mycmakeargs
- mycmakeargs=(
- -DAVIDEMUX_SOURCE_DIR="'${S}'"
- -DGETTEXT="$(usex nls)"
- -DSDL="$(usex sdl)"
- -DLIBVA="$(usex vaapi)"
- -DVDPAU="$(usex vdpau)"
- -DXVBA="$(usex video_cards_fglrx)"
- -DXVIDEO="$(usex xv)"
- )
-
- if use debug ; then
- mycmakeargs+=( -DVERBOSE=1 -DCMAKE_BUILD_TYPE=Debug -DADM_DEBUG=1 )
- fi
-
- processes="buildCli:avidemux/cli"
- use qt4 && processes+=" buildQt4:avidemux/qt4"
-
- # Needed for gcc-6
- append-cxxflags $(test-flags-CXX -std=gnu++98)
-
- # Add lax vector typing for PowerPC.
- if use ppc || use ppc64 ; then
- append-cflags -flax-vector-conversions
- fi
-
- # See bug 432322.
- use x86 && replace-flags -O0 -O1
-
- for process in ${processes} ; do
- local build="${process%%:*}"
-
- mkdir "${S}"/${build} || die "Can't create build folder."
- cd "${S}"/${build} || die "Can't enter build folder."
- CMAKE_USE_DIR="${S}"/${process#*:} BUILD_DIR="${S}"/${build} cmake-utils_src_configure
- done
-}
-
-src_compile() {
- for process in ${processes} ; do
- BUILD_DIR="${S}/${process%%:*}" cmake-utils_src_compile
- done
-}
-
-DOCS=( AUTHORS README )
-
-src_install() {
- for process in ${processes} ; do
- BUILD_DIR="${S}/${process%%:*}" cmake-utils_src_install
- done
-
- if [[ -f "${ED}"/usr/bin/avidemux3_cli ]] ; then
- fperms +x /usr/bin/avidemux3_cli
- fi
-
- if [[ -f "${ED}"/usr/bin/avidemux3_jobs ]] ; then
- fperms +x /usr/bin/avidemux3_jobs
- fi
-
- cd "${S}" || die "Can't enter source folder."
- newicon ${PN}_icon.png ${PN}-2.6.png
-
- if use qt4 ; then
- fperms +x /usr/bin/avidemux3_qt4
- domenu ${PN}-2.6.desktop
- fi
-}
diff --git a/media-video/avidemux/avidemux-2.6.15-r1.ebuild b/media-video/avidemux/avidemux-2.6.15-r1.ebuild
index 3226c752..91bb3074 100644
--- a/media-video/avidemux/avidemux-2.6.15-r1.ebuild
+++ b/media-video/avidemux/avidemux-2.6.15-r1.ebuild
@@ -70,6 +70,7 @@ src_prepare() {
# Fix underlinking to work with gold linker
sed -i -e 's/\( ADM_core6\)/ Xext\1/' avidemux/common/ADM_render/CMakeLists.txt || die "Couldn't fix underlinking"
+
eapply_user
}
@@ -103,6 +104,9 @@ src_configure() {
# Needed for gcc-6
append-cxxflags $(test-flags-CXX -std=gnu++98)
+ # Filter problematic flags
+ filter-flags -fwhole-program -flto -ftracer
+
# Add lax vector typing for PowerPC.
if use ppc || use ppc64 ; then
append-cflags -flax-vector-conversions