summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenry Gebhardt <hsggebhardt@googlemail.com>2011-05-15 21:55:17 +0200
committerHenry Gebhardt <hsggebhardt@googlemail.com>2011-05-15 21:55:17 +0200
commit1c0391a14089173e048222eb3a2286dc01d6962a (patch)
tree3b303c73d03e4d31b9d3a3717cd13a3784b83ad5
parentsys-apps/systemd-26: Add check for uevent helper (diff)
downloadsystemd-1c0391a14089173e048222eb3a2286dc01d6962a.tar.gz
systemd-1c0391a14089173e048222eb3a2286dc01d6962a.tar.bz2
systemd-1c0391a14089173e048222eb3a2286dc01d6962a.zip
sys-apps/systemd-9999: Synchronize with v26 ebuild
-rw-r--r--sys-apps/systemd/Manifest2
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild29
2 files changed, 26 insertions, 5 deletions
diff --git a/sys-apps/systemd/Manifest b/sys-apps/systemd/Manifest
index 6d4bf64..8b22bab 100644
--- a/sys-apps/systemd/Manifest
+++ b/sys-apps/systemd/Manifest
@@ -1,4 +1,4 @@
DIST systemd-26.tar.bz2 791117 RMD160 06836ca8daf0c5ebc113940357289348561dac56 SHA1 901486904aeb1d8a3ae20e5971afd9b42b847450 SHA256 d7a222c09cdb0a9eebe97c7c499c458cc29ef8b3b2d0ca79bb949b2fd3d077d3
EBUILD systemd-26.ebuild 4236 RMD160 a7bdee3b9cadc269b6849229768b068f8f346f39 SHA1 ff30a7f5eac8d79fe6c1306a28d6e40a47d39370 SHA256 994bf8838bd831476181bd023a2b1c9b038cb318c4b70a8bdf49e681987ad5cb
-EBUILD systemd-9999.ebuild 3609 RMD160 b01d998c48ad0cb5e851cc6e4f85a876867920e4 SHA1 61b2d74cc54d7b00af725c3275fd0d4f4d070761 SHA256 52bdb7d785a54b3fcb16156ba46845cbc5806942a9972d8b90d487c1949b03a3
+EBUILD systemd-9999.ebuild 4215 RMD160 a7fda5c858136bd474c2a23fd5c630e84d6f412d SHA1 75eb64200629c890a8cdd554b58c57e06493d4ca SHA256 da9533edb1b2c531692c6d4a3b03e2b46ec82fb2fedbabeb870ac85609c711a5
MISC metadata.xml 737 RMD160 cdd440f38c039bfa7967fd713ef238588c2e1fb4 SHA1 1dea5e1d1e388bf43131297667bb4dbba10e65dd SHA256 042b1b68c02c274920954280705e21c2ca2ef5eece3229aab03d8dd43e06422d
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 28ddd06..26cf3b0 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=4
inherit autotools git linux-info pam
@@ -14,7 +14,7 @@ EGIT_BRANCH="master"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="audit gtk pam +tcpwrap sysv selinux"
+IUSE="audit gtk pam selinux sysv +tcpwrap"
COMMON_DEPEND=">=sys-apps/dbus-1.4.8-r1
sys-libs/libcap
@@ -30,6 +30,7 @@ COMMON_DEPEND=">=sys-apps/dbus-1.4.8-r1
tcpwrap? ( sys-apps/tcp-wrappers )
>=sys-apps/util-linux-2.19"
+# Vala-0.10 doesn't work with libnotify 0.7.1
VALASLOT="0.12"
MINKV="2.6.38"
@@ -39,10 +40,30 @@ DEPEND="${COMMON_DEPEND}
gtk? ( dev-lang/vala:${VALASLOT} )
>=sys-kernel/linux-headers-${MINKV}"
-CONFIG_CHECK="AUTOFS4_FS CGROUPS DEVTMPFS ~FANOTIFY ~IPV6"
+check_no_uevent_hotplug_helper() {
+ local path
+ if linux_config_exists; then
+ path="$(linux_chkconfig_string UEVENT_HELPER_PATH)"
+ path="${path#\"}"
+ path="${path%\"}"
+ path="${path#\'}"
+ path="${path%\'}"
+ if test "${path}" != ""; then
+ qewarn "The kernel should be configured with"
+ qewarn "CONFIG_UEVENT_HELPER_PATH=\"\". Also, be sure to check"
+ qewarn "that /proc/sys/kernel/hotplug is empty."
+ fi
+ fi
+}
-pkg_setup() {
+pkg_pretend() {
+ local CONFIG_CHECK="AUTOFS4_FS CGROUPS DEVTMPFS ~FANOTIFY ~IPV6"
linux-info_pkg_setup
+ check_no_uevent_hotplug_helper
+ kernel_is -ge ${MINKV//./ } || die "Kernel version at least ${MINKV} required"
+}
+
+pkg_setup() {
enewgroup lock # used by var-lock.mount
enewgroup tty 5 # used by mount-setup for /dev/pts
}