aboutsummaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorJason Stubbs <jstubbs@gentoo.org>2004-12-14 12:56:29 +0000
committerJason Stubbs <jstubbs@gentoo.org>2004-12-14 12:56:29 +0000
commit4ebbdfc552985b4f69306d473b2e276b29129390 (patch)
tree1352c702eddd16125dab0321e3085ff27a1b9797 /bin
parentpkgcmp needs to be in portage namespace as well (diff)
downloadportage-cvs-4ebbdfc552985b4f69306d473b2e276b29129390.tar.gz
portage-cvs-4ebbdfc552985b4f69306d473b2e276b29129390.tar.bz2
portage-cvs-4ebbdfc552985b4f69306d473b2e276b29129390.zip
Fixed emerge so that the "emerge by path" message is only shown when the
"path" ends in .ebuild or .tbz2. Fixed the package.keywords bug that caused all packages to become unmasked.
Diffstat (limited to 'bin')
-rwxr-xr-xbin/emerge4
1 files changed, 2 insertions, 2 deletions
diff --git a/bin/emerge b/bin/emerge
index f88137a..e349786 100755
--- a/bin/emerge
+++ b/bin/emerge
@@ -1,7 +1,7 @@
#!/usr/bin/python -O
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/bin/emerge,v 1.367 2004/12/07 15:06:41 jstubbs Exp $
+# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/bin/emerge,v 1.368 2004/12/14 12:56:29 jstubbs Exp $
import os,sys
os.environ["PORTAGE_CALLER"]="emerge"
@@ -293,7 +293,7 @@ if (myaction in ["world", "system"]) and myfiles:
sys.exit(1)
for x in myfiles:
- if os.path.exists(os.path.abspath(x)):
+ if (x.endswith(".ebuild") or x.endswith(".tbz2")) and os.path.exists(os.path.abspath(x)):
print "emerging by path implies --oneshot... adding --oneshot to options."
print red("\n*** emerging by path is broken and may not always work!!!\n")
break