summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-01-04 22:47:42 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-01-04 22:47:42 +0000
commit004b657906ec29c48d3926920053a59af9701b78 (patch)
treeacfee916f6db98cb5c76b1049fda1120fecb520b
parentdrop alpha keyword to match >=x11-base/xorg-server-1.5 keywords (diff)
downloadgentoo-2-004b657906ec29c48d3926920053a59af9701b78.tar.gz
gentoo-2-004b657906ec29c48d3926920053a59af9701b78.tar.bz2
gentoo-2-004b657906ec29c48d3926920053a59af9701b78.zip
Bumping to 0.7. Fixes #180918. Thanks to Scott McClung for the ebuild
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
-rw-r--r--dev-lang/gforth/ChangeLog9
-rw-r--r--dev-lang/gforth/gforth-0.7.0.ebuild63
2 files changed, 70 insertions, 2 deletions
diff --git a/dev-lang/gforth/ChangeLog b/dev-lang/gforth/ChangeLog
index 3b05cf9a574e..20c0326cc9c3 100644
--- a/dev-lang/gforth/ChangeLog
+++ b/dev-lang/gforth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/gforth
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/ChangeLog,v 1.26 2008/09/06 06:50:36 ulm Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/ChangeLog,v 1.27 2009/01/04 22:47:42 patrick Exp $
+
+*gforth-0.7.0 (04 Jan 2009)
+
+ 04 Jan 2009; Patrick Lauer <patrick@gentoo.org> +gforth-0.7.0.ebuild:
+ Bumping to 0.7. Fixes #180918. Thanks to Scott McClung for the ebuild
06 Sep 2008; Ulrich Mueller <ulm@gentoo.org> files/gforth.el-gentoo.patch,
gforth-0.6.2-r1.ebuild:
diff --git a/dev-lang/gforth/gforth-0.7.0.ebuild b/dev-lang/gforth/gforth-0.7.0.ebuild
new file mode 100644
index 000000000000..524c8f9a4cd2
--- /dev/null
+++ b/dev-lang/gforth/gforth-0.7.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.7.0.ebuild,v 1.1 2009/01/04 22:47:42 patrick Exp $
+
+inherit elisp-common eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="GNU Forth is a fast and portable implementation of the ANSI Forth language"
+HOMEPAGE="http://www.gnu.org/software/gforth"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/gforth/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs"
+
+DEPEND="virtual/libc
+ dev-libs/ffcall
+ emacs? ( virtual/emacs )"
+
+RDEPEND="${DEPEND}"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ local myconf
+
+ # May want to add a USE flag for --enable-force-cdiv, if necessary
+ # At this point I do not know when that is appropriate, and I don't
+ # want to add an ebuild-specific USE flag without understanding.
+
+ if ! use emacs; then
+ myconf="--without-lispdir"
+ fi
+
+ econf ${myconf} || die "econf failed"
+
+ # Parallel make breaks here
+ emake -j1 || die "emake failed"
+
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS BUGS ChangeLog NEWS* README* ToDo doc/glossaries.doc doc/*.ps
+
+ if use emacs; then
+ elisp-install ${PN} gforth.el gforth.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}