summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-06-10 09:52:46 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-06-10 09:52:46 +0000
commit00f6cb2b4c9c056d23689d90ca0f7397b6d84e43 (patch)
tree23ba57a0607ee7a5ec5bd966926dafc81273c975
parentMarked stable on hppa. (Manifest recommit) (diff)
downloadgentoo-2-00f6cb2b4c9c056d23689d90ca0f7397b6d84e43.tar.gz
gentoo-2-00f6cb2b4c9c056d23689d90ca0f7397b6d84e43.tar.bz2
gentoo-2-00f6cb2b4c9c056d23689d90ca0f7397b6d84e43.zip
Version bumped. Closes 53383
-rw-r--r--net-p2p/bittornado/ChangeLog7
-rw-r--r--net-p2p/bittornado/Manifest2
-rw-r--r--net-p2p/bittornado/bittornado-0.3.2.ebuild66
-rw-r--r--net-p2p/bittornado/files/digest-bittornado-0.3.21
4 files changed, 75 insertions, 1 deletions
diff --git a/net-p2p/bittornado/ChangeLog b/net-p2p/bittornado/ChangeLog
index 2781dfa61aee..6b64ac40cea8 100644
--- a/net-p2p/bittornado/ChangeLog
+++ b/net-p2p/bittornado/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/bittornado
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/ChangeLog,v 1.12 2004/06/01 21:27:19 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/ChangeLog,v 1.13 2004/06/10 09:52:46 mholzer Exp $
+
+*bittornado-0.3.2 (10 Jun 2004)
+
+ 10 Jun 2004; Martin Holzer <mholzer@gentoo.org> bittornado-0.3.2.ebuild:
+ Version bumped. Closes 53383
02 Jun 2004; Martin Holzer <mholzer@gentoo.org> bittornado-0.3.0.ebuild:
x86 stable.
diff --git a/net-p2p/bittornado/Manifest b/net-p2p/bittornado/Manifest
index d4d0c45e634a..e874fd86b400 100644
--- a/net-p2p/bittornado/Manifest
+++ b/net-p2p/bittornado/Manifest
@@ -1,6 +1,8 @@
MD5 a3395ad73d589fbebbed0c9ef138f977 bittornado-0.3.0.ebuild 1858
MD5 7741fac1cdc61652a05e0bf891cf501a bittornado-0.3.1.ebuild 1741
+MD5 7741fac1cdc61652a05e0bf891cf501a bittornado-0.3.2.ebuild 1741
MD5 8aefbc0e49db723ca1ad02d0c409cd49 metadata.xml 160
MD5 8fcd6badaddb9a5e7c450df55328db4e ChangeLog 2062
MD5 1254611280cd18cac6f13a32910f6223 files/digest-bittornado-0.3.1 68
+MD5 42424b1ceb30e798c909cd377fbe78f8 files/digest-bittornado-0.3.2 68
MD5 28f41e964823c678f90c061fa88bcbe5 files/digest-bittornado-0.3.0 68
diff --git a/net-p2p/bittornado/bittornado-0.3.2.ebuild b/net-p2p/bittornado/bittornado-0.3.2.ebuild
new file mode 100644
index 000000000000..bf61c070b77d
--- /dev/null
+++ b/net-p2p/bittornado/bittornado-0.3.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/bittornado-0.3.2.ebuild,v 1.1 2004/06/10 09:52:46 mholzer Exp $
+
+inherit distutils
+inherit eutils
+
+MY_PN="BitTornado"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="TheShad0w's experimental BitTorrent client"
+HOMEPAGE="http://www.bittornado.com/"
+SRC_URI="http://e.scarywater.net/bt/download/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="X"
+
+RDEPEND="X? ( >=dev-python/wxPython-2.2 )
+ >=dev-lang/python-2.0
+ !virtual/bittorrent"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.0.5"
+
+PROVIDE="virtual/bittorrent"
+
+S="${WORKDIR}/${MY_PN}-CVS"
+PIXMAPLOC="/usr/share/pixmaps/bittornado"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # fixes wrong icons path
+ sed -i "s:os.path.abspath(os.path.dirname(os.path.realpath(sys.argv\[0\]))):\"${PIXMAPLOC}/\":" btdownloadgui.py
+}
+
+src_install() {
+ distutils_src_install
+
+ dodir etc
+ cp -a /etc/mailcap ${D}/etc/
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use X; then
+ dodir ${PIXMAPLOC}
+ insinto ${PIXMAPLOC}
+ doins *.ico *.gif
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ rm ${D}/usr/bin/*gui.py
+ fi
+}
+
diff --git a/net-p2p/bittornado/files/digest-bittornado-0.3.2 b/net-p2p/bittornado/files/digest-bittornado-0.3.2
new file mode 100644
index 000000000000..3fb37ebf5633
--- /dev/null
+++ b/net-p2p/bittornado/files/digest-bittornado-0.3.2
@@ -0,0 +1 @@
+MD5 469a6e4283af4636c729b70ce89a425a BitTornado-0.3.2.tar.gz 175324