summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Laue <brad@gentoo.org>2005-02-26 07:45:04 +0000
committerBrad Laue <brad@gentoo.org>2005-02-26 07:45:04 +0000
commit023cb22bd7ec765ae5648969d2be66cb285fa50e (patch)
tree9588f9da9af7ab0f0f89fb9d196827af5537d3a0
parentversion bump (diff)
downloadgentoo-2-023cb22bd7ec765ae5648969d2be66cb285fa50e.tar.gz
gentoo-2-023cb22bd7ec765ae5648969d2be66cb285fa50e.tar.bz2
gentoo-2-023cb22bd7ec765ae5648969d2be66cb285fa50e.zip
Update to 1.0.1
(Portage version: 2.0.51-r15)
-rw-r--r--net-www/mozilla-firefox/ChangeLog11
-rw-r--r--net-www/mozilla-firefox/files/digest-mozilla-firefox-1.0.11
-rw-r--r--net-www/mozilla-firefox/files/svg-cairo-0.3.0-fix.patch22
-rw-r--r--net-www/mozilla-firefox/mozilla-firefox-1.0.1.ebuild193
4 files changed, 226 insertions, 1 deletions
diff --git a/net-www/mozilla-firefox/ChangeLog b/net-www/mozilla-firefox/ChangeLog
index 508783d0fc6e..b89da8e186ac 100644
--- a/net-www/mozilla-firefox/ChangeLog
+++ b/net-www/mozilla-firefox/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-www/mozilla-firefox
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/ChangeLog,v 1.96 2005/02/18 23:26:30 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/ChangeLog,v 1.97 2005/02/26 07:45:04 brad Exp $
+
+*mozilla-firefox-1.0.1 (26 Feb 2005)
+
+ 26 Feb 2005; Brad Laue <brad@gentoo.org> +files/svg-cairo-0.3.0-fix.patch,
+ +mozilla-firefox-1.0.1.ebuild:
+ Bump to 1.0.1, which features stability and security enhancements (and whiter,
+ brighter web pages!)
+
+ Also, fix compilation of SVG support with cairo 0.3.0.
19 Feb 2005; Heinrich Wendel <lanius@gentoo.org>
mozilla-firefox-1.0-r3.ebuild:
diff --git a/net-www/mozilla-firefox/files/digest-mozilla-firefox-1.0.1 b/net-www/mozilla-firefox/files/digest-mozilla-firefox-1.0.1
new file mode 100644
index 000000000000..d93a4c1b13de
--- /dev/null
+++ b/net-www/mozilla-firefox/files/digest-mozilla-firefox-1.0.1
@@ -0,0 +1 @@
+MD5 ebaea974fea9460ab7050fff76b41cb1 firefox-1.0.1-source.tar.bz2 32671529
diff --git a/net-www/mozilla-firefox/files/svg-cairo-0.3.0-fix.patch b/net-www/mozilla-firefox/files/svg-cairo-0.3.0-fix.patch
new file mode 100644
index 000000000000..9d1f0d830559
--- /dev/null
+++ b/net-www/mozilla-firefox/files/svg-cairo-0.3.0-fix.patch
@@ -0,0 +1,22 @@
+diff -aur mozilla-orig/layout/svg/renderer/src/cairo/nsSVGCairoCanvas.cpp mozilla/layout/svg/renderer/src/cairo/nsSVGCairoCanvas.cpp
+--- mozilla-orig/layout/svg/renderer/src/cairo/nsSVGCairoCanvas.cpp 2004-02-10 15:18:09.000000000 -0500
++++ mozilla/layout/svg/renderer/src/cairo/nsSVGCairoCanvas.cpp 2005-02-23 20:25:32.240459288 -0500
+@@ -50,6 +50,7 @@
+ #include "nsRenderingContextGTK.h"
+ #include <gdk/gdkx.h>
+ #include <cairo.h>
++#include <cairo-xlib.h>
+
+ /**
+ * \addtogroup cairo_renderer Cairo Rendering Engine
+diff -aur mozilla-orig/layout/svg/renderer/src/cairo/nsSVGCairoGlyphMetrics.cpp mozilla/layout/svg/renderer/src/cairo/nsSVGCairoGlyphMetrics.cpp
+--- mozilla-orig/layout/svg/renderer/src/cairo/nsSVGCairoGlyphMetrics.cpp 2004-03-16 16:40:07.000000000 -0500
++++ mozilla/layout/svg/renderer/src/cairo/nsSVGCairoGlyphMetrics.cpp 2005-02-23 20:25:09.538910448 -0500
+@@ -51,6 +51,7 @@
+ #include "nsSVGTypeCIDs.h"
+ #include "nsIComponentManager.h"
+ #include <cairo.h>
++#include <stdlib.h>
+
+ /**
+ * \addtogroup gdiplus_renderer Cairo Rendering Engine
diff --git a/net-www/mozilla-firefox/mozilla-firefox-1.0.1.ebuild b/net-www/mozilla-firefox/mozilla-firefox-1.0.1.ebuild
new file mode 100644
index 000000000000..47823f88cebd
--- /dev/null
+++ b/net-www/mozilla-firefox/mozilla-firefox-1.0.1.ebuild
@@ -0,0 +1,193 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/mozilla-firefox-1.0.1.ebuild,v 1.1 2005/02/26 07:45:04 brad Exp $
+
+inherit makeedit flag-o-matic gcc nsplugins eutils mozconfig mozilla-launcher
+
+S=${WORKDIR}/mozilla
+
+DESCRIPTION="The Mozilla Firefox Web Browser"
+HOMEPAGE="http://www.mozilla.org/projects/firefox/"
+MY_PV=${PV/_rc/rc}
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${MY_PV}/source/firefox-${MY_PV}-source.tar.bz2"
+
+LICENSE="MPL-1.1 NPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86 ~hppa"
+IUSE="java mozsvg"
+
+# xrender.pc appeared for the first time in xorg-x11-6.7.0-r2
+# and is required to build with support for cairo. #71504
+RDEPEND="java? ( virtual/jre )
+ >=media-libs/libmng-1.0.0
+ mozsvg? (
+ >=x11-base/xorg-x11-6.7.0-r2
+ x11-libs/cairo
+ )"
+
+DEPEND="${RDEPEND}
+ java? ( >=dev-java/java-config-0.2.0 )"
+
+# Needed by src_compile() and src_install().
+# Would do in pkg_setup but that loses the export attribute, they
+# become pure shell variables.
+export MOZ_PHOENIX=1
+
+src_unpack() {
+ unpack firefox-${MY_PV}-source.tar.bz2 || die "unpack failed"
+ cd ${S} || die "cd failed"
+
+ # alpha stubs patch from lfs project.
+ # <taviso@gentoo.org> (26 Jun 2003)
+ use alpha && epatch ${FILESDIR}/mozilla-1.3-alpha-stubs.patch
+
+ # hppa patches from Ivar <orskaug@stud.ntnu.no>
+ # <gmsoft@gentoo.org> (22 Dec 2004)
+ epatch ${FILESDIR}/mozilla-hppa.patch
+
+ # patch out ft caching code since the API changed between releases of
+ # freetype; this enables freetype-2.1.8+ compat.
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=234035#c65
+ epatch ${FILESDIR}/mozilla-firefox-1.0-4ft2.patch
+
+ # patch to fix separate character on euro keyboards, bug 68995
+ epatch ${FILESDIR}/mozilla-firefox-1.0-kp_separator.patch
+
+ if has_version '>=x11-libs/cairo-0.3.0'; then
+ epatch ${FILESDIR}/svg-cairo-0.3.0-fix.patch
+ fi
+}
+
+src_compile() {
+ ####################################
+ #
+ # mozconfig, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+
+ mozconfig_init
+
+ # Bug 60668: Galeon doesn't build without oji enabled, so enable it
+ # regardless of java setting.
+ mozconfig_annotate '' --enable-oji --enable-mathml
+
+ # Other ff-specific settings
+ mozconfig_use_enable mozdevelop jsd
+ mozconfig_use_enable mozdevelop xpctools
+ mozconfig_use_extension mozdevelop venkman
+ mozconfig_use_enable gnome gnomevfs
+ mozconfig_use_extension gnome gnomevfs
+ mozconfig_use_enable mozsvg svg
+ mozconfig_use_enable mozsvg svg-renderer-cairo
+ mozconfig_annotate '' --with-default-mozilla-five-home=/usr/lib/MozillaFirefox
+
+ # Finalize and report settings
+ mozconfig_final
+
+ # hardened GCC uses -fstack-protector-all by default, and this breaks
+ # firefox.
+ has_hardened && append-flags -fno-stack-protector-all
+ replace-flags -fstack-protector-all -fstack-protector
+
+ ####################################
+ #
+ # Configure and build Firefox
+ #
+ ####################################
+
+ # ./configure picks up the mozconfig stuff
+ econf
+
+ # This removes extraneous CFLAGS from the Makefiles to reduce RAM
+ # requirements while compiling
+ edit_makefiles
+
+ emake MOZ_PHOENIX=1 || die
+}
+
+src_install() {
+ # Plugin path creation
+ PLUGIN_DIR="/usr/lib/nsbrowser/plugins"
+ dodir ${PLUGIN_DIR}
+
+ dodir /usr/lib
+ dodir /usr/lib/MozillaFirefox
+ cp -RL --no-preserve=links ${S}/dist/bin/* ${D}/usr/lib/MozillaFirefox
+
+ #fix permissions
+ chown -R root:root ${D}/usr/lib/MozillaFirefox
+
+ # Plugin path setup (rescuing the existent plugins)
+ src_mv_plugins /usr/lib/MozillaFirefox/plugins
+
+ dodir /usr/bin
+ dosym /usr/libexec/mozilla-launcher /usr/bin/firefox
+ insinto /etc/env.d
+ doins ${FILESDIR}/10MozillaFirefox
+
+ # Fix icons to look the same everywhere
+ insinto /usr/lib/MozillaFirefox/icons
+ doins ${S}/build/package/rpm/SOURCES/mozicon16.xpm
+ doins ${S}/build/package/rpm/SOURCES/mozicon50.xpm
+
+ # Install icon and .desktop for menu entry
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/icon/firefox-icon.png
+ # Fix bug 54179: Install .desktop file into /usr/share/applications
+ # instead of /usr/share/gnome/apps/Internet (18 Jun 2004 agriffis)
+ insinto /usr/share/applications
+ doins ${FILESDIR}/icon/mozillafirefox.desktop
+
+ # Normally firefox-0.9 must be run as root once before it can be
+ # run as a normal user. Drop in some initialized files to avoid
+ # this.
+ einfo "Extracting firefox-${PV} initialization files"
+ tar xjpf ${FILESDIR}/firefox-0.9-init.tar.bz2 -C ${D}/usr/lib/MozillaFirefox
+}
+
+pkg_preinst() {
+ export MOZILLA_FIVE_HOME=${ROOT}/usr/lib/MozillaFirefox
+
+ # Remove the old plugins dir
+ pkg_mv_plugins /usr/lib/MozillaFirefox/plugins
+
+ # Remove entire installed instance to prevent all kinds of
+ # problems... see bug 44772 for example
+ rm -rf "${MOZILLA_FIVE_HOME}"
+}
+
+pkg_postinst() {
+ export MOZILLA_FIVE_HOME="${ROOT}/usr/lib/MozillaFirefox"
+
+ # Needed to update the run time bindings for REGXPCOM
+ # (do not remove next line!)
+ env-update
+
+ # Register Components and Chrome
+ #
+ # Bug 67031: Set HOME=~root in case this is being emerged via sudo.
+ # Otherwise the following commands will create ~/.mozilla owned by root
+ # and 700 perms, which makes subsequent execution of firefox by user
+ # impossible.
+ einfo "Registering Components and Chrome..."
+ HOME=~root LD_LIBRARY_PATH=/usr/lib/MozillaFirefox ${MOZILLA_FIVE_HOME}/regxpcom
+ HOME=~root LD_LIBRARY_PATH=/usr/lib/MozillaFirefox ${MOZILLA_FIVE_HOME}/regchrome
+
+ # Fix permissions of component registry
+ chmod 0644 ${MOZILLA_FIVE_HOME}/components/compreg.dat
+
+ # Fix directory permissions
+ find ${MOZILLA_FIVE_HOME}/ -type d -perm 0700 -exec chmod 0755 {} \; || :
+
+ # Fix permissions on chrome files
+ find ${MOZILLA_FIVE_HOME}/chrome/ -name '*.rdf' -exec chmod 0644 {} \; || :
+
+ # This should be called in the postinst and postrm of all the
+ # mozilla, mozilla-bin, firefox, firefox-bin, thunderbird and
+ # thunderbird-bin ebuilds.
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}