summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-01 21:13:26 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-01 21:13:26 +0000
commit04b68de4ac8cec723dd068792f7e47373def562d (patch)
tree7f2e53e5d415fee96dca3f80a68a2c44a259a14c
parentremove stale ebuild with security issue (diff)
downloadgentoo-2-04b68de4ac8cec723dd068792f7e47373def562d.tar.gz
gentoo-2-04b68de4ac8cec723dd068792f7e47373def562d.tar.bz2
gentoo-2-04b68de4ac8cec723dd068792f7e47373def562d.zip
Delete older ebuilds.
(Portage version: 2.2.0_alpha11_p6/cvs/Linux x86_64)
-rw-r--r--dev-python/pycuda/ChangeLog9
-rw-r--r--dev-python/pycuda/files/pycuda-0.93-fix-include-path.patch41
-rw-r--r--dev-python/pycuda/pycuda-0.92.ebuild44
-rw-r--r--dev-python/pycuda/pycuda-0.93.ebuild56
4 files changed, 7 insertions, 143 deletions
diff --git a/dev-python/pycuda/ChangeLog b/dev-python/pycuda/ChangeLog
index 067e1b0eee35..e1b4cc378f71 100644
--- a/dev-python/pycuda/ChangeLog
+++ b/dev-python/pycuda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pycuda
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/ChangeLog,v 1.8 2010/12/12 19:54:08 spock Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/ChangeLog,v 1.9 2011/01/01 21:13:26 arfrever Exp $
+
+ 01 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -pycuda-0.92.ebuild, -pycuda-0.93.ebuild,
+ -files/pycuda-0.93-fix-include-path.patch:
+ Delete.
12 Dec 2010; Michał Januszewski <spock@gentoo.org> pycuda-0.94.2.ebuild,
pycuda-9999.ebuild:
diff --git a/dev-python/pycuda/files/pycuda-0.93-fix-include-path.patch b/dev-python/pycuda/files/pycuda-0.93-fix-include-path.patch
deleted file mode 100644
index ab765ae19479..000000000000
--- a/dev-python/pycuda/files/pycuda-0.93-fix-include-path.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff -r -u -w pycuda-0.93-old/pycuda/compiler.py pycuda-0.93/pycuda/compiler.py
---- pycuda-0.93-old/pycuda/compiler.py 2009-05-28 07:45:53.000000000 -0500
-+++ pycuda-0.93/pycuda/compiler.py 2009-08-12 15:49:00.000000000 -0500
-@@ -115,14 +115,25 @@
- file, pathname, descr = find_module("pycuda")
-
- from os.path import join, exists
-- installed_path = join(pathname, "..", "include", "cuda")
-+ installed_path = join(pathname, "..", "include", "pycuda")
- development_path = join(pathname, "..", "src", "cuda")
-
-+ usr_path = "/usr/include/pycuda"
-+ usr_local_path = "/usr/local/include/pycuda"
-+
-+ import sys
-+
- if exists(installed_path):
- return installed_path
- elif exists(development_path):
- return development_path
- else:
-+ if sys.platform == "linux2":
-+ if exists(usr_path):
-+ return usr_path
-+ elif exists(usr_local_path):
-+ return usr_local_path
-+
- raise RuntimeError("could not find path PyCUDA's C header files")
-
-
-diff -r -u -w pycuda-0.93-old/setup.py pycuda-0.93/setup.py
---- pycuda-0.93-old/setup.py 2009-08-10 08:17:18.000000000 -0500
-+++ pycuda-0.93/setup.py 2009-08-12 15:47:22.000000000 -0500
-@@ -314,7 +314,7 @@
- ],
-
- data_files=[
-- ("include/cuda", glob.glob("src/cuda/*.hpp"))
-+ ("include/pycuda", glob.glob("src/cuda/*.hpp"))
- ],
- )
diff --git a/dev-python/pycuda/pycuda-0.92.ebuild b/dev-python/pycuda/pycuda-0.92.ebuild
deleted file mode 100644
index 387495182d62..000000000000
--- a/dev-python/pycuda/pycuda-0.92.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/pycuda-0.92.ebuild,v 1.2 2010/10/17 21:50:20 arfrever Exp $
-
-EAPI="2"
-
-inherit distutils
-
-DESCRIPTION="Python wrapper for NVIDIA CUDA"
-HOMEPAGE="http://mathema.tician.de/software/pycuda"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-RDEPEND="dev-python/pytools
- dev-libs/boost[python]
- >=dev-util/nvidia-cuda-toolkit-2.0
- >=dev-python/numpy-1.0.4"
-DEPEND="${RDEPEND}"
-
-src_configure()
-{
- ./configure.py --cuda-root="${ROOT}opt/cuda" --boost-python-libname=boost_python-mt
-}
-
-src_install()
-{
- distutils_src_install
- insinto /usr/share/doc/${PF}
- if use examples; then
- doins -r examples || die
- fi
-}
-
-pkg_postinst()
-{
- distutils_pkg_postinst
- if use examples; then
- elog "Some of the examples provided by this package require dev-python/matplotlib."
- fi
-}
diff --git a/dev-python/pycuda/pycuda-0.93.ebuild b/dev-python/pycuda/pycuda-0.93.ebuild
deleted file mode 100644
index 6958bec66983..000000000000
--- a/dev-python/pycuda/pycuda-0.93.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/pycuda-0.93.ebuild,v 1.4 2010/10/17 21:50:20 arfrever Exp $
-
-EAPI="2"
-
-inherit distutils eutils
-
-DESCRIPTION="Python wrapper for NVIDIA CUDA"
-HOMEPAGE="http://mathema.tician.de/software/pycuda http://pypi.python.org/pypi/pycuda"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples opengl"
-
-RDEPEND="dev-python/pytools
- dev-libs/boost[python]
- >=dev-util/nvidia-cuda-toolkit-2.0
- >=dev-python/numpy-1.0.4
- virtual/opengl"
-DEPEND="${RDEPEND}"
-
-src_prepare()
-{
- epatch "${FILESDIR}"/${P}-fix-include-path.patch
-}
-
-src_configure()
-{
- local myopts=""
- use opengl && myopts="${myopts} --cuda-enable-gl"
-
- ./configure.py --cuda-root="${ROOT}opt/cuda" \
- --boost-python-libname=boost_python-mt \
- --boost-thread-libname=boost_thread-mt \
- ${myopts}
-}
-
-src_install()
-{
- distutils_src_install
- insinto /usr/share/doc/${PF}
- if use examples; then
- doins -r examples || die
- fi
-}
-
-pkg_postinst()
-{
- distutils_pkg_postinst
- if use examples; then
- elog "Some of the examples provided by this package require dev-python/matplotlib."
- fi
-}