summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-09-05 17:03:48 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-09-05 17:03:48 +0000
commit04f3b679c652318dbbf53791801494cce09cac43 (patch)
tree9ab29a61218ec66d4e9365be6f860baf13b37c1d
parentfixed typo (diff)
downloadgentoo-2-04f3b679c652318dbbf53791801494cce09cac43.tar.gz
gentoo-2-04f3b679c652318dbbf53791801494cce09cac43.tar.bz2
gentoo-2-04f3b679c652318dbbf53791801494cce09cac43.zip
Closing #58661
-rw-r--r--games-mud/mcl/ChangeLog6
-rw-r--r--games-mud/mcl/files/mcl-0.53.00-gcc34.patch12
-rw-r--r--games-mud/mcl/mcl-0.53.00.ebuild3
3 files changed, 19 insertions, 2 deletions
diff --git a/games-mud/mcl/ChangeLog b/games-mud/mcl/ChangeLog
index 6645e3da16e6..6f32ddb70967 100644
--- a/games-mud/mcl/ChangeLog
+++ b/games-mud/mcl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-mud/mcl
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/mcl/ChangeLog,v 1.8 2004/08/20 07:50:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/mcl/ChangeLog,v 1.9 2004/09/05 17:03:48 aliz Exp $
+
+ 05 Sep 2004; Daniel Ahlberg <aliz@gentoo.org> mcl-0.53.00.ebuild,
+ files/mcl-0.53.00-gcc34.patch:
+ Added gcc34 patch by Thomas Weidner <3.14159@gmx.net> in #58661.
20 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org>
+files/0.53.00-vc.patch, mcl-0.53.00.ebuild:
diff --git a/games-mud/mcl/files/mcl-0.53.00-gcc34.patch b/games-mud/mcl/files/mcl-0.53.00-gcc34.patch
new file mode 100644
index 000000000000..f25d9c4eb925
--- /dev/null
+++ b/games-mud/mcl/files/mcl-0.53.00-gcc34.patch
@@ -0,0 +1,12 @@
+esdiff -ru mcl-0.53.00/InputLine.cc mcl-0.53.00.new/InputLine.cc
+--- mcl-0.53.00/InputLine.cc 2003-09-29 12:37:49.000000000 +0200
++++ mcl-0.53.00.new/InputLine.cc 2004-07-28 16:40:13.025986752 +0200
+@@ -27,7 +27,7 @@
+
+ History::History(int _id) : id (_id), current(0) {
+ max_history = config->getOption(opt_histsize);
+- strings = new (char*)[max_history];
++ strings = new char*[max_history];
+ timestamps = new time_t[max_history];
+
+ // Hmm, not sure about this
diff --git a/games-mud/mcl/mcl-0.53.00.ebuild b/games-mud/mcl/mcl-0.53.00.ebuild
index f4d2444c055b..079a01aa28f3 100644
--- a/games-mud/mcl/mcl-0.53.00.ebuild
+++ b/games-mud/mcl/mcl-0.53.00.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/mcl/mcl-0.53.00.ebuild,v 1.8 2004/08/20 07:50:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/mcl/mcl-0.53.00.ebuild,v 1.9 2004/09/05 17:03:48 aliz Exp $
inherit eutils gnuconfig games
@@ -24,6 +24,7 @@ src_unpack() {
epatch "${FILESDIR}/${P}-fPIC.patch"
epatch "${FILESDIR}/${PV}-vc.patch"
+ epatch "${FILESDIR}/${P}-gcc34.patch"
sed -i \
-e "/MCL_LIBRARY_PATH/ s:/usr/lib/mcl:${GAMES_LIBDIR}/${PN}:" \