summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-03-22 16:17:06 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-03-22 16:17:06 +0000
commit097789f3920940b88ffc09e4591045ffcf236ce4 (patch)
tree2ccc0f291b02a4aa8aa631be103ca8906d84d823
parentAdd EAPI3 support to eautoreconf call - this commit aligns xfconf.eclass to t... (diff)
downloadgentoo-2-097789f3920940b88ffc09e4591045ffcf236ce4.tar.gz
gentoo-2-097789f3920940b88ffc09e4591045ffcf236ce4.tar.bz2
gentoo-2-097789f3920940b88ffc09e4591045ffcf236ce4.zip
Version bump to 1.5.8 Bug #310143
(Portage version: 2.1.7.17/cvs/Linux x86_64)
-rw-r--r--media-libs/libjsw/ChangeLog10
-rw-r--r--media-libs/libjsw/files/libjsw-1.5.8-build.patch110
-rw-r--r--media-libs/libjsw/libjsw-1.5.8.ebuild56
3 files changed, 174 insertions, 2 deletions
diff --git a/media-libs/libjsw/ChangeLog b/media-libs/libjsw/ChangeLog
index 03066e60d3f2..9294818f571b 100644
--- a/media-libs/libjsw/ChangeLog
+++ b/media-libs/libjsw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libjsw
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libjsw/ChangeLog,v 1.15 2007/08/13 21:00:45 dertobi123 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libjsw/ChangeLog,v 1.16 2010/03/22 16:17:05 tupone Exp $
+
+*libjsw-1.5.8 (22 Mar 2010)
+
+ 22 Mar 2010; Alfredo Tupone <tupone@gentoo.org> +libjsw-1.5.8.ebuild,
+ +files/libjsw-1.5.8-build.patch:
+ Version bump to 1.5.8 Bug #310143 by Lars Wendler (Polynomial-C)
13 Aug 2007; Tobias Scherbaum <dertobi123@gentoo.org> libjsw-1.5.6.ebuild:
ppc. stable
diff --git a/media-libs/libjsw/files/libjsw-1.5.8-build.patch b/media-libs/libjsw/files/libjsw-1.5.8-build.patch
new file mode 100644
index 000000000000..d786195058c1
--- /dev/null
+++ b/media-libs/libjsw/files/libjsw-1.5.8-build.patch
@@ -0,0 +1,110 @@
+--- libjsw/Makefile.old 2010-03-22 17:03:21.000000000 +0100
++++ libjsw/Makefile 2010-03-22 17:07:02.000000000 +0100
+@@ -51,10 +51,10 @@
+ # to debug the program.
+ #
+
+-CFLAGS = -Wall -O2 -g
+-CFLAGS += -ffast-math
++CFLAGS += -fPIC
++CXXFLAGS += -fPIC
+
+-CPPFLAGS = -D__cplusplus
++CPPFLAGS += -D__cplusplus
+
+
+ # ########################################################################
+@@ -82,11 +82,9 @@
+ OBJ_C = $(SRC_C:.c=.o)
+ OBJ_CPP = $(SRC_CPP:.cpp=.o)
+ .c.o:
+- @echo "Compiling module $*.o"
+- @+$(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
++ $(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
+ .cpp.o:
+- @echo "Compiling module $*.o"
+- @+$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
++ $(CPP) -c $*.cpp $(INC_DIRS) $(CXXFLAGS) $(CPPFLAGS)
+
+
+ # ########################################################################
+@@ -95,13 +93,7 @@
+ $(LIB): prebuild modules postbuild
+
+ modules: $(OBJ_C) $(OBJ_CPP)
+- @echo -n "Linking modules..."
+- @$(CC) $(OBJ_C) $(OBJ_CPP) -Wl,-soname=$(LIB) -shared -o $(LIB) $(LIBS) $(LIB_DIRS)
+- @echo -n " "
+- @$(RM) $(RMFLAGS) $(LIBPFX).so
+- @$(LINK) -s $(LIB) $(LIBPFX).so
+- @$(LINK) -s $(LIB) $(LIBPFX).so.1
+- @-$(LS) $(LSFLAGS) $(LIB)
++ $(CPP) $(OBJ_C) $(OBJ_CPP) -o $(LIB) $(LDFLAGS) $(LIBS) $(LIB_DIRS)
+
+ prebuild:
+ @echo "Building library \"$(LIB)\"..."
+--- jscalibrator/Makefile.old 2010-03-22 17:08:07.000000000 +0100
++++ jscalibrator/Makefile 2010-03-22 17:11:26.000000000 +0100
+@@ -59,9 +59,6 @@
+ #CFLAGS = -Wall -O -g \
+ # `gtk-config --cflags`
+
+-CFLAGS = -Wall -O6 -fomit-frame-pointer -funroll-loops -ffast-math \
+- `gtk-config --cflags`
+-
+ CPPFLAGS = -D__cplusplus
+
+
+@@ -76,7 +73,7 @@
+ # to the LIB line depending on what you have set in the CFLAGS line
+ # farther above.
+ #
+-LIBS = -ljsw `gtk-config --libs`
++LIBS := -ljsw $(shell gtk-config --libs)
+
+ # Library Directories:
+ #
+@@ -85,7 +82,7 @@
+ # Each argument is of the format -L<dir> where <dir> is the full
+ # path to the directory.
+ #
+-LIB_DIRS =
++LIB_DIRS = -L../libjsw
+
+ # Header File Directories:
+ #
+@@ -95,7 +92,7 @@
+ # Each argument is of the format -I<dir> where <dir> is the full
+ # path to the directory.
+ #
+-INC_DIRS =
++INC_DIRS = $(shell gtk-config --cflags) -I../libjsw
+
+
+ # ########################################################################
+@@ -117,11 +114,9 @@
+ OBJ_C = $(SRC_C:.c=.o)
+ OBJ_CPP = $(SRC_CPP:.cpp=.o)
+ .c.o:
+- @echo "Compiling module $*.o"
+- @+$(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
++ $(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
+ .cpp.o:
+- @echo "Compiling module $*.o"
+- @+$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
++ $(CPP) -c $*.cpp $(INC_DIRS) $(CXXFLAGS) $(CPPFLAGS)
+
+
+ # ########################################################################
+@@ -130,10 +125,7 @@
+ $(BIN): prebuild modules postbuild
+
+ modules: $(OBJ_C) $(OBJ_CPP)
+- @echo -n "Linking modules..."
+- @$(CC) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LIBS) $(LIB_DIRS)
+- @echo -n " "
+- @-$(LS) $(LSFLAGS) $(BIN)
++ $(CC) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LDFLAGS) $(LIB_DIRS) $(LIBS)
+
+ prebuild:
+ @echo "Building program \"$(BIN)\"..."
diff --git a/media-libs/libjsw/libjsw-1.5.8.ebuild b/media-libs/libjsw/libjsw-1.5.8.ebuild
new file mode 100644
index 000000000000..847f20db12ed
--- /dev/null
+++ b/media-libs/libjsw/libjsw-1.5.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libjsw/libjsw-1.5.8.ebuild,v 1.1 2010/03/22 16:17:05 tupone Exp $
+EAPI=2
+
+inherit eutils multilib
+
+DESCRIPTION="provide a uniform API and user configuration for joysticks and game controllers"
+HOMEPAGE="http://freshmeat.net/projects/libjsw/"
+SRC_URI="http://wolfsinger.com/~wolfpack/packages/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="gtk"
+
+DEPEND="gtk? ( =x11-libs/gtk+-1.2* )"
+
+src_prepare() {
+ cp include/jsw.h libjsw/
+ epatch "${FILESDIR}"/${P}-build.patch
+ bunzip2 libjsw/man/* jscalibrator/jscalibrator.1.bz2 || die "bunzip failed"
+}
+
+src_compile() {
+ cd libjsw
+ emake || die "main build failed"
+ ln -s libjsw.so.${PV} libjsw.so
+
+ if use gtk ; then
+ cd ../jscalibrator
+ emake || die "jscalibrator failed"
+ fi
+}
+
+src_install() {
+ insinto /usr/include
+ doins include/jsw.h || die "doins jsw.h failed"
+
+ dodoc AUTHORS README
+ docinto jswdemos
+ dodoc jswdemos/*
+
+ cd "${S}"/libjsw
+ dolib.so libjsw.so.${PV} || die "dolib.so"
+ dosym libjsw.so.${PV} /usr/$(get_libdir)/libjsw.so
+ doman man/*
+
+ if use gtk ; then
+ cd "${S}"/jscalibrator
+ dobin jscalibrator || die
+ doman jscalibrator.1
+ insinto /usr/share/${PN}
+ doins -r data/help
+ fi
+}