summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-08-01 00:10:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-08-01 00:10:32 +0000
commit09fae1ce51eee881a2ce5015b4d5ac054e1ec699 (patch)
tree011989c90ae543a80777620f936631dedde8626c
parentStable on amd64 wrt bug #184203 (diff)
downloadgentoo-2-09fae1ce51eee881a2ce5015b4d5ac054e1ec699.tar.gz
gentoo-2-09fae1ce51eee881a2ce5015b4d5ac054e1ec699.tar.bz2
gentoo-2-09fae1ce51eee881a2ce5015b4d5ac054e1ec699.zip
version bump
(Portage version: 2.1.2.9)
-rw-r--r--games-emulation/mamory/ChangeLog8
-rw-r--r--games-emulation/mamory/files/digest-mamory-0.2.243
-rw-r--r--games-emulation/mamory/mamory-0.2.24.ebuild54
3 files changed, 64 insertions, 1 deletions
diff --git a/games-emulation/mamory/ChangeLog b/games-emulation/mamory/ChangeLog
index c520cccf985c..06e26bb5c3be 100644
--- a/games-emulation/mamory/ChangeLog
+++ b/games-emulation/mamory/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/mamory
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mamory/ChangeLog,v 1.20 2007/07/02 21:25:34 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mamory/ChangeLog,v 1.21 2007/08/01 00:10:32 mr_bones_ Exp $
+
+*mamory-0.2.24 (01 Aug 2007)
+
+ 01 Aug 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +mamory-0.2.24.ebuild:
+ version bump
02 Jul 2007; Tristan Heaven <nyhm@gentoo.org> mamory-0.2.23.ebuild:
Make sure the system expat is used
diff --git a/games-emulation/mamory/files/digest-mamory-0.2.24 b/games-emulation/mamory/files/digest-mamory-0.2.24
new file mode 100644
index 000000000000..377e324ad8d0
--- /dev/null
+++ b/games-emulation/mamory/files/digest-mamory-0.2.24
@@ -0,0 +1,3 @@
+MD5 e335590f45d256f6ad4b63a68bca9b9d mamory-0.2.24.tar.gz 514520
+RMD160 62667cc3d2a63e3ed2a5313dadd2ac3e0f3760fe mamory-0.2.24.tar.gz 514520
+SHA256 9b6cfabd18ad30cc7cac39912ee8925d0d35290c608e6e6f0f2513056be462b9 mamory-0.2.24.tar.gz 514520
diff --git a/games-emulation/mamory/mamory-0.2.24.ebuild b/games-emulation/mamory/mamory-0.2.24.ebuild
new file mode 100644
index 000000000000..0838fbc84912
--- /dev/null
+++ b/games-emulation/mamory/mamory-0.2.24.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mamory/mamory-0.2.24.ebuild,v 1.1 2007/08/01 00:10:32 mr_bones_ Exp $
+
+inherit autotools games
+
+DESCRIPTION="ROM management tools and library"
+HOMEPAGE="http://mamory.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/expat"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Make sure the system expat is used
+ sed -i \
+ -e 's/#ifdef.*SYSEXPAT/#if 1/' \
+ mamory/amlxml.c mamory/amlxml.h \
+ || die "sed amlxml failed"
+
+ # Remove hardcoded CFLAGS options
+ sed -i \
+ -e '/AC_ARG_ENABLE(debug,/ {N;N;N;d}' \
+ configure.ac \
+ || die "sed configure.ac failed"
+
+ # Make it possible for eautoreconf to fix fPIC etc.
+ sed -i \
+ -e '/libcommon_la_LDFLAGS= -static/d' \
+ common/Makefile.am \
+ || die "sed Makefile.am failed"
+
+ AT_M4DIR="config" eautoreconf || die
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --includedir=/usr/include || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO
+ dohtml DOCS/mamory.html
+ prepgamesdirs
+}