summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2010-07-03 12:10:38 +0000
committerBenedikt Boehm <hollow@gentoo.org>2010-07-03 12:10:38 +0000
commit0aaf35e9b369d3cef4fd301fa23a7af0222e9d8f (patch)
tree624ce811ccbadee5e29293546d8f195f14e89460
parentinitial ebuild, thanks to Gábor Vészi (diff)
downloadgentoo-2-0aaf35e9b369d3cef4fd301fa23a7af0222e9d8f.tar.gz
gentoo-2-0aaf35e9b369d3cef4fd301fa23a7af0222e9d8f.tar.bz2
gentoo-2-0aaf35e9b369d3cef4fd301fa23a7af0222e9d8f.zip
initial ebuild, thanks to Gábor Vészi
(Portage version: 2.2_rc67/cvs/Linux i686)
-rw-r--r--dev-ruby/ohai/ChangeLog10
-rw-r--r--dev-ruby/ohai/files/ohai-lsb-release.patch20
-rw-r--r--dev-ruby/ohai/metadata.xml5
-rw-r--r--dev-ruby/ohai/ohai-0.5.6.ebuild30
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-ruby/ohai/ChangeLog b/dev-ruby/ohai/ChangeLog
new file mode 100644
index 000000000000..f7181fa54a19
--- /dev/null
+++ b/dev-ruby/ohai/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/ohai
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ChangeLog,v 1.1 2010/07/03 12:10:38 hollow Exp $
+
+*ohai-0.5.6 (03 Jul 2010)
+
+ 03 Jul 2010; Benedikt Böhm <hollow@gentoo.org> +ohai-0.5.6.ebuild,
+ +files/ohai-lsb-release.patch, +metadata.xml:
+ initial ebuild, thanks to Gábor Vészi
+
diff --git a/dev-ruby/ohai/files/ohai-lsb-release.patch b/dev-ruby/ohai/files/ohai-lsb-release.patch
new file mode 100644
index 000000000000..e67e4f61dd12
--- /dev/null
+++ b/dev-ruby/ohai/files/ohai-lsb-release.patch
@@ -0,0 +1,20 @@
+--- a/lib/ohai/plugins/linux/lsb.rb
++++ b/lib/ohai/plugins/linux/lsb.rb
+@@ -23,13 +23,13 @@ lsb Mash.new
+ begin
+ File.open("/etc/lsb-release").each do |line|
+ case line
+- when /^DISTRIB_ID=(.+)$/
++ when /^DISTRIB_ID=["']?(.+?)["']?$/
+ lsb[:id] = $1
+- when /^DISTRIB_RELEASE=(.+)$/
++ when /^DISTRIB_RELEASE=["']?(.+?)["']?$/
+ lsb[:release] = $1
+- when /^DISTRIB_CODENAME=(.+)$/
++ when /^DISTRIB_CODENAME=["']?(.+?)["']?$/
+ lsb[:codename] = $1
+- when /^DISTRIB_DESCRIPTION=(.+)$/
++ when /^DISTRIB_DESCRIPTION=["']?(.+?)["']?$/
+ lsb[:description] = $1
+ end
+ end
diff --git a/dev-ruby/ohai/metadata.xml b/dev-ruby/ohai/metadata.xml
new file mode 100644
index 000000000000..0040b1162894
--- /dev/null
+++ b/dev-ruby/ohai/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/ohai/ohai-0.5.6.ebuild b/dev-ruby/ohai/ohai-0.5.6.ebuild
new file mode 100644
index 000000000000..663857a44b42
--- /dev/null
+++ b/dev-ruby/ohai/ohai-0.5.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ohai-0.5.6.ebuild,v 1.1 2010/07/03 12:10:38 hollow Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ohai profiles your system and emits JSON"
+HOMEPAGE="http://wiki.opscode.com/display/ohai"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/extlib
+ <=dev-ruby/json-1.4.2
+ dev-ruby/mixlib-cli
+ dev-ruby/mixlib-config
+ dev-ruby/mixlib-log
+ dev-ruby/systemu"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}/ohai-lsb-release.patch"
+}