summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-10-14 23:29:58 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-10-14 23:29:58 +0000
commit0ab8fe0fde84c0a3122692444b4f3eccfe84dd80 (patch)
treee9cc87289b988a64cf3a4de37d77450efadf8cfe
parentbump to 4.6.0 (diff)
downloadgentoo-2-0ab8fe0fde84c0a3122692444b4f3eccfe84dd80.tar.gz
gentoo-2-0ab8fe0fde84c0a3122692444b4f3eccfe84dd80.tar.bz2
gentoo-2-0ab8fe0fde84c0a3122692444b4f3eccfe84dd80.zip
revision bump for fixed Emacs support, see bug 193427
(Portage version: 2.1.3.9)
-rw-r--r--app-misc/cdargs/ChangeLog8
-rw-r--r--app-misc/cdargs/cdargs-1.35-r1.ebuild62
-rw-r--r--app-misc/cdargs/files/50cdargs-gentoo.el8
-rw-r--r--app-misc/cdargs/files/digest-cdargs-1.35-r13
4 files changed, 80 insertions, 1 deletions
diff --git a/app-misc/cdargs/ChangeLog b/app-misc/cdargs/ChangeLog
index fbb62684467c..3a1dd4c5d423 100644
--- a/app-misc/cdargs/ChangeLog
+++ b/app-misc/cdargs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/cdargs
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/cdargs/ChangeLog,v 1.14 2007/02/21 22:23:03 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cdargs/ChangeLog,v 1.15 2007/10/14 23:29:57 opfer Exp $
+
+*cdargs-1.35-r1 (14 Oct 2007)
+
+ 14 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
+ +files/50cdargs-gentoo.el, +cdargs-1.35-r1.ebuild:
+ revision bump for fixed Emacs support, see bug 193427
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/app-misc/cdargs/cdargs-1.35-r1.ebuild b/app-misc/cdargs/cdargs-1.35-r1.ebuild
new file mode 100644
index 000000000000..799d5aea060f
--- /dev/null
+++ b/app-misc/cdargs/cdargs-1.35-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cdargs/cdargs-1.35-r1.ebuild,v 1.1 2007/10/14 23:29:57 opfer Exp $
+
+inherit elisp-common
+
+DESCRIPTION="Bookmarks and browser for the shell builtin cd command"
+HOMEPAGE="http://www.skamphausen.de/software/cdargs"
+SRC_URI="http://www.skamphausen.de/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="emacs"
+
+DEPEND="sys-libs/ncurses
+ emacs? ( virtual/emacs )"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+
+ if use emacs; then
+ elisp-compile contrib/cdargs.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README THANKS TODO AUTHORS
+
+ cd "${S}/contrib"
+ insinto /usr/share/cdargs
+ doins cdargs-bash.sh cdargs-tcsh.csh \
+ || die "failed to install contrib scripts"
+ if use emacs ; then
+ elisp-install ${PN} cdargs.{el,elc} || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+
+ echo
+ elog "Add the following line to your ~/.bashrc to enable cdargs helper"
+ elog "functions/aliases in your environment:"
+ elog "[ -f /usr/share/cdargs/cdargs-bash.sh ] && \\ "
+ elog " source /usr/share/cdargs/cdargs-bash.sh"
+ elog
+ elog "Users of tcshell will find cdargs-tcsh.csh there with a reduced"
+ elog "feature set. See INSTALL file in the documentation directory for"
+ elog "more information."
+ echo
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/app-misc/cdargs/files/50cdargs-gentoo.el b/app-misc/cdargs/files/50cdargs-gentoo.el
new file mode 100644
index 000000000000..f9203b308ce0
--- /dev/null
+++ b/app-misc/cdargs/files/50cdargs-gentoo.el
@@ -0,0 +1,8 @@
+
+;;; app-misc/cdargs site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'cdargs "cdargs"
+ "Change the current working directory using a bookmarks file." t)
+(defalias 'cv 'cdargs)
+(autoload 'cdargs-edit "cdargs" "Simply open the bookmarks file" t)
diff --git a/app-misc/cdargs/files/digest-cdargs-1.35-r1 b/app-misc/cdargs/files/digest-cdargs-1.35-r1
new file mode 100644
index 000000000000..a70cb0b30f0e
--- /dev/null
+++ b/app-misc/cdargs/files/digest-cdargs-1.35-r1
@@ -0,0 +1,3 @@
+MD5 50be618d67f0b9f2439526193c69c567 cdargs-1.35.tar.gz 74103
+RMD160 44cbe35281ab29fa48149792c34afa61d117e33d cdargs-1.35.tar.gz 74103
+SHA256 ee35a8887c2379c9664b277eaed9b353887d89480d5749c9ad957adf9c57ed2c cdargs-1.35.tar.gz 74103