summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-07-11 21:00:20 +0000
committerUlrich Müller <ulm@gentoo.org>2007-07-11 21:00:20 +0000
commit0e59c949a064461837a63de4ed7407261504af45 (patch)
tree35cea9dde69ede1f5696df9698ceed1636f2d7ee
parentStable on sparc wrt security #184815 (diff)
downloadgentoo-2-0e59c949a064461837a63de4ed7407261504af45.tar.gz
gentoo-2-0e59c949a064461837a63de4ed7407261504af45.tar.bz2
gentoo-2-0e59c949a064461837a63de4ed7407261504af45.zip
Improved Emacs support; fixes bug #184506.
(Portage version: 2.1.3_rc7)
-rw-r--r--dev-libs/quantlib/ChangeLog10
-rw-r--r--dev-libs/quantlib/files/50quantlib-gentoo.el6
-rw-r--r--dev-libs/quantlib/files/digest-quantlib-0.3.14-r13
-rw-r--r--dev-libs/quantlib/quantlib-0.3.14-r1.ebuild80
4 files changed, 97 insertions, 2 deletions
diff --git a/dev-libs/quantlib/ChangeLog b/dev-libs/quantlib/ChangeLog
index ff313f0ce6b0..9e9240c62a48 100644
--- a/dev-libs/quantlib/ChangeLog
+++ b/dev-libs/quantlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/quantlib
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/quantlib/ChangeLog,v 1.29 2006/11/07 22:34:50 dev-zero Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/quantlib/ChangeLog,v 1.30 2007/07/11 21:00:20 ulm Exp $
+
+*quantlib-0.3.14-r1 (11 Jul 2007)
+
+ 11 Jul 2007; Ulrich Mueller <ulm@gentoo.org> +files/50quantlib-gentoo.el,
+ +quantlib-0.3.14-r1.ebuild:
+ Improved Emacs support; fixes bug #184506.
*quantlib-0.3.14 (07 Nov 2006)
diff --git a/dev-libs/quantlib/files/50quantlib-gentoo.el b/dev-libs/quantlib/files/50quantlib-gentoo.el
new file mode 100644
index 000000000000..68f6ce003295
--- /dev/null
+++ b/dev-libs/quantlib/files/50quantlib-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; quantlib site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'ql-new-header "quantlib" nil t)
+(autoload 'ql-new-source "quantlib" nil t)
diff --git a/dev-libs/quantlib/files/digest-quantlib-0.3.14-r1 b/dev-libs/quantlib/files/digest-quantlib-0.3.14-r1
new file mode 100644
index 000000000000..adf302d39b8e
--- /dev/null
+++ b/dev-libs/quantlib/files/digest-quantlib-0.3.14-r1
@@ -0,0 +1,3 @@
+MD5 0f9b75124cb5ac5dec4e5715498f3cc4 QuantLib-0.3.14.tar.gz 1881768
+RMD160 53829652e0f35d761a03c5b6fa1bd3aa3bef36ce QuantLib-0.3.14.tar.gz 1881768
+SHA256 ac4160ca19cf7d714b2273ee642cadfc4a563b452aa1ca6dc6f13c9321027f67 QuantLib-0.3.14.tar.gz 1881768
diff --git a/dev-libs/quantlib/quantlib-0.3.14-r1.ebuild b/dev-libs/quantlib/quantlib-0.3.14-r1.ebuild
new file mode 100644
index 000000000000..0aef0179e7b4
--- /dev/null
+++ b/dev-libs/quantlib/quantlib-0.3.14-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/quantlib/quantlib-0.3.14-r1.ebuild,v 1.1 2007/07/11 21:00:20 ulm Exp $
+
+inherit autotools eutils elisp-common
+
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+MY_P=QuantLib-${PV}
+DESCRIPTION="A comprehensive software framework for quantitative finance"
+HOMEPAGE="http://www.quantlib.org"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+SLOT="0"
+LICENSE="BSD"
+IUSE="doc emacs examples"
+
+RDEPEND="dev-libs/boost"
+DEPEND="sys-devel/libtool
+ emacs? ( virtual/emacs )
+ doc? ( app-doc/doxygen )
+ ${RDEPEND}"
+
+SITEFILE=50${PN}-gentoo.el
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e 's/qlintro.tex quantlibheader.tex //' \
+ Docs/Makefile.in || die "sed failed"
+
+ eautoconf
+}
+
+src_compile() {
+ use emacs ||
+ sed -i -e "s/^EMACS=.*/EMACS=no/" configure || die "sed failed"
+
+ econf --with-lispdir="${SITELISP}/${PN}" || die "econf failed"
+ emake || die "emake failed"
+
+ if use doc ; then
+ cd "${S}/Docs"
+ emake docs-online || die "emake docs-html failed"
+ fi
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc *.txt
+
+ if use doc ; then
+ cd "${S}/Docs"
+ dohtml html-online/*
+ fi
+
+ if use examples ; then
+ cd "${S}/Examples"
+ insinto /usr/share/doc/${PF}/examples
+ doins *.txt
+ for example in $(ls -d */); do
+ doins ${example%%/}/*.{cpp,h,txt}
+ done
+ fi
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}