summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-19 03:37:06 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-19 03:37:06 +0000
commit0ec0374582a72a2c1aab2de6b771f846766974a3 (patch)
treee5a4a8d1575d3fda35d47d3a0826dd71ec180016
parentAdded ~sparc keyword. (Manifest recommit) (diff)
downloadgentoo-2-0ec0374582a72a2c1aab2de6b771f846766974a3.tar.gz
gentoo-2-0ec0374582a72a2c1aab2de6b771f846766974a3.tar.bz2
gentoo-2-0ec0374582a72a2c1aab2de6b771f846766974a3.zip
depend on virtual/x11, not x11-base/xfree; only unpack what's needed to compile; use CFLAGS and CC; tidy src_install
-rw-r--r--app-emulation/xtrs/ChangeLog8
-rw-r--r--app-emulation/xtrs/xtrs-4.9.ebuild56
2 files changed, 28 insertions, 36 deletions
diff --git a/app-emulation/xtrs/ChangeLog b/app-emulation/xtrs/ChangeLog
index c271b29ae1b9..8f7b4c40d667 100644
--- a/app-emulation/xtrs/ChangeLog
+++ b/app-emulation/xtrs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/xtrs
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xtrs/ChangeLog,v 1.2 2003/02/12 04:04:38 vapier Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xtrs/ChangeLog,v 1.3 2004/03/19 03:37:06 mr_bones_ Exp $
+
+ 18 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> xtrs-4.9.ebuild:
+ depend on virtual/x11, not x11-base/xfree; only unpack what's needed to
+ compile; use CFLAGS and CC; tidy src_install
*xtrs-4.9 (29 Jun 2002)
diff --git a/app-emulation/xtrs/xtrs-4.9.ebuild b/app-emulation/xtrs/xtrs-4.9.ebuild
index 0ec0872625cc..ff738d0b3905 100644
--- a/app-emulation/xtrs/xtrs-4.9.ebuild
+++ b/app-emulation/xtrs/xtrs-4.9.ebuild
@@ -1,56 +1,44 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xtrs/xtrs-4.9.ebuild,v 1.10 2004/02/20 06:02:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xtrs/xtrs-4.9.ebuild,v 1.11 2004/03/19 03:37:06 mr_bones_ Exp $
-DESCRIPTION="XTRS 4.9.0 - RadioShack TRS80 Emulator, inc. FreeWare ROM & LDOS Image"
+inherit eutils
+
+DESCRIPTION="RadioShack TRS80 Emulator, inc. FreeWare ROM & LDOS Image"
HOMEPAGE="http://www.tim-mann.org/trs80.html"
+SRC_URI="http://home.gwi.net/~plemon/sources/${P}.tar.gz
+ http://home.gwi.net/~plemon/support/disks/xtrs/ld4-631.tar.gz"
+
LICENSE="GPL-2"
KEYWORDS="x86"
SLOT="0"
+IUSE=""
+
DEPEND="sys-libs/ncurses
sys-libs/readline
- x11-base/xfree "
-SRC_URI="http://home.gwi.net/~plemon/sources/xtrs-4.9.tar.gz
- http://home.gwi.net/~plemon/support/disks/xtrs/ld4-631.tar.gz"
-
-S=${WORKDIR}/xtrs-4.9
+ virtual/x11"
src_unpack () {
-
### make doesn't play nicely with the usual ${PREFIX} behaviour, but relies
### on an external Makefile.local to set compiletime options, and default
### behavious. we'll patch it here, to make our install sane.
-
- unpack ${A}
+ unpack ${P}.tar.gz
cd ${WORKDIR}
- patch -p0 < ${FILESDIR}/${P}-gentoo.diff || die "XTRS Patch Failed"
+ epatch "${FILESDIR}/${P}-gentoo.diff"
}
src_compile() {
-
- ### As we mentioned, make ignores any/all prefixes so it's just a standard
- ### make here, the install prefixes were taken care of by our patch above
-
- emake || die "XTRS Make Failed"
+ emake DEBUG="${CFLAGS}" CC="${CC}" || die "emake failed"
}
src_install () {
-
- ### make install, isn't really a 'make install' but a set of 'cp x y' commands
- ### which fails miserablly if the directories dont exist, we'll create them
- ### first to keep everthing smiley happy
-
- dodir /usr/bin
- dodir /usr/share/xtrs
- dodir /usr/share/man/man1
-
- ### and now run the make install script
-
- make install || die "XTRS Make Install Failed"
-
- ### and finally, move the OSS rom images & extract an lsdos image
-
- cp *.hex ${D}/usr/share/xtrs
- cp *.dsk ${D}/usr/share/xtrs/disks
- tar -zxvf ${DISTDIR}/ld4-631.tar.gz -C ${D}/usr/share/xtrs/
+ dodir /usr/bin /usr/share/xtrs/disks /usr/share/man/man1
+ make install || die "make install failed"
+ dodoc README xtrsrom4p.README
+
+ # OSS rom images & an lsdos image
+ tar \
+ -C ${D}/usr/share/xtrs/ \
+ --no-same-owner \
+ -zxvf "${DISTDIR}/ld4-631.tar.gz" || die "tar failed"
}