summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-10-05 06:12:43 +0000
committerMamoru Komachi <usata@gentoo.org>2004-10-05 06:12:43 +0000
commit0f2d3ed2fd065cac9b16a4908d7a6a4dfb1c300f (patch)
tree34a5d5c00e69388898838c0ca7a4a5c2d670fc38
parentrun autoconf/autoheader after applying the acl patch #66299 (Manifest recommit) (diff)
downloadgentoo-2-0f2d3ed2fd065cac9b16a4908d7a6a4dfb1c300f.tar.gz
gentoo-2-0f2d3ed2fd065cac9b16a4908d7a6a4dfb1c300f.tar.bz2
gentoo-2-0f2d3ed2fd065cac9b16a4908d7a6a4dfb1c300f.zip
Initial import. Ebuild submitted by Michael Hordijk <hoffbrinkle@hotmail.com>. This closes bug #65953.
-rw-r--r--app-emacs/vhdl-mode/ChangeLog11
-rw-r--r--app-emacs/vhdl-mode/Manifest3
-rw-r--r--app-emacs/vhdl-mode/files/50vhdl-mode-gentoo.el7
-rw-r--r--app-emacs/vhdl-mode/files/digest-vhdl-mode-3.33.21
-rw-r--r--app-emacs/vhdl-mode/metadata.xml5
-rw-r--r--app-emacs/vhdl-mode/vhdl-mode-3.33.2.ebuild31
6 files changed, 58 insertions, 0 deletions
diff --git a/app-emacs/vhdl-mode/ChangeLog b/app-emacs/vhdl-mode/ChangeLog
new file mode 100644
index 000000000000..9790b582c3a2
--- /dev/null
+++ b/app-emacs/vhdl-mode/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/vhdl-mode
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/vhdl-mode/ChangeLog,v 1.1 2004/10/05 06:12:43 usata Exp $
+
+*vhdl-mode-3.33.2 (05 Oct 2004)
+
+ 05 Oct 2004; Mamoru KOMACHI <usata@gentoo.org> +metadata.xml,
+ +files/50vhdl-mode-gentoo.el, +vhdl-mode-3.33.2.ebuild:
+ Initial import. Ebuild submitted by Michael Hordijk
+ <hoffbrinkle@hotmail.com>. This closes bug #65953.
+
diff --git a/app-emacs/vhdl-mode/Manifest b/app-emacs/vhdl-mode/Manifest
new file mode 100644
index 000000000000..79e25a3a169f
--- /dev/null
+++ b/app-emacs/vhdl-mode/Manifest
@@ -0,0 +1,3 @@
+MD5 a14dc1481fd651f41610f06c97efc042 vhdl-mode-3.33.2.ebuild 769
+MD5 792ddd890b1e4550ece823eb320ddbc3 files/digest-vhdl-mode-3.33.2 68
+MD5 a660a1a260fe78bf0674e003faac9cb7 files/50vhdl-mode-gentoo.el 147
diff --git a/app-emacs/vhdl-mode/files/50vhdl-mode-gentoo.el b/app-emacs/vhdl-mode/files/50vhdl-mode-gentoo.el
new file mode 100644
index 000000000000..841ef7d72da6
--- /dev/null
+++ b/app-emacs/vhdl-mode/files/50vhdl-mode-gentoo.el
@@ -0,0 +1,7 @@
+
+;;;
+;;; VHDL mode
+;;;
+(autoload 'vhdl-mode "vhdl-mode" "VHDL Mode" t)
+(setq auto-mode-alist (cons '("\\.vhdl?\\'" . vhdl-mode) auto-mode-alist))
+
diff --git a/app-emacs/vhdl-mode/files/digest-vhdl-mode-3.33.2 b/app-emacs/vhdl-mode/files/digest-vhdl-mode-3.33.2
new file mode 100644
index 000000000000..4e427ffd6de9
--- /dev/null
+++ b/app-emacs/vhdl-mode/files/digest-vhdl-mode-3.33.2
@@ -0,0 +1 @@
+MD5 183dcb6c47e0e47a18f5fe1bfe0b8f13 vhdl-mode-3.33.2.tar.gz 411236
diff --git a/app-emacs/vhdl-mode/metadata.xml b/app-emacs/vhdl-mode/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/vhdl-mode/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>
diff --git a/app-emacs/vhdl-mode/vhdl-mode-3.33.2.ebuild b/app-emacs/vhdl-mode/vhdl-mode-3.33.2.ebuild
new file mode 100644
index 000000000000..aecd1436db46
--- /dev/null
+++ b/app-emacs/vhdl-mode/vhdl-mode-3.33.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/vhdl-mode/vhdl-mode-3.33.2.ebuild,v 1.1 2004/10/05 06:12:43 usata Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="VHDL-mode for Emacs"
+HOMEPAGE="http://opensource.ethz.ch/emacs/vhdl-mode.html"
+SRC_URI="http://opensource.ethz.ch/emacs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc-macos"
+
+DEPEND="virtual/emacs"
+
+SITEFILE=50vhdl-mode-gentoo.el
+
+# do these manually because we only want vhdl-mode right now. The other .el
+# files are only needed for dependencies that need to be figured out
+src_compile() {
+ /usr/bin/emacs --batch -f batch-byte-compile --no-site-file --no-init-file vhdl-mode.el || die
+}
+
+src_install() {
+ elisp-install ${PN} vhdl-mode.el vhdl-mode.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+