summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-02-04 21:49:38 +0000
committerChris White <chriswhite@gentoo.org>2005-02-04 21:49:38 +0000
commit0ff2923fec48fd4f7a6e36b26696f1f0130bbe0c (patch)
treec90b300f65156d23bdc111a6ac001a723b86bb4e
parentBug #80703, missing dodir. (diff)
downloadgentoo-2-0ff2923fec48fd4f7a6e36b26696f1f0130bbe0c.tar.gz
gentoo-2-0ff2923fec48fd4f7a6e36b26696f1f0130bbe0c.tar.bz2
gentoo-2-0ff2923fec48fd4f7a6e36b26696f1f0130bbe0c.zip
Ok, while we're off breaking things, let's stop by mplayer too. So... I backported the giflib detection from pre6 configure to pre5-r5. Now they act the same (though I'm still forcing giflib for all intensive purposes as the main gif lib and upstream supports it...). That's all.
-rw-r--r--media-video/mplayer/ChangeLog6
-rw-r--r--media-video/mplayer/files/mplayer-gif.patch66
-rw-r--r--media-video/mplayer/mplayer-1.0_pre5-r5.ebuild12
3 files changed, 76 insertions, 8 deletions
diff --git a/media-video/mplayer/ChangeLog b/media-video/mplayer/ChangeLog
index c82024d92362..6a4aba150554 100644
--- a/media-video/mplayer/ChangeLog
+++ b/media-video/mplayer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/mplayer
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.265 2005/02/03 22:19:24 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.266 2005/02/04 21:49:38 chriswhite Exp $
+
+ 05 Feb 2005; Chris White <chriswhite@gentoo.org> +files/mplayer-gif.patch,
+ mplayer-1.0_pre5-r5.ebuild:
+ Fixed giflib support by backing mplayer pre6 giflib detection.
04 Feb 2005; Chris White <chriswhite@gentoo.org> mplayer-1.0_pre5-r5.ebuild,
mplayer-1.0_pre6.ebuild:
diff --git a/media-video/mplayer/files/mplayer-gif.patch b/media-video/mplayer/files/mplayer-gif.patch
new file mode 100644
index 000000000000..5f8ff60003c1
--- /dev/null
+++ b/media-video/mplayer/files/mplayer-gif.patch
@@ -0,0 +1,66 @@
+--- MPlayer-1.0pre5try2/configure 2004-12-19 03:17:24.000000000 +0900
++++ MPlayer-1.0pre6/configure 2004-12-24 00:36:00.000000000 +0900
+@@ -3719,7 +3965,42 @@
+ fi
+
+
++
++echocheck "PNM support"
++if test "$_pnm" = yes; then
++ _def_pnm="#define HAVE_PNM"
++ _vosrc="$_vosrc vo_pnm.c"
++ _vomodules="pnm $_vomodules"
++else
++ _def_pnm="#undef HAVE_PNM"
++ _novomodules="pnm $_novomodules"
++fi
++echores "$_pnm"
++
++
++
++echocheck "md5sum support"
++if test "$_md5sum" = yes; then
++ _def_md5sum="#define HAVE_MD5SUM"
++ _vosrc="$_vosrc vo_md5sum.c md5sum.c"
++ _vomodules="md5sum $_vomodules"
++else
++ _def_md5sum="#undef HAVE_MD5SUM"
++ _novomodules="md5sum $_novomodules"
++fi
++echores "$_md5sum"
++
++
++
+ echocheck "GIF support"
++# This is to appease people who want to force gif support.
++# If it is forced to yes, then we still do checks to determine
++# which gif library to use.
++if test "$_gif" = yes ; then
++ _force_gif=yes
++ _gif=auto
++fi
++
+ if test "$_gif" = auto ; then
+ _gif=no
+ cat > $TMPC << EOF
+@@ -3743,6 +4024,20 @@
+ fi
+ fi
+
++# If no library was found, and the user wants support forced,
++# then we force it on with libgif, as this is the safest
++# assumption IMHO. (libungif & libregif both create symbolic
++# links to libgif. We also assume that no x11 support is needed,
++# because if you are forcing this, then you _should_ know what
++# you are doing. [ Besides, package maintainers should never
++# have compiled x11 deps into libungif in the first place. ] )
++# </rant>
++# --Joey
++if test "$_force_gif" = yes && test "$_gif" = no ; then
++ _gif=yes
++ _ld_gif="-lgif"
++fi
++
+ if test "$_gif" = yes ; then
+ _def_gif='#define HAVE_GIF 1'
+ _vosrc="$_vosrc vo_gif89a.c"
diff --git a/media-video/mplayer/mplayer-1.0_pre5-r5.ebuild b/media-video/mplayer/mplayer-1.0_pre5-r5.ebuild
index 7d05a98cfb00..0831d8ca80b5 100644
--- a/media-video/mplayer/mplayer-1.0_pre5-r5.ebuild
+++ b/media-video/mplayer/mplayer-1.0_pre5-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_pre5-r5.ebuild,v 1.19 2005/02/03 22:19:24 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_pre5-r5.ebuild,v 1.20 2005/02/04 21:49:38 chriswhite Exp $
inherit eutils flag-o-matic kernel-mod
@@ -162,6 +162,10 @@ src_unpack() {
epatch ${FILESDIR}/${P}-bio2jack.patch
use ppc64 && epatch ${FILESDIR}/${P}-r4-ppc64.patch
+
+ # backport the gif recognition from pre6...
+ # yay! - Chris
+ epatch ${FILESDIR}/${PN}-gif.patch
}
linguas_warn() {
@@ -442,12 +446,6 @@ src_compile() {
--with-x11incdir=/usr/X11R6/include \
${myconf} || die
- # when gif is autodetected, GIF_LIB is set correctly. We're explicitly controlling it, and it doesn't behave correctly.
- # so... we have to help it along.
- if use gif; then
- sed -e "s:GIF_LIB =:GIF_LIB = -lgif:" -i config.mak
- fi
-
einfo "Make"
make all || die "Failed to build MPlayer!"
einfo "Make completed"