summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2004-11-28 21:44:09 +0000
committerIlya Volynets <iluxa@gentoo.org>2004-11-28 21:44:09 +0000
commit12506ed9a5c410362484a56ef8a11fd4015914db (patch)
tree1cd33a67d2bb09b262e042c1e04f64fd0e034100
parentStable on ppc64; bug #71595 (Manifest recommit) (diff)
downloadgentoo-2-12506ed9a5c410362484a56ef8a11fd4015914db.tar.gz
gentoo-2-12506ed9a5c410362484a56ef8a11fd4015914db.tar.bz2
gentoo-2-12506ed9a5c410362484a56ef8a11fd4015914db.zip
Add latest sptk ebuild
-rw-r--r--dev-cpp/sptk/ChangeLog8
-rw-r--r--dev-cpp/sptk/Manifest16
-rw-r--r--dev-cpp/sptk/files/digest-sptk-2.3.161
-rw-r--r--dev-cpp/sptk/sptk-2.3.16.ebuild44
4 files changed, 56 insertions, 13 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index 2932a38e046b..7088620aefca 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/sptk
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.4 2004/11/08 21:54:41 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.5 2004/11/28 21:44:09 iluxa Exp $
+
+*sptk-2.3.16 (28 Nov 2004)
+
+ 28 Nov 2004; Ilya A. Volynets-Evenbach <iluxa@gentoo.org>
+ +sptk-2.3.16.ebuild:
+ Add sptk 2.3.16 (By Alexey Parshin <alexeyp@tts-sf.com>)
08 Nov 2004; Bryan Østergaard <kloeri@gentoo.org> sptk-2.2.1.ebuild,
sptk-2.2.ebuild:
diff --git a/dev-cpp/sptk/Manifest b/dev-cpp/sptk/Manifest
index 67e4511b6ceb..093bbf37d760 100644
--- a/dev-cpp/sptk/Manifest
+++ b/dev-cpp/sptk/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 a14ea70026f828e8510de801d092e6b2 ChangeLog 1113
-MD5 623669b964009bb2a2adfc367f12d072 metadata.xml 334
+MD5 57ccddb0964914a63a171eea956036a1 sptk-2.3.16.ebuild 1076
MD5 27793e9f85264bac1dc0a43adc3daf8f sptk-2.2.ebuild 1086
MD5 707572a6dc747e2175751580e7a3db78 sptk-2.2.1.ebuild 1094
+MD5 a14ea70026f828e8510de801d092e6b2 ChangeLog 1113
+MD5 623669b964009bb2a2adfc367f12d072 metadata.xml 334
+MD5 57e9f89edc425e694c858182f785d30e files/digest-sptk-2.3.16 62
MD5 005ad61b10481108e76f80f21470a05d files/digest-sptk-2.2.1 60
MD5 ca482c4334f36836fb9377c2009ce95f files/digest-sptk-2.2 58
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBj+svugEuf3OQ0akRAq6SAKCIM5SiGaIDbhrelJfodfw6RfVCeACcDhg2
-PNGBUsm4vZx96O9xgzi3zJM=
-=iCdn
------END PGP SIGNATURE-----
diff --git a/dev-cpp/sptk/files/digest-sptk-2.3.16 b/dev-cpp/sptk/files/digest-sptk-2.3.16
new file mode 100644
index 000000000000..556e34c3dd2e
--- /dev/null
+++ b/dev-cpp/sptk/files/digest-sptk-2.3.16
@@ -0,0 +1 @@
+MD5 f6084cb6ddf06c3a4eb6d68fd9b43696 sptk-2.3.16.tbz2 3188068
diff --git a/dev-cpp/sptk/sptk-2.3.16.ebuild b/dev-cpp/sptk/sptk-2.3.16.ebuild
new file mode 100644
index 000000000000..f9de0ce118b1
--- /dev/null
+++ b/dev-cpp/sptk/sptk-2.3.16.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-2.3.16.ebuild,v 1.1 2004/11/28 21:44:09 iluxa Exp $
+
+IUSE="fltk odbc"
+
+DESCRIPTION="C++ user interface toolkit for X with database and Excel support"
+SRC_URI="http://sptk.tts-sf.com/sptk-${PV}.tbz2"
+HOMEPAGE="http://sptk.tts-sf.com"
+
+SLOT="2"
+LICENSE="|| ( FLTK GPL-2 )"
+KEYWORDS="~x86 ~sparc ~mips"
+
+DEPEND="fltk? ( x11-libs/fltk )
+ odbc? ( >=dev-db/unixODBC-2.2.6 )"
+
+src_compile() {
+
+ local myconf
+ myconf="--enable-shared"
+
+ use odbc || myconf="${myconf} --disable-odbc" #default enabled
+ use fltk || myconf="${myconf} --disable-fltk"
+
+ econf \
+ --prefix=/usr \
+ ${myconf} || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+src_install () {
+
+ einstall \
+ includedir=${D}/usr/include/sptk \
+ libdir=${D}/usr/lib || die "Installation Failed"
+
+ dodoc CHANGES COPYING README
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/sptk/* ${D}/usr/share/doc/${PF}/html
+ rmdir ${D}/usr/share/doc/sptk
+}