summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-05-31 15:02:39 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-05-31 15:02:39 +0000
commit12eb93c8714990394d03d3a672979cc0dcaff34a (patch)
tree0443d492c4f82822a8d29ebe9d4ac1b843006821
parentStable for HPPA (bug #171107). (diff)
downloadgentoo-2-12eb93c8714990394d03d3a672979cc0dcaff34a.tar.gz
gentoo-2-12eb93c8714990394d03d3a672979cc0dcaff34a.tar.bz2
gentoo-2-12eb93c8714990394d03d3a672979cc0dcaff34a.zip
Version bump, security bug #180436
(Portage version: 2.1.2.7)
-rw-r--r--www-client/seamonkey/ChangeLog7
-rw-r--r--www-client/seamonkey/files/digest-seamonkey-1.1.29
-rw-r--r--www-client/seamonkey/seamonkey-1.1.2.ebuild284
3 files changed, 299 insertions, 1 deletions
diff --git a/www-client/seamonkey/ChangeLog b/www-client/seamonkey/ChangeLog
index c562d456e0c6..5e667acfbe42 100644
--- a/www-client/seamonkey/ChangeLog
+++ b/www-client/seamonkey/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/seamonkey
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey/ChangeLog,v 1.62 2007/05/13 14:19:55 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey/ChangeLog,v 1.63 2007/05/31 15:02:39 armin76 Exp $
+
+*seamonkey-1.1.2 (31 May 2007)
+
+ 31 May 2007; Raúl Porcel <armin76@gentoo.org> +seamonkey-1.1.2.ebuild:
+ Version bump, security bug #180436
13 May 2007; Raúl Porcel <armin76@gentoo.org> seamonkey-1.1.1.ebuild:
Add missing WANT_AUTOCONF, bug 177012
diff --git a/www-client/seamonkey/files/digest-seamonkey-1.1.2 b/www-client/seamonkey/files/digest-seamonkey-1.1.2
new file mode 100644
index 000000000000..6fcf1880d6f7
--- /dev/null
+++ b/www-client/seamonkey/files/digest-seamonkey-1.1.2
@@ -0,0 +1,9 @@
+MD5 b255e7a77ecea435934bfa1872e99f6a enigmail-0.94.1.tar.gz 513084
+RMD160 1b8719c7669449f706bd3ff6964565e6ba9f8902 enigmail-0.94.1.tar.gz 513084
+SHA256 3584329e4f51e43fbb9028cf47101de8c74651e7607de80cb1f61349424133c1 enigmail-0.94.1.tar.gz 513084
+MD5 6521660623dd894812228056cf97333d seamonkey-1.1.1-patches-0.2.tar.bz2 20492
+RMD160 19bad75df317d33852514ed8e3f4ce3e91e12616 seamonkey-1.1.1-patches-0.2.tar.bz2 20492
+SHA256 029edd8170c6c596050c5399d768b1b224e70ddcbe07ecda10d8c8a2b089441a seamonkey-1.1.1-patches-0.2.tar.bz2 20492
+MD5 a84742277a3d3036f9d8f55e3b82ac3d seamonkey-1.1.2.source.tar.bz2 35220020
+RMD160 aa681ebe1e68ab8fba0d04e3c0c0434b65e6f1ad seamonkey-1.1.2.source.tar.bz2 35220020
+SHA256 2cf313503cf5e66d3da5471b872f086f656409e031b5f57c8b662d23faab1fda seamonkey-1.1.2.source.tar.bz2 35220020
diff --git a/www-client/seamonkey/seamonkey-1.1.2.ebuild b/www-client/seamonkey/seamonkey-1.1.2.ebuild
new file mode 100644
index 000000000000..fe3ba952f7d0
--- /dev/null
+++ b/www-client/seamonkey/seamonkey-1.1.2.ebuild
@@ -0,0 +1,284 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey/seamonkey-1.1.2.ebuild,v 1.1 2007/05/31 15:02:39 armin76 Exp $
+
+WANT_AUTOCONF="2.1"
+
+inherit flag-o-matic toolchain-funcs eutils mozcoreconf mozconfig-2 mozilla-launcher makeedit multilib autotools
+
+PATCH="${PN}-1.1.1-patches-0.2"
+EMVER="0.94.1"
+
+DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
+HOMEPAGE="http://www.mozilla.org"
+SRC_URI="http://releases.mozilla.org/pub/mozilla.org/${PN}/releases/${PV}/${P}.source.tar.bz2
+ mirror://gentoo/${PATCH}.tar.bz2
+ crypt? ( !moznomail? ( http://www.mozilla-enigmail.org/downloads/src/enigmail-${EMVER}.tar.gz ) )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+SLOT="0"
+LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+IUSE="java ldap mozdevelop moznocompose moznoirc moznomail moznoroaming postgres crypt xforms"
+
+RDEPEND="java? ( virtual/jre )
+ >=www-client/mozilla-launcher-1.56
+ >=dev-libs/nss-3.11.5
+ >=dev-libs/nspr-4.6.5-r1
+ crypt? ( !moznomail? ( >=app-crypt/gnupg-1.4 ) )"
+
+DEPEND="${RDEPEND}
+ java? ( >=dev-java/java-config-0.2.0 )
+ dev-lang/perl
+ postgres? ( >=dev-db/postgresql-7.2.0 )"
+
+S="${WORKDIR}/mozilla"
+
+# Needed by src_compile() and src_install().
+# Would do in pkg_setup but that loses the export attribute, they
+# become pure shell variables.
+export MOZ_CO_PROJECT=suite
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+
+pkg_setup() {
+ use moznopango && warn_mozilla_launcher_stub
+}
+
+src_unpack() {
+ unpack ${P}.source.tar.bz2 ${PATCH}.tar.bz2
+
+ cd ${S} || die "cd failed"
+ EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" epatch ${WORKDIR}/patch
+
+ # Unpack the enigmail plugin
+ if use crypt && ! use moznomail; then
+ cd ${S}/mailnews/extensions || die
+ unpack enigmail-${EMVER}.tar.gz
+ cd ${S}/mailnews/extensions/enigmail || die "cd failed"
+ makemake2
+ fi
+
+ # Fix scripts that call for /usr/local/bin/perl #51916
+ ebegin "Patching smime to call perl from /usr/bin"
+ sed -i -e '1s,usr/local/bin,usr/bin,' ${S}/security/nss/cmd/smimetools/smime
+ eend $? || die "sed failed"
+
+ # Fix a compilation issue using the 32-bit userland with 64-bit kernel on
+ # PowerPC, because with that configuration, mozilla detects a ppc64 system.
+ # -- hansmi, 2005-10-02
+ if use ppc && [[ "${PROFILE_ARCH}" == ppc64 ]]; then
+ sed -i -e "s#OS_TEST=\`uname -m\`\$#OS_TEST=${ARCH}#" \
+ ${S}/configure.in
+ sed -i -e "s#OS_TEST :=.*uname -m.*\$#OS_TEST:=${ARCH}#" \
+ ${S}/security/coreconf/arch.mk
+ fi
+
+ cd ${S}
+ eautoreconf
+}
+
+src_compile() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+
+ ####################################
+ #
+ # mozconfig, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+ mozconfig_init
+ mozconfig_config
+
+ mozconfig_annotate 'gentoo' --enable-canvas
+ mozconfig_annotate 'gentoo' --with-system-nspr
+ mozconfig_annotate 'gentoo' --with-system-nss
+
+ # Bug 60668: Galeon doesn't build without oji enabled, so enable it
+ # regardless of java setting.
+ mozconfig_annotate 'galeon' --enable-oji --enable-mathml
+
+ # Other moz-specific settings
+ mozconfig_use_enable mozdevelop jsd
+ mozconfig_use_enable mozdevelop xpctools
+ mozconfig_use_extension mozdevelop venkman
+
+ if use moznoirc; then
+ mozconfig_annotate '+moznocompose +moznoirc' --enable-extensions=-irc
+ fi
+
+ if use moznoroaming ; then
+ mozconfig_annotate '+moznoroaming' --enable-extensions=-sroaming
+ fi
+
+ if use postgres ; then
+ mozconfig_annotate '+postgres' --enable-extensions=sql
+ export MOZ_ENABLE_PGSQL=1
+ export MOZ_PGSQL_INCLUDES=/usr/include
+ export MOZ_PGSQL_LIBS=/usr/$(get_libdir)
+ fi
+
+ mozconfig_use_enable ldap
+ mozconfig_use_enable ldap ldap-experimental
+ mozconfig_annotate '' --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME}
+ mozconfig_annotate '' --with-user-appdir=.mozilla
+
+ if use moznomail; then
+ mozconfig_annotate "+moznomail" --disable-mailnews
+ fi
+
+ if use moznocompose; then
+ if use moznoirc && use moznomail; then
+ mozconfig_annotate "+moznocompose" --disable-composer
+ fi
+ fi
+
+ if use xforms; then
+ mozconfig_annotate "+xforms" --enable-extensions=xforms,schema-validation
+ fi
+
+ # Finalize and report settings
+ mozconfig_final
+
+ # hardened GCC uses -fstack-protector-all by default, which breaks us
+ gcc-specs-ssp && append-flags -fno-stack-protector-all
+ replace-flags -fstack-protector-all -fstack-protector
+
+ append-flags -freorder-blocks -fno-reorder-functions
+
+ ####################################
+ #
+ # Configure and build
+ #
+ ####################################
+
+ CPPFLAGS="${CPPFLAGS} -DARON_WAS_HERE" \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
+ econf || die
+
+ # It would be great if we could pass these in via CPPFLAGS or CFLAGS prior
+ # to econf, but the quotes cause configure to fail.
+ sed -i -e \
+ 's|-DARON_WAS_HERE|-DGENTOO_NSPLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsplugins\\\" -DGENTOO_NSBROWSER_PLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsbrowser/plugins\\\"|' \
+ ${S}/config/autoconf.mk \
+ ${S}/xpfe/global/buildconfig.html
+
+ # This removes extraneous CFLAGS from the Makefiles to reduce RAM
+ # requirements while compiling
+ edit_makefiles
+
+ emake -j1 || die
+
+ ####################################
+ #
+ # Build Enigmail extension
+ #
+ ####################################
+
+ if use crypt && ! use moznomail; then
+ emake -C ${S}/mailnews/extensions/enigmail || die "make enigmail failed"
+ fi
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+
+ # Most of the installation happens here
+ dodir ${MOZILLA_FIVE_HOME}
+ cp -RL ${S}/dist/bin/* ${D}${MOZILLA_FIVE_HOME}
+
+ # Create directory structure to support portage-installed extensions.
+ # See update_chrome() in mozilla-launcher
+ keepdir ${MOZILLA_FIVE_HOME}/chrome.d
+ keepdir ${MOZILLA_FIVE_HOME}/extensions.d
+ cp ${D}${MOZILLA_FIVE_HOME}/chrome/installed-chrome.txt \
+ ${D}${MOZILLA_FIVE_HOME}/chrome.d/0_base-chrome.txt
+
+ # Create /usr/bin/mozilla
+ install_mozilla_launcher_stub seamonkey ${MOZILLA_FIVE_HOME}
+
+ # Install icon and .desktop for menu entry
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/icon/${PN}.png
+
+ # Fix bug 54179: Install .desktop file into /usr/share/applications
+ # instead of /usr/share/gnome/apps/Internet (18 Jun 2004 agriffis)
+ insinto /usr/share/applications
+ doins ${FILESDIR}/icon/${PN}.desktop
+
+ # Fix icons to look the same everywhere
+ insinto ${MOZILLA_FIVE_HOME}/icons
+ doins ${S}/widget/src/gtk/mozicon16.xpm
+ doins ${S}/widget/src/gtk/mozicon50.xpm
+
+ ####################################
+ #
+ # Install files necessary for applications to build against mozilla
+ #
+ ####################################
+
+ einfo "Installing includes and idl files..."
+ dodir ${MOZILLA_FIVE_HOME}/{include,idl} /usr/include
+ cd ${S}/dist
+ cp -LfR include/* ${D}${MOZILLA_FIVE_HOME}/include
+ cp -LfR idl/* ${D}${MOZILLA_FIVE_HOME}/idl
+
+ # Fix mozilla-config and install it
+ exeinto ${MOZILLA_FIVE_HOME}
+ doexe ${S}/build/unix/${PN}-config
+
+ # Fix pkgconfig files and install them
+ insinto /usr/$(get_libdir)/pkgconfig
+ for x in ${S}/build/unix/*.pc; do
+ doins ${x}
+ done
+
+ # Install env.d snippet, which isn't necessary for running mozilla, but
+ # might be necessary for programs linked against firefox
+ doenvd ${FILESDIR}/10${PN}
+ dosed "s|/usr/lib|/usr/$(get_libdir)|" /etc/env.d/10${PN}
+
+ # Install rebuild script since mozilla-bin doesn't support registration yet
+ exeinto ${MOZILLA_FIVE_HOME}
+ doexe ${FILESDIR}/${PN}-rebuild-databases.pl
+ dosed -e 's|/lib/|/'"$(get_libdir)"'/|g' \
+ ${MOZILLA_FIVE_HOME}/${PN}-rebuild-databases.pl
+
+ # Install docs
+ dodoc ${S}/{LEGAL,LICENSE}
+
+ # Update Google search plugin to use UTF8 charset ...
+ insinto ${MOZILLA_FIVE_HOME}/searchplugins
+ doins ${FILESDIR}/google.src
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+
+ # Remove entire installed instance to solve various problems,
+ # for example see bug 27719
+ rm -rf ${ROOT}${MOZILLA_FIVE_HOME}
+}
+
+pkg_postinst() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+
+ # Update the component registry
+ MOZILLA_LIBDIR=${ROOT}${MOZILLA_FIVE_HOME} MOZILLA_LAUNCHER=${PN} \
+ /usr/libexec/mozilla-launcher -register
+
+ # This should be called in the postinst and postrm of all the
+ # mozilla, mozilla-bin, firefox, firefox-bin, thunderbird and
+ # thunderbird-bin ebuilds.
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+
+ # Update the component registry
+ if [[ -x ${MOZILLA_FIVE_HOME}/${PN}-bin ]]; then
+ MOZILLA_LIBDIR=${ROOT}${MOZILLA_FIVE_HOME} MOZILLA_LAUNCHER=${PN} \
+ /usr/libexec/mozilla-launcher -register
+ fi
+
+ update_mozilla_launcher_symlinks
+} \ No newline at end of file