summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-11-25 17:18:30 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-11-25 17:18:30 +0000
commit172d855b1b2d148f2602a9b2a1b0a68cd1ea9bb6 (patch)
tree36d47d6712ebad8890e071bad4bde9f39524fbdf
parentAdd ~amd64 (diff)
downloadgentoo-2-172d855b1b2d148f2602a9b2a1b0a68cd1ea9bb6.tar.gz
gentoo-2-172d855b1b2d148f2602a9b2a1b0a68cd1ea9bb6.tar.bz2
gentoo-2-172d855b1b2d148f2602a9b2a1b0a68cd1ea9bb6.zip
Move some python related code behind USE=python. Drop makeopts changes as it should be fixed per changelog.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key C6085806)
-rw-r--r--net-libs/gupnp-igd/ChangeLog7
-rw-r--r--net-libs/gupnp-igd/gupnp-igd-0.2.1.ebuild6
-rw-r--r--net-libs/gupnp-igd/gupnp-igd-0.2.2.ebuild12
3 files changed, 14 insertions, 11 deletions
diff --git a/net-libs/gupnp-igd/ChangeLog b/net-libs/gupnp-igd/ChangeLog
index 6705717ba044..5c2ba558bda2 100644
--- a/net-libs/gupnp-igd/ChangeLog
+++ b/net-libs/gupnp-igd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gupnp-igd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/ChangeLog,v 1.40 2012/11/25 17:09:26 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/ChangeLog,v 1.41 2012/11/25 17:18:30 eva Exp $
+
+ 25 Nov 2012; Gilles Dartiguelongue <eva@gentoo.org> gupnp-igd-0.2.1.ebuild,
+ gupnp-igd-0.2.2.ebuild:
+ Move some python related code behind USE=python. Drop makeopts changes as it
+ should be fixed per changelog.
*gupnp-igd-0.2.2 (25 Nov 2012)
diff --git a/net-libs/gupnp-igd/gupnp-igd-0.2.1.ebuild b/net-libs/gupnp-igd/gupnp-igd-0.2.1.ebuild
index 0bcb216f4274..6f52fb762a2d 100644
--- a/net-libs/gupnp-igd/gupnp-igd-0.2.1.ebuild
+++ b/net-libs/gupnp-igd/gupnp-igd-0.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/gupnp-igd-0.2.1.ebuild,v 1.6 2012/10/01 08:29:14 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/gupnp-igd-0.2.1.ebuild,v 1.7 2012/11/25 17:18:30 eva Exp $
EAPI="3"
PYTHON_DEPEND="python? 2:2.5"
@@ -58,9 +58,7 @@ src_configure() {
}
src_compile() {
- # introspection is built in the same directory and libtool does not handle
- # well dependency like this
- MAKEOPTS="${MAKEOPTS} -j1" default
+ default
if use python; then
python_copy_sources python
diff --git a/net-libs/gupnp-igd/gupnp-igd-0.2.2.ebuild b/net-libs/gupnp-igd/gupnp-igd-0.2.2.ebuild
index 51cf05d7bb8b..2b3ec5a5904b 100644
--- a/net-libs/gupnp-igd/gupnp-igd-0.2.2.ebuild
+++ b/net-libs/gupnp-igd/gupnp-igd-0.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/gupnp-igd-0.2.2.ebuild,v 1.1 2012/11/25 17:09:26 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/gupnp-igd-0.2.2.ebuild,v 1.2 2012/11/25 17:18:30 eva Exp $
EAPI="5"
PYTHON_DEPEND="python? 2:2.5"
@@ -40,13 +40,13 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-0.1.11-disable_static_modules.patch
-
- # Python bindings are built/installed manually.
- sed -e "/PYTHON_SUBDIR =/s/ python//" -i Makefile.am
-
eautoreconf
- python_clean_py-compile_files -q
+ # Python bindings are built/installed manually.
+ if use python; then
+ sed -e "/PYTHON_SUBDIR =/s/ python//" -i Makefile.am Makefile.in || die
+ python_clean_py-compile_files -q
+ fi
}
src_configure() {