summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-05-21 05:50:57 +0000
committerHans de Graaff <graaff@gentoo.org>2010-05-21 05:50:57 +0000
commit183d86bbf7faaf31c6827b4ed855d162ba9e096e (patch)
treee4db691ee74aa73dbf75254922fa5cefdc67b235
parentamd64 stable, bug #318809 (diff)
downloadgentoo-2-183d86bbf7faaf31c6827b4ed855d162ba9e096e.tar.gz
gentoo-2-183d86bbf7faaf31c6827b4ed855d162ba9e096e.tar.bz2
gentoo-2-183d86bbf7faaf31c6827b4ed855d162ba9e096e.zip
Version bump. Convert to ruby-fakegem.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
-rw-r--r--dev-ruby/id3lib-ruby/ChangeLog9
-rw-r--r--dev-ruby/id3lib-ruby/id3lib-ruby-0.6.0.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-ruby/id3lib-ruby/ChangeLog b/dev-ruby/id3lib-ruby/ChangeLog
index e8018d0a4c37..b05fec4edb8e 100644
--- a/dev-ruby/id3lib-ruby/ChangeLog
+++ b/dev-ruby/id3lib-ruby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/id3lib-ruby
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/id3lib-ruby/ChangeLog,v 1.4 2008/04/22 18:08:22 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/id3lib-ruby/ChangeLog,v 1.5 2010/05/21 05:50:57 graaff Exp $
+
+*id3lib-ruby-0.6.0 (21 May 2010)
+
+ 21 May 2010; Hans de Graaff <graaff@gentoo.org> +id3lib-ruby-0.6.0.ebuild:
+ Version bump. Convert to ruby-fakegem.
22 Apr 2008; Raúl Porcel <armin76@gentoo.org> id3lib-ruby-0.5.0.ebuild:
Add ~sparc
diff --git a/dev-ruby/id3lib-ruby/id3lib-ruby-0.6.0.ebuild b/dev-ruby/id3lib-ruby/id3lib-ruby-0.6.0.ebuild
new file mode 100644
index 000000000000..49b30ece1f27
--- /dev/null
+++ b/dev-ruby/id3lib-ruby/id3lib-ruby-0.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/id3lib-ruby/id3lib-ruby-0.6.0.ebuild,v 1.1 2010/05/21 05:50:57 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README TODO"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby interface to the id3lib C++ library"
+HOMEPAGE="http://id3lib-ruby.rubyforge.org/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="${DEPEND} media-libs/id3lib"
+RDEPEND="${RDEPEND} media-libs/id3lib"
+
+each_ruby_configure() {
+ pushd ext/id3lib_api
+ ${RUBY} extconf.rb
+ popd
+}
+
+each_ruby_compile() {
+ pushd ext/id3lib_api
+ emake || die "Unable to compile extension."
+ popd
+}
+
+each_ruby_install() {
+ mv ext/id3lib_api/id3lib_api.so lib || die "Unable to install extension."
+
+ each_fakegem_install
+}