summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-09-04 14:17:05 +0000
committerIan Delaney <idella4@gentoo.org>2014-09-04 14:17:05 +0000
commit19607888c67e71767cc93ab9e33035ac0dfc7b6f (patch)
treee997b61919559e26e895bb50e710bdeb8e515438
parentAdd ruby20, ruby21. (diff)
downloadgentoo-2-19607888c67e71767cc93ab9e33035ac0dfc7b6f.tar.gz
gentoo-2-19607888c67e71767cc93ab9e33035ac0dfc7b6f.tar.bz2
gentoo-2-19607888c67e71767cc93ab9e33035ac0dfc7b6f.zip
bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
-rw-r--r--dev-python/click/ChangeLog7
-rw-r--r--dev-python/click/click-3.2.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/click/ChangeLog b/dev-python/click/ChangeLog
index afa4e967823d..9468ba1dcf58 100644
--- a/dev-python/click/ChangeLog
+++ b/dev-python/click/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/click
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/click/ChangeLog,v 1.5 2014/08/18 05:07:03 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/click/ChangeLog,v 1.6 2014/09/04 14:17:05 idella4 Exp $
+
+*click-3.2 (04 Sep 2014)
+
+ 04 Sep 2014; Ian Delaney <idella4@gentoo.org> +click-3.2.ebuild:
+ bump
*click-3.1 (18 Aug 2014)
diff --git a/dev-python/click/click-3.2.ebuild b/dev-python/click/click-3.2.ebuild
new file mode 100644
index 000000000000..2b5dee7ba674
--- /dev/null
+++ b/dev-python/click/click-3.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/click/click-3.2.ebuild,v 1.1 2014/09/04 14:17:05 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://click.pocoo.org/ http://pypi.python.org/pypi/click"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc examples test"
+
+RDEPEND="dev-python/colorama[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # https://github.com/mitsuhiko/click/issues/217
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}