summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-06-14 20:59:38 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-06-14 20:59:38 +0000
commit197137002a6a16e2fca5d4536d3891120a3caa60 (patch)
treeb6487afd43e73fbf8ada0c0a0c239bdc85cdaad8
parentDocument "AuthBasicAuthoritative Off" in the configuration examples. (diff)
downloadgentoo-2-197137002a6a16e2fca5d4536d3891120a3caa60.tar.gz
gentoo-2-197137002a6a16e2fca5d4536d3891120a3caa60.tar.bz2
gentoo-2-197137002a6a16e2fca5d4536d3891120a3caa60.zip
fix make test. bug #176535
(Portage version: 2.1.2.9)
-rw-r--r--sys-apps/hal/ChangeLog7
-rw-r--r--sys-apps/hal/files/0.5.9/98_hald_cache_test_path.patch17
-rw-r--r--sys-apps/hal/files/0.5.9/series1
-rw-r--r--sys-apps/hal/hal-0.5.9-r1.ebuild3
4 files changed, 26 insertions, 2 deletions
diff --git a/sys-apps/hal/ChangeLog b/sys-apps/hal/ChangeLog
index a49e7a7e3823..27519cb940da 100644
--- a/sys-apps/hal/ChangeLog
+++ b/sys-apps/hal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hal
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.182 2007/05/08 03:17:59 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.183 2007/06/14 20:59:38 cardoe Exp $
+
+ 14 Jun 2007; Doug Goldstein <cardoe@gentoo.org>
+ +files/0.5.9/98_hald_cache_test_path.patch, files/0.5.9/series,
+ hal-0.5.9-r1.ebuild:
+ fix make test. bug #176535
08 May 2007; Doug Goldstein <cardoe@gentoo.org>
files/0.5.9/13_detect_newer_macbooks.patch,
diff --git a/sys-apps/hal/files/0.5.9/98_hald_cache_test_path.patch b/sys-apps/hal/files/0.5.9/98_hald_cache_test_path.patch
new file mode 100644
index 000000000000..46268e4a0cac
--- /dev/null
+++ b/sys-apps/hal/files/0.5.9/98_hald_cache_test_path.patch
@@ -0,0 +1,17 @@
+Index: b/hald/hald-cache-test.sh
+===================================================================
+--- a/hald/hald-cache-test.sh 2007-03-07 16:52:19.000000000 -0500
++++ b/hald/hald-cache-test.sh 2007-06-14 12:10:19.000000000 -0400
+@@ -3,9 +3,9 @@
+ mkdir .local-fdi-test
+ make -C ../fdi install DESTDIR=`pwd`/.local-fdi-test prefix=/
+
+-HAL_FDI_SOURCE_PREPROBE=.local-fdi-test/share/hal/fdi/preprobe
+-HAL_FDI_SOURCE_INFORMATION=.local-fdi-test/share/hal/fdi/preprobe
+-HAL_FDI_SOURCE_POLICY=.local-fdi-test/share/hal/fdi/policy
++HAL_FDI_SOURCE_PREPROBE=.local-fdi-test/usr/share/hal/fdi/preprobe
++HAL_FDI_SOURCE_INFORMATION=.local-fdi-test/usr/share/hal/fdi/preprobe
++HAL_FDI_SOURCE_POLICY=.local-fdi-test/usr/share/hal/fdi/policy
+ HAL_FDI_CACHE_NAME=.local-fdi-test/hald-local-fdi-cache
+ export HAL_FDI_SOURCE_PREPROBE HAL_FDI_SOURCE_INFORMATION \
+ HAL_FDI_SOURCE_POLICY HAL_FDI_CACHE_NAME
diff --git a/sys-apps/hal/files/0.5.9/series b/sys-apps/hal/files/0.5.9/series
index 08ebb4c3ce24..415275d6c17e 100644
--- a/sys-apps/hal/files/0.5.9/series
+++ b/sys-apps/hal/files/0.5.9/series
@@ -23,3 +23,4 @@
95_gentoo_man_page.patch
96_plugdev_allow_send.patch
97_ignore_fixed_drives.patch
+98_hald_cache_test_path.patch
diff --git a/sys-apps/hal/hal-0.5.9-r1.ebuild b/sys-apps/hal/hal-0.5.9-r1.ebuild
index 850073b6fcf1..5e6acfa5ccb3 100644
--- a/sys-apps/hal/hal-0.5.9-r1.ebuild
+++ b/sys-apps/hal/hal-0.5.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.9-r1.ebuild,v 1.3 2007/05/07 16:18:33 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.9-r1.ebuild,v 1.4 2007/06/14 20:59:38 cardoe Exp $
inherit eutils linux-info autotools flag-o-matic
@@ -134,6 +134,7 @@ src_unpack() {
epatch ${FILESDIR}/${PV}/95_gentoo_man_page.patch
epatch ${FILESDIR}/${PV}/96_plugdev_allow_send.patch
epatch ${FILESDIR}/${PV}/97_ignore_fixed_drives.patch
+ epatch ${FILESDIR}/${PV}/98_hald_cache_test_path.patch
eautoreconf
}