summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2004-06-01 02:36:05 +0000
committerSteve Arnold <nerdboy@gentoo.org>2004-06-01 02:36:05 +0000
commit1cc7c5db099b9af2ea25f692680c43df7ff363bc (patch)
treed76d5869520729eddca2e517159c00b657cbab36
parentStable on sparc wrt bug #52434. (Manifest recommit) (diff)
downloadgentoo-2-1cc7c5db099b9af2ea25f692680c43df7ff363bc.tar.gz
gentoo-2-1cc7c5db099b9af2ea25f692680c43df7ff363bc.tar.bz2
gentoo-2-1cc7c5db099b9af2ea25f692680c43df7ff363bc.zip
updated to use distutils and the self-test
-rw-r--r--dev-python/PyClimate/ChangeLog7
-rw-r--r--dev-python/PyClimate/Manifest2
-rw-r--r--dev-python/PyClimate/PyClimate-1.2.1-r1.ebuild51
-rw-r--r--dev-python/PyClimate/files/digest-PyClimate-1.2.1-r11
4 files changed, 60 insertions, 1 deletions
diff --git a/dev-python/PyClimate/ChangeLog b/dev-python/PyClimate/ChangeLog
index e9b6e7955d1c..92461e1a2126 100644
--- a/dev-python/PyClimate/ChangeLog
+++ b/dev-python/PyClimate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/PyClimate
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyClimate/ChangeLog,v 1.1 2004/05/31 18:11:31 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyClimate/ChangeLog,v 1.2 2004/06/01 02:36:05 nerdboy Exp $
+
+*PyClimate-1.2.1-r1 (31 May 2004)
+
+ 31 May 2004; Steve Arnold <nerdboy@gentoo.org> PyClimate-1.2.1-r1.ebuild:
+ updated to use distutils and install the test script and data
*PyClimate-1.2.1 (31 May 2004)
diff --git a/dev-python/PyClimate/Manifest b/dev-python/PyClimate/Manifest
index 61c8690f451d..0273bc5538ee 100644
--- a/dev-python/PyClimate/Manifest
+++ b/dev-python/PyClimate/Manifest
@@ -1,4 +1,6 @@
MD5 d704534b86e2653d25b4e2f4c6b9e1e1 PyClimate-1.2.1.ebuild 921
MD5 5711f48155e6a9f7f569dab40265e627 metadata.xml 729
MD5 a39bdb2cec7fb3be0f0f6956379e68db ChangeLog 395
+MD5 baa876b71f43035daf530b22b293c1ba PyClimate-1.2.1-r1.ebuild 1301
MD5 f8ee275409815fba5c7c815d370748bf files/digest-PyClimate-1.2.1 67
+MD5 f8ee275409815fba5c7c815d370748bf files/digest-PyClimate-1.2.1-r1 67
diff --git a/dev-python/PyClimate/PyClimate-1.2.1-r1.ebuild b/dev-python/PyClimate/PyClimate-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..e625a03b2feb
--- /dev/null
+++ b/dev-python/PyClimate/PyClimate-1.2.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyClimate/PyClimate-1.2.1-r1.ebuild,v 1.1 2004/06/01 02:36:05 nerdboy Exp $
+
+inherit eutils distutils
+
+IUSE=""
+DESCRIPTION="Climate Data Analysis Module for Python"
+SRC_URI="http://starship.python.net/crew/jsaenz/pyclimate/downloads/${P}.tar.gz"
+HOMEPAGE="http://starship.python.net/crew/jsaenz/pyclimate/index.html"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc"
+
+DEPEND="virtual/python
+ >=dev-python/numeric-19.0
+ dev-python/ScientificPython
+ >=app-sci/netcdf-3.0"
+
+src_install() {
+
+ distutils_src_install
+
+ dodir /usr/share/doc/${PF}/doc
+ insinto /usr/share/doc/${PF}/doc
+ doins doc/*
+ doins doc/dcdflib_doc/dcdflib*
+
+ dodir /usr/share/${PF}/examples
+ insinto /usr/share/${PF}/examples
+ doins examples/*
+
+ dodir /usr/share/${PF}/test
+ insinto /usr/share/${PF}/test
+ doins test/*
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/pyclimate
+ einfo
+ einfo "Try the test script in /usr/share/${PF}/test."
+ einfo "See the examples in /usr/share/${PF}/examples."
+ einfo "Read the doc in /usr/share/doc/${PF}."
+ einfo
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}
diff --git a/dev-python/PyClimate/files/digest-PyClimate-1.2.1-r1 b/dev-python/PyClimate/files/digest-PyClimate-1.2.1-r1
new file mode 100644
index 000000000000..b4eada622105
--- /dev/null
+++ b/dev-python/PyClimate/files/digest-PyClimate-1.2.1-r1
@@ -0,0 +1 @@
+MD5 2d19f9622cdc5f3107b90157fcd9266c PyClimate-1.2.1.tar.gz 336090