summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-06-06 18:09:22 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-06-06 18:09:22 +0000
commit2193a0076425e02d40209d568b563be7933762aa (patch)
tree707d48528bab21ba8e1153832ffdd08f4f6c6115
parentversion bump thanks to David PIRY <klessou@gmail.com> in bug 135785 (diff)
downloadgentoo-2-2193a0076425e02d40209d568b563be7933762aa.tar.gz
gentoo-2-2193a0076425e02d40209d568b563be7933762aa.tar.bz2
gentoo-2-2193a0076425e02d40209d568b563be7933762aa.zip
version bump thanks to David PIRY <klessou@gmail.com> in bug 135785
(Portage version: 2.1_rc4-r1)
-rw-r--r--net-libs/opal/ChangeLog7
-rw-r--r--net-libs/opal/files/digest-opal-2.2.23
-rw-r--r--net-libs/opal/opal-2.2.2.ebuild104
3 files changed, 113 insertions, 1 deletions
diff --git a/net-libs/opal/ChangeLog b/net-libs/opal/ChangeLog
index bb692a50fca7..02546c64f478 100644
--- a/net-libs/opal/ChangeLog
+++ b/net-libs/opal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/opal
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/ChangeLog,v 1.1 2006/03/20 23:39:39 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/ChangeLog,v 1.2 2006/06/06 18:09:22 genstef Exp $
+
+*opal-2.2.2 (06 Jun 2006)
+
+ 06 Jun 2006; Stefan Schweizer <genstef@gentoo.org> +opal-2.2.2.ebuild:
+ version bump thanks to David PIRY <klessou@gmail.com> in bug 135785
*opal-2.2.1 (20 Mar 2006)
diff --git a/net-libs/opal/files/digest-opal-2.2.2 b/net-libs/opal/files/digest-opal-2.2.2
new file mode 100644
index 000000000000..10c983e6c617
--- /dev/null
+++ b/net-libs/opal/files/digest-opal-2.2.2
@@ -0,0 +1,3 @@
+MD5 899e38f5586e3b03d07cc1c55680a56f opal-2.2.2.tar.gz 4112700
+RMD160 2e1be0271671c7f71ed477078f27825b389e6fa0 opal-2.2.2.tar.gz 4112700
+SHA256 133f59a0d126ae02b554750702bfcd4e7f75641c15bc8c9156e03f8582709cfc opal-2.2.2.tar.gz 4112700
diff --git a/net-libs/opal/opal-2.2.2.ebuild b/net-libs/opal/opal-2.2.2.ebuild
new file mode 100644
index 000000000000..4ed2924b3e97
--- /dev/null
+++ b/net-libs/opal/opal-2.2.2.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/opal-2.2.2.ebuild,v 1.1 2006/06/06 18:09:22 genstef Exp $
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="OPAL library, used by Ekiga"
+HOMEPAGE="http://www.ekiga.org"
+SRC_URI="http://www.ekiga.org/admin/downloads/latest/sources/sources/${P}.tar.gz"
+
+IUSE="novideo noaudio debug"
+SLOT="0"
+LICENSE="MPL-1.1"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND=">=dev-libs/pwlib-1.10.1
+ >=media-video/ffmpeg-0.4.7"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Makefile is currently broken with NOTRACE=1, fix that
+ epatch ${FILESDIR}/${PN}-2.1.1-notrace.diff
+}
+
+src_compile() {
+ local makeopts
+ local myconf
+
+ # remove -fstack-protector, may cause problems (bug #75259)
+ filter-flags -fstack-protector
+
+ # NOTRACE avoid compilation problems, we disable PTRACING using NOTRACE=1
+ # compile with PTRACING if the user wants to debug stuff
+ if ! use debug; then
+ makeopts="${makeopts} NOTRACE=1"
+ fi
+
+ # doesn't work with osptoolkit-3.3.1
+ # iax2 support is missing in the tarball, disable it too
+ myconf="--disable-transnexusosp --disable-iax --enable-localspeex"
+
+ use novideo \
+ && myconf="${myconf} --disable-video"
+
+ use noaudio \
+ && myconf="${myconf} --disable-audio"
+
+ econf \
+ PWLIBDIR=/usr/share/pwlib \
+ OPALDIR=${S} \
+ ${myconf} || die "configure failed"
+
+ emake ${makeopts} opt || die "make failed"
+}
+
+src_install() {
+ local OPAL_ARCH ALT_ARCH OPAL_SUFFIX
+ local makeopts libdir libname
+
+ # make NOTRACE=1 opt ==> linux_$ARCH_n
+ # make opt ==> linux_$ARCH_r
+ if ! use debug; then
+ OPAL_SUFFIX="n"
+ makeopts="NOTRACE=1"
+ else
+ OPAL_SUFFIX="r"
+ fi
+
+ # use ptlib-config to get the right values here (for hppa, amd64 ...)
+ OPAL_ARCH="$(ptlib-config --ostype)_$(ptlib-config --machtype)_${OPAL_SUFFIX}"
+
+ # set ALT_ARCH
+ if use debug; then
+ ALT_ARCH=${OPAL_ARCH/_r/_n}
+ else
+ ALT_ARCH=${OPAL_ARCH/_n/_r}
+ fi
+
+ ###
+ # Install stuff
+ #
+ make PREFIX=/usr DESTDIR=${D} \
+ ${makeopts} install || die "install failed"
+
+ libdir=$(get_libdir)
+ libname="libopal_${OPAL_ARCH}.so.${PV}"
+
+ # compat symlinks
+ for pv in ${PV} ${PV%.[0-9]} ${PV%.[0-9]*.[0-9]}; do
+ dosym ${libname} /usr/${libdir}/libopal_${ALT_ARCH}.so.${pv}
+ done
+ dosym ${libname} /usr/${libdir}/libopal_${OPAL_ARCH}.so
+ dosym ${libname} /usr/${libdir}/libopal_${ALT_ARCH}.so
+
+ ###
+ # Compatibility "hacks"
+ #
+
+ # install version.h into $OPALDIR
+ insinto /usr/share/opal
+ doins version.h
+}