summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-07-25 17:16:17 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-07-25 17:16:17 +0000
commit29a53d3dbf416972411723ab4d609b2dfdd811d8 (patch)
tree2cc44d40cf36ae1774d55028e223ad78e922df7f
parent Fix minor memory leak. (diff)
downloadgentoo-2-29a53d3dbf416972411723ab4d609b2dfdd811d8.tar.gz
gentoo-2-29a53d3dbf416972411723ab4d609b2dfdd811d8.tar.bz2
gentoo-2-29a53d3dbf416972411723ab4d609b2dfdd811d8.zip
Rule out possible int overflow, PAM compatibility fix.
(Portage version: 2.1.3_rc9)
-rw-r--r--kde-base/kcheckpass/ChangeLog7
-rw-r--r--kde-base/kcheckpass/files/digest-kcheckpass-3.5.76
-rw-r--r--kde-base/kcheckpass/kcheckpass-3.5.7.ebuild23
3 files changed, 35 insertions, 1 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index d14bd110232d..2015c4cd8ca6 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.63 2007/05/24 11:12:15 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.64 2007/07/25 17:16:17 carlo Exp $
+
+*kcheckpass-3.5.7 (25 Jul 2007)
+
+ 25 Jul 2007; Carsten Lohrke <carlo@gentoo.org> +kcheckpass-3.5.7.ebuild:
+ Rule out possible int overflow, PAM compatibility fix.
24 May 2007; Carsten Lohrke <carlo@gentoo.org> kcheckpass-3.5.6.ebuild:
Adjust MAXKDEVER.
diff --git a/kde-base/kcheckpass/files/digest-kcheckpass-3.5.7 b/kde-base/kcheckpass/files/digest-kcheckpass-3.5.7
new file mode 100644
index 000000000000..ce2d5ae895f7
--- /dev/null
+++ b/kde-base/kcheckpass/files/digest-kcheckpass-3.5.7
@@ -0,0 +1,6 @@
+MD5 f6f2574fc332dd1123144bb6a00e5e26 kdebase-3.5-patchset-06.tar.bz2 19825
+RMD160 ab7358b635e912ed9912cb95e48e3187064abae7 kdebase-3.5-patchset-06.tar.bz2 19825
+SHA256 c9ab23f648f84ebc66054f4db48685cbed3d99e9c87fa3df2c0d8a282b9a2394 kdebase-3.5-patchset-06.tar.bz2 19825
+MD5 b421e01b3ee712549ee967f58ed24de0 kdebase-3.5.7.tar.bz2 24395088
+RMD160 f43070b5428c3099c0abceed56041e5b4ff3c656 kdebase-3.5.7.tar.bz2 24395088
+SHA256 3c6d739abefc55b6cb64e1cf37b79f5993b666a5b40492471754794416b5c28d kdebase-3.5.7.tar.bz2 24395088
diff --git a/kde-base/kcheckpass/kcheckpass-3.5.7.ebuild b/kde-base/kcheckpass/kcheckpass-3.5.7.ebuild
new file mode 100644
index 000000000000..01b8c8cdfbd1
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-3.5.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-3.5.7.ebuild,v 1.1 2007/07/25 17:16:17 carlo Exp $
+
+KMNAME=kdebase
+MAXKDEVER=3.5.7
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils flag-o-matic
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdebase-3.5-patchset-06.tar.bz2"
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="pam kdehiddenvisibility"
+DEPEND="pam? ( kde-base/kdebase-pam )"
+
+src_compile() {
+ myconf="$(use_with pam)"
+
+ export BINDNOW_FLAGS="$(bindnow-flags)"
+ kde-meta_src_compile
+}