summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2011-08-23 19:03:37 +0000
committerJesus Rivero <neurogeek@gentoo.org>2011-08-23 19:03:37 +0000
commit30366e9c8e7d93eb00603a941b9b52b801b5a70c (patch)
tree5eb67c12e23e7436967b555d06fa098ed402c349
parentAdd net-misc/leechcraft-cstp (diff)
downloadgentoo-2-30366e9c8e7d93eb00603a941b9b52b801b5a70c.tar.gz
gentoo-2-30366e9c8e7d93eb00603a941b9b52b801b5a70c.tar.bz2
gentoo-2-30366e9c8e7d93eb00603a941b9b52b801b5a70c.zip
Applied patch from upstream, wrt bug #376303. Fixed License
(Portage version: 2.2.0_alpha46/cvs/Linux i686)
-rw-r--r--dev-lang/python/ChangeLog6
-rw-r--r--dev-lang/python/files/python-3.2-soname_typo.patch51
-rw-r--r--dev-lang/python/python-3.2-r2.ebuild7
3 files changed, 61 insertions, 3 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index badee20503a6..6851d8b59172 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.542 2011/08/07 09:58:09 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.543 2011/08/23 19:03:37 neurogeek Exp $
+
+ 23 Aug 2011; Jesus Rivero <neurogeek@gentoo.org> python-3.2-r2.ebuild,
+ +files/python-3.2-soname_typo.patch:
+ Applied patch from upstream, wrt bug #376303. Fixed License
07 Aug 2011; Naohiro Aota <naota@gentoo.org> python-2.6.7-r2.ebuild,
python-2.7.2-r2.ebuild, python-3.1.4-r2.ebuild, python-3.2-r2.ebuild:
diff --git a/dev-lang/python/files/python-3.2-soname_typo.patch b/dev-lang/python/files/python-3.2-soname_typo.patch
new file mode 100644
index 000000000000..357274c491df
--- /dev/null
+++ b/dev-lang/python/files/python-3.2-soname_typo.patch
@@ -0,0 +1,51 @@
+# HG changeset patch
+# User Martin v. Löwis <martin@v.loewis.de>
+# Date 1304919465 -7200
+# Node ID 749686064642118c5ccc8ad28105472321931353
+# Parent 4f3f67a595fb05f04d89ed906df911b743e47463
+Use --as-needed when linking libpython3.so. Closes #11347.
+Patch by Arfrever Frehtes Taifersar Arahesis.
+
+diff --git a/Makefile.pre.in b/Makefile.pre.in
+--- a/Makefile.pre.in
++++ b/Makefile.pre.in
+@@ -76,6 +76,7 @@ PY_CFLAGS= $(BASECFLAGS) $(OPT) $(CONFIG
+ # environment variables
+ PY_CPPFLAGS= -I. -IInclude -I$(srcdir)/Include $(CONFIGURE_CPPFLAGS) $(CPPFLAGS)
+ PY_LDFLAGS= $(CONFIGURE_LDFLAGS) $(LDFLAGS)
++NO_AS_NEEDED= @NO_AS_NEEDED@
+ LDLAST= @LDLAST@
+ SGI_ABI= @SGI_ABI@
+ CCSHARED= @CCSHARED@
+@@ -459,7 +460,7 @@ libpython$(LDVERSION).so: $(LIBRARY_OBJS
+ fi
+
+ libpython3.so: libpython$(LDVERSION).so
+- $(BLDSHARED) -o $@ -Wl,-hl$@ $^
++ $(BLDSHARED) $(NO_AS_NEEDED) -o $@ -Wl,-h$@ $^
+
+ libpython$(LDVERSION).dylib: $(LIBRARY_OBJS)
+ $(CC) -dynamiclib -Wl,-single_module $(PY_LDFLAGS) -undefined dynamic_lookup -Wl,-install_name,$(prefix)/lib/libpython$(LDVERSION).dylib -Wl,-compatibility_version,$(VERSION) -Wl,-current_version,$(VERSION) -o $@ $(LIBRARY_OBJS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
+diff --git a/configure.in b/configure.in
+--- a/configure.in
++++ b/configure.in
+@@ -525,6 +525,18 @@ then
+ fi
+
+
++AC_MSG_CHECKING([for -Wl,--no-as-needed])
++save_LDFLAGS="$LDFLAGS"
++LDFLAGS="$LDFLAGS -Wl,--no-as-needed"
++AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[]])],
++ [NO_AS_NEEDED="-Wl,--no-as-needed"
++ AC_MSG_RESULT([yes])],
++ [NO_AS_NEEDED=""
++ AC_MSG_RESULT([no])])
++LDFLAGS="$save_LDFLAGS"
++AC_SUBST(NO_AS_NEEDED)
++
++
+ # checks for UNIX variants that set C preprocessor variables
+ AC_USE_SYSTEM_EXTENSIONS
+
+
diff --git a/dev-lang/python/python-3.2-r2.ebuild b/dev-lang/python/python-3.2-r2.ebuild
index abc20268e709..e6bdf0553e73 100644
--- a/dev-lang/python/python-3.2-r2.ebuild
+++ b/dev-lang/python/python-3.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2-r2.ebuild,v 1.3 2011/08/07 09:58:09 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2-r2.ebuild,v 1.4 2011/08/23 19:03:37 neurogeek Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -29,7 +29,7 @@ else
mirror://gentoo/python-gentoo-patches-${MY_PV}$([[ "${PATCHSET_REVISION}" != "0" ]] && echo "-r${PATCHSET_REVISION}").tar.bz2"
fi
-LICENSE="PSF-2.2"
+LICENSE="PSF-2"
SLOT="3.2"
PYTHON_ABI="${SLOT}"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
@@ -137,6 +137,9 @@ src_prepare() {
sed -e "s/\(-DSVNVERSION=\).*\( -o\)/\1\\\\\"${ESVN_REVISION}\\\\\"\2/" -i Makefile.pre.in || die "sed failed"
fi
+ #WRT bug #376303
+ epatch "${FILESDIR}/${P}-soname_typo.patch" || die "soname patch failed"
+
eautoreconf
}