summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-11-20 13:56:57 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-11-20 13:56:57 +0000
commit3181b21fb107e63574562f1273504cfbae85e597 (patch)
tree7d45d39d4894caf9cd3e4bd3d7ba0da1396a7f8c
parentVarious fixes and new version (diff)
downloadgentoo-2-3181b21fb107e63574562f1273504cfbae85e597.tar.gz
gentoo-2-3181b21fb107e63574562f1273504cfbae85e597.tar.bz2
gentoo-2-3181b21fb107e63574562f1273504cfbae85e597.zip
Version bump
-rw-r--r--net-www/lynx/ChangeLog7
-rw-r--r--net-www/lynx/files/digest-lynx-2.8.4.1d5
-rw-r--r--net-www/lynx/files/lynx-2.8.4.1d-gentoo.patch8
-rw-r--r--net-www/lynx/lynx-2.8.4.1d.ebuild81
4 files changed, 100 insertions, 1 deletions
diff --git a/net-www/lynx/ChangeLog b/net-www/lynx/ChangeLog
index 309b80e34aa4..f8457aeaf2e0 100644
--- a/net-www/lynx/ChangeLog
+++ b/net-www/lynx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/lynx
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/ChangeLog,v 1.10 2002/09/16 00:33:22 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/ChangeLog,v 1.11 2002/11/20 13:56:57 aliz Exp $
+
+*lynx-2.8.4.1d (20 Nov 2002)
+
+ 20 Nov 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump
*lynx-2.8.4.1c (26 Aug 2002)
diff --git a/net-www/lynx/files/digest-lynx-2.8.4.1d b/net-www/lynx/files/digest-lynx-2.8.4.1d
new file mode 100644
index 000000000000..28f910b2bc5c
--- /dev/null
+++ b/net-www/lynx/files/digest-lynx-2.8.4.1d
@@ -0,0 +1,5 @@
+MD5 6916c0127839f1e454052b683e4691c4 lynx2.8.4rel.1.tar.bz2 1940531
+MD5 d209e52d8182c7c12d784e90c0890ee4 lynx2.8.4rel.1a.patch 7530
+MD5 a687a3d2465d5fd42ce686485dbf71eb lynx2.8.4rel.1b.patch 8939
+MD5 728c8dfde1484b68940673ccf060707e lynx2.8.4rel.1c.patch 9270
+MD5 f710a4b1eac5be0f014816dd48da6ddc lynx2.8.4rel.1d.patch 4688
diff --git a/net-www/lynx/files/lynx-2.8.4.1d-gentoo.patch b/net-www/lynx/files/lynx-2.8.4.1d-gentoo.patch
new file mode 100644
index 000000000000..0d28397d1b0c
--- /dev/null
+++ b/net-www/lynx/files/lynx-2.8.4.1d-gentoo.patch
@@ -0,0 +1,8 @@
+--- src/LYStrings.c Wed May 29 14:41:43 2002
++++ src/LYStrings.c~ Wed May 29 14:41:21 2002
+@@ -1,3 +1,4 @@
++#include <term.h>
+ #include <HTUtils.h>
+ #include <HTCJK.h>
+ #include <UCAux.h>
+
diff --git a/net-www/lynx/lynx-2.8.4.1d.ebuild b/net-www/lynx/lynx-2.8.4.1d.ebuild
new file mode 100644
index 000000000000..819f418e9a81
--- /dev/null
+++ b/net-www/lynx/lynx-2.8.4.1d.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/lynx-2.8.4.1d.ebuild,v 1.1 2002/11/20 13:56:57 aliz Exp $
+
+IUSE="ssl nls ipv6"
+
+MY_PV=${PV/.1d/rel.1}
+S=${WORKDIR}/${PN}2-8-4
+DESCRIPTION="An excellent console-based web browser with ssl support"
+HOMEPAGE="http://lynx.browser.org/"
+SRC_URI="ftp://lynx.isc.org/${PN}/${PN}2.8.4/${PN}${MY_PV}.tar.bz2
+ ftp://lynx.isc.org/lynx/lynx2.8.4/patches/${PN}${MY_PV}a.patch
+ ftp://lynx.isc.org/lynx/lynx2.8.4/patches/${PN}${MY_PV}b.patch
+ ftp://lynx.isc.org/lynx/lynx2.8.4/patches/${PN}${MY_PV}c.patch
+ ftp://lynx.isc.org/lynx/lynx2.8.4/patches/${PN}${MY_PV}d.patch"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ >=sys-libs/zlib-1.1.3
+ nls? ( sys-devel/gettext )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+PROVIDE="virtual/textbrowser"
+
+src_unpack() {
+ unpack ${PN}${MY_PV}.tar.bz2
+ cd ${S}
+
+ patch -p1 < ${DISTDIR}/${PN}${MY_PV}a.patch || die
+ patch -p1 < ${DISTDIR}/${PN}${MY_PV}b.patch || die
+ patch -p1 < ${DISTDIR}/${PN}${MY_PV}c.patch || die
+ patch -p1 < ${DISTDIR}/${PN}${MY_PV}d.patch || die
+
+ # GCC3.1 support -- check if it's really needed in
+ # future. Some users report complete success with -r3 --
+ # credit to lostlogix and carpaski. Resolves #3172
+ patch -p0 < ${FILESDIR}/${P}-gentoo.patch || die
+}
+
+src_compile() {
+ local myconf
+ use nls && myconf="${myconf} --enable-nls"
+ use ssl && myconf="${myconf} --with-ssl=yes"
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ CFLAGS="${CFLAGS} -DANSI_VARARGS"
+
+ econf \
+ --libdir=/etc/lynx \
+ --enable-cgi-links \
+ --enable-prettysrc \
+ --enable-nsl-fork \
+ --enable-file-upload \
+ --enable-read-eta \
+ --enable-libjs \
+ --enable-color-style \
+ --enable-scrollbar \
+ --enable-included-msgs \
+ --with-zlib \
+ ${myconf} || die
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ make prefix=${D}/usr datadir=${D}/usr/share mandir=${D}/usr/share/man \
+ libdir=${D}/etc/lynx install || die
+
+ dodoc CHANGES COPYHEADER COPYING INSTALLATION PROBLEMS README
+ docinto docs
+ dodoc docs/*
+ docinto lynx_help
+ dodoc lynx_help/*.txt
+ dohtml -r lynx_help
+
+ # small little manpage glitch
+ rm ${D}/usr/share/man/lynx.1
+ newman lynx.man lynx.1
+}