summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-07-18 18:26:14 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-07-18 18:26:14 +0000
commit34759fb1d7deeeffdba6bf5e1de852599b908fa5 (patch)
tree7cab398520497c53f052796f12b2ac27bdb93285
parentStabilise 4.0.16 everywhere. Add 4.0.17. (diff)
downloadgentoo-2-34759fb1d7deeeffdba6bf5e1de852599b908fa5.tar.gz
gentoo-2-34759fb1d7deeeffdba6bf5e1de852599b908fa5.tar.bz2
gentoo-2-34759fb1d7deeeffdba6bf5e1de852599b908fa5.zip
Bump to the latest.
(Portage version: 2.2.0_alpha119/cvs/Linux x86_64)
-rw-r--r--net-libs/dslib/ChangeLog8
-rw-r--r--net-libs/dslib/dslib-2.1.0.ebuild34
2 files changed, 40 insertions, 2 deletions
diff --git a/net-libs/dslib/ChangeLog b/net-libs/dslib/ChangeLog
index 3d0b144f9c03..9ec7e600af40 100644
--- a/net-libs/dslib/ChangeLog
+++ b/net-libs/dslib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/dslib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/dslib/ChangeLog,v 1.10 2012/04/26 08:47:02 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/dslib/ChangeLog,v 1.11 2012/07/18 18:26:14 scarabeus Exp $
+
+*dslib-2.1.0 (18 Jul 2012)
+
+ 18 Jul 2012; Tomáš Chvátal <scarabeus@gentoo.org> +dslib-2.1.0.ebuild:
+ Bump to the latest.
26 Apr 2012; Tomáš Chvátal <scarabeus@gentoo.org> -dslib-1.7-r2.ebuild,
dslib-2.0.2.ebuild:
@@ -49,4 +54,3 @@
05 Oct 2011; Tomáš Chvátal <scarabeus@gentoo.org> +dslib-1.6.ebuild,
+metadata.xml:
Initial commit, probably usefull for czech people only.
-
diff --git a/net-libs/dslib/dslib-2.1.0.ebuild b/net-libs/dslib/dslib-2.1.0.ebuild
new file mode 100644
index 000000000000..88bfaefc1a5e
--- /dev/null
+++ b/net-libs/dslib/dslib-2.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/dslib/dslib-2.1.0.ebuild,v 1.1 2012/07/18 18:26:14 scarabeus Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="*"
+
+inherit distutils
+
+DESCRIPTION="Library to access Czech eGov system \"Datove schranky\""
+HOMEPAGE="http://labs.nic.cz/page/969/datovka/"
+SRC_URI="http://www.nic.cz/public_media/datove_schranky/releases/datovka-2.1.1/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/pyasn1
+ dev-python/pyopenssl
+ dev-python/sudsds
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 "${WORKDIR}"
+}