summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-03-28 05:04:43 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-03-28 05:04:43 +0000
commit3525b8cacca4ea7fab40881b50810dba95a61b98 (patch)
treed332103acb579edab701f808170a024c81c6cfad
parentMove to ~arch. (diff)
downloadgentoo-2-3525b8cacca4ea7fab40881b50810dba95a61b98.tar.gz
gentoo-2-3525b8cacca4ea7fab40881b50810dba95a61b98.tar.bz2
gentoo-2-3525b8cacca4ea7fab40881b50810dba95a61b98.zip
Version bump, wrt bug #428214
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
-rw-r--r--dev-libs/antlr-c/ChangeLog9
-rw-r--r--dev-libs/antlr-c/antlr-c-3.4.ebuild66
-rw-r--r--dev-libs/antlr-c/antlr-c-3.5.ebuild66
3 files changed, 140 insertions, 1 deletions
diff --git a/dev-libs/antlr-c/ChangeLog b/dev-libs/antlr-c/ChangeLog
index c19a9acce439..91a7681529d2 100644
--- a/dev-libs/antlr-c/ChangeLog
+++ b/dev-libs/antlr-c/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/antlr-c
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/antlr-c/ChangeLog,v 1.4 2013/02/03 11:22:03 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/antlr-c/ChangeLog,v 1.5 2013/03/28 05:04:43 pinkbyte Exp $
+
+*antlr-c-3.5 (28 Mar 2013)
+*antlr-c-3.4 (28 Mar 2013)
+
+ 28 Mar 2013; Sergey Popov <pinkbyte@gentoo.org> +antlr-c-3.4.ebuild,
+ +antlr-c-3.5.ebuild:
+ Version bump, wrt bug #428214
03 Feb 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due #333419
diff --git a/dev-libs/antlr-c/antlr-c-3.4.ebuild b/dev-libs/antlr-c/antlr-c-3.4.ebuild
new file mode 100644
index 000000000000..4380d6143aeb
--- /dev/null
+++ b/dev-libs/antlr-c/antlr-c-3.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/antlr-c/antlr-c-3.4.ebuild,v 1.1 2013/03/28 05:04:43 pinkbyte Exp $
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils eutils
+
+MY_P="antlr-${PV}"
+DESCRIPTION="The ANTLR3 C Runtime"
+HOMEPAGE="https://github.com/antlr/antlr3/tree/master/runtime/C"
+SRC_URI="https://github.com/antlr/antlr3/archive/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug debugger doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+S="${WORKDIR}/antlr3-${MY_P}/runtime/C"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+PATCHES=( "${FILESDIR}/${PN}-3.3-cflags.patch" )
+
+src_prepare() {
+ sed -i -e '/^QUIET/s/NO/YES/' doxyfile || die 'sed on doxyfile failed'
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable debug debuginfo)
+ $(use_enable debugger antlrdebug)
+ )
+ if use amd64 || use ia64; then
+ myeconfargs+=( --enable-64bit )
+ else
+ myeconfargs+=( --disable-64bit )
+ fi
+
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ if use doc; then
+ einfo "Generating documentation API ..."
+ doxygen -u doxyfile
+ doxygen doxyfile || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use doc; then
+ dohtml api/*
+ fi
+}
diff --git a/dev-libs/antlr-c/antlr-c-3.5.ebuild b/dev-libs/antlr-c/antlr-c-3.5.ebuild
new file mode 100644
index 000000000000..0a6ff268af5f
--- /dev/null
+++ b/dev-libs/antlr-c/antlr-c-3.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/antlr-c/antlr-c-3.5.ebuild,v 1.1 2013/03/28 05:04:43 pinkbyte Exp $
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils eutils
+
+MY_P="antlr-${PV}"
+DESCRIPTION="The ANTLR3 C Runtime"
+HOMEPAGE="https://github.com/antlr/antlr3/tree/master/runtime/C"
+SRC_URI="https://github.com/antlr/antlr3/archive/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug debugger doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+S="${WORKDIR}/antlr3-${MY_P}/runtime/C"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+PATCHES=( "${FILESDIR}/${PN}-3.3-cflags.patch" )
+
+src_prepare() {
+ sed -i -e '/^QUIET/s/NO/YES/' doxyfile || die 'sed on doxyfile failed'
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable debug debuginfo)
+ $(use_enable debugger antlrdebug)
+ )
+ if use amd64 || use ia64; then
+ myeconfargs+=( --enable-64bit )
+ else
+ myeconfargs+=( --disable-64bit )
+ fi
+
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ if use doc; then
+ einfo "Generating documentation API ..."
+ doxygen -u doxyfile
+ doxygen doxyfile || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use doc; then
+ dohtml api/*
+ fi
+}