summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-15 00:51:03 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-15 00:51:03 +0000
commit3747d3dd21793e252e049bdacf06f28e49c4dbdb (patch)
tree8e28c30965b2bc514d7155655754ea8495cb821c
parentremove ${D} for new eclass. (diff)
downloadgentoo-2-3747d3dd21793e252e049bdacf06f28e49c4dbdb.tar.gz
gentoo-2-3747d3dd21793e252e049bdacf06f28e49c4dbdb.tar.bz2
gentoo-2-3747d3dd21793e252e049bdacf06f28e49c4dbdb.zip
Fix PIC handling on AMD64 systems when PIE is enabled, bug #122437. Many thanks to Chris White for helping testing.
(Portage version: 2.1_pre6-r2)
-rw-r--r--media-tv/tvtime/ChangeLog6
-rw-r--r--media-tv/tvtime/files/tvtime-pic.patch2
2 files changed, 6 insertions, 2 deletions
diff --git a/media-tv/tvtime/ChangeLog b/media-tv/tvtime/ChangeLog
index 8aa705239479..1ab298c93c12 100644
--- a/media-tv/tvtime/ChangeLog
+++ b/media-tv/tvtime/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/tvtime
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/ChangeLog,v 1.24 2006/02/07 20:44:37 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/ChangeLog,v 1.25 2006/03/15 00:51:03 flameeyes Exp $
+
+ 15 Mar 2006; Diego Pettenò <flameeyes@gentoo.org> files/tvtime-pic.patch:
+ Fix PIC handling on AMD64 systems when PIE is enabled, bug #122437. Many
+ thanks to Chris White for helping testing.
07 Feb 2006; Simon Stelling <blubb@gentoo.org> tvtime-0.9.15.ebuild:
stable on amd64
diff --git a/media-tv/tvtime/files/tvtime-pic.patch b/media-tv/tvtime/files/tvtime-pic.patch
index ec3779a87bbf..00b040e60af9 100644
--- a/media-tv/tvtime/files/tvtime-pic.patch
+++ b/media-tv/tvtime/files/tvtime-pic.patch
@@ -5,7 +5,7 @@
uint32_t caps;
-#ifndef PIC
-+#if !defined(PIC) && !defined(__PIC__)
++#if !defined(__PIC__) || defined(__x86_64__)
#define cpuid(op,eax,ebx,ecx,edx) \
__asm__ ("cpuid" \
: "=a" (eax), \