summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2007-09-29 10:12:57 +0000
committerRémi Cardona <remi@gentoo.org>2007-09-29 10:12:57 +0000
commit37ff2431eddba5daada5e7b9f36399d450ecab02 (patch)
tree8aa377a554d72aad380ce16aa6f299507c1f74b3
parentsparc stable wrt #191615 (diff)
downloadgentoo-2-37ff2431eddba5daada5e7b9f36399d450ecab02.tar.gz
gentoo-2-37ff2431eddba5daada5e7b9f36399d450ecab02.tar.bz2
gentoo-2-37ff2431eddba5daada5e7b9f36399d450ecab02.zip
gnome-extra/gcalctool: Fix compatibility with gtk+ 2.12 (bug #193701)
(Portage version: 2.1.3.10)
-rw-r--r--gnome-extra/gcalctool/ChangeLog9
-rw-r--r--gnome-extra/gcalctool/files/digest-gcalctool-5.9.14-r13
-rw-r--r--gnome-extra/gcalctool/files/gcalctool-5.9.14-gtk+-2.12.0-compat.patch14
-rw-r--r--gnome-extra/gcalctool/gcalctool-5.9.14-r1.ebuild39
4 files changed, 64 insertions, 1 deletions
diff --git a/gnome-extra/gcalctool/ChangeLog b/gnome-extra/gcalctool/ChangeLog
index b631372dd444..1dc58afe1d75 100644
--- a/gnome-extra/gcalctool/ChangeLog
+++ b/gnome-extra/gcalctool/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/gcalctool
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gcalctool/ChangeLog,v 1.138 2007/09/22 08:06:24 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gcalctool/ChangeLog,v 1.139 2007/09/29 10:12:56 remi Exp $
+
+*gcalctool-5.9.14-r1 (29 Sep 2007)
+
+ 29 Sep 2007; Rémi Cardona <remi@gentoo.org>
+ +files/gcalctool-5.9.14-gtk+-2.12.0-compat.patch,
+ +gcalctool-5.9.14-r1.ebuild:
+ Fix compatibility with gtk+ 2.12 (bug #193701)
22 Sep 2007; Tom Gall <tgall@gentoo.org> gcalctool-5.9.14.ebuild:
stable on ppc64
diff --git a/gnome-extra/gcalctool/files/digest-gcalctool-5.9.14-r1 b/gnome-extra/gcalctool/files/digest-gcalctool-5.9.14-r1
new file mode 100644
index 000000000000..fc5f8de7dd8a
--- /dev/null
+++ b/gnome-extra/gcalctool/files/digest-gcalctool-5.9.14-r1
@@ -0,0 +1,3 @@
+MD5 dd51bc2fa9e53a3b6d7b3264e1059296 gcalctool-5.9.14.tar.bz2 1189518
+RMD160 a790a820c1b2e7321badc2ef3aef4f814159baac gcalctool-5.9.14.tar.bz2 1189518
+SHA256 f94a63f6860bfd3d868d8419de2a9d709381eeb44d8535565629525dbc9729c5 gcalctool-5.9.14.tar.bz2 1189518
diff --git a/gnome-extra/gcalctool/files/gcalctool-5.9.14-gtk+-2.12.0-compat.patch b/gnome-extra/gcalctool/files/gcalctool-5.9.14-gtk+-2.12.0-compat.patch
new file mode 100644
index 000000000000..ff134afee76c
--- /dev/null
+++ b/gnome-extra/gcalctool/files/gcalctool-5.9.14-gtk+-2.12.0-compat.patch
@@ -0,0 +1,14 @@
+--- gcalctool/Makefile.am.orig 2007-09-27 18:05:53.000000000 -0500
++++ gcalctool/Makefile.am 2007-09-27 18:06:10.000000000 -0500
+@@ -2,11 +2,6 @@
+
+ INCLUDES = \
+ -I$(includedir) \
+- -DG_DISABLE_DEPRECATED \
+- -DGDK_PIXBUF_DISABLE_DEPRECATED \
+- -DGDK_DISABLE_DEPRECATED \
+- -DGNOME_DISABLE_DEPRECATED \
+- -DGTK_DISABLE_DEPRECATED \
+ -DPACKAGE_DATA_DIR=\""$(datadir)"\" \
+ -DPACKAGE_LOCALE_DIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
+ -DPACKAGE_PIXMAP_DIR=\""$(prefix)/$(DATADIRNAME)/pixmaps"\" \
diff --git a/gnome-extra/gcalctool/gcalctool-5.9.14-r1.ebuild b/gnome-extra/gcalctool/gcalctool-5.9.14-r1.ebuild
new file mode 100644
index 000000000000..d42317367c9f
--- /dev/null
+++ b/gnome-extra/gcalctool/gcalctool-5.9.14-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gcalctool/gcalctool-5.9.14-r1.ebuild,v 1.1 2007/09/29 10:12:56 remi Exp $
+
+inherit eutils autotools gnome2
+
+DESCRIPTION="A calculator application for GNOME"
+HOMEPAGE="http://calctool.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2
+ >=dev-libs/atk-1.5
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gconf-2
+ !<gnome-extra/gnome-utils-2.3"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ app-text/scrollkeeper
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ >=app-text/gnome-doc-utils-0.3.2"
+
+DOCS="AUTHORS ChangeLog* MAINTAINERS NEWS README TODO"
+
+src_unpack() {
+ gnome2_src_unpack
+ epatch "${FILESDIR}/${P}-gtk+-2.12.0-compat.patch"
+ AT_M4DIR="m4" eautoreconf
+}
+
+pkg_setup() {
+ G2CONF="${G2CONF} --enable-gnome"
+}