summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-08-11 23:46:31 +0000
committerAron Griffis <agriffis@gentoo.org>2005-08-11 23:46:31 +0000
commit3b52c14e667a01d2b0897c9c3af65291fd55ed62 (patch)
tree895720d5ff5c3c6e32ef7e03a7be711c6df9efa6
parentVersion bump (diff)
downloadgentoo-2-3b52c14e667a01d2b0897c9c3af65291fd55ed62.tar.gz
gentoo-2-3b52c14e667a01d2b0897c9c3af65291fd55ed62.tar.bz2
gentoo-2-3b52c14e667a01d2b0897c9c3af65291fd55ed62.zip
Fix configure.in to work correctly when --without-sasl is specified
(Portage version: 2.0.51.22-r2)
-rw-r--r--mail-client/mutt/ChangeLog6
-rw-r--r--mail-client/mutt/files/mutt-1.5.9-sasl.patch40
-rw-r--r--mail-client/mutt/mutt-1.5.9.ebuild11
3 files changed, 53 insertions, 4 deletions
diff --git a/mail-client/mutt/ChangeLog b/mail-client/mutt/ChangeLog
index 3b2b23839938..10c3d71570e9 100644
--- a/mail-client/mutt/ChangeLog
+++ b/mail-client/mutt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-client/mutt
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/ChangeLog,v 1.54 2005/08/11 23:28:28 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/ChangeLog,v 1.55 2005/08/11 23:46:31 agriffis Exp $
+
+ 11 Aug 2005; Aron Griffis <agriffis@gentoo.org>
+ +files/mutt-1.5.9-sasl.patch, mutt-1.5.9.ebuild:
+ Fix configure.in to work correctly when --without-sasl is specified
11 Aug 2005; Aron Griffis <agriffis@gentoo.org> mutt-1.5.9.ebuild:
Disable sasl unless pop or imap is specified; it's the same as ssl or gnutls
diff --git a/mail-client/mutt/files/mutt-1.5.9-sasl.patch b/mail-client/mutt/files/mutt-1.5.9-sasl.patch
new file mode 100644
index 000000000000..dead1a793fe1
--- /dev/null
+++ b/mail-client/mutt/files/mutt-1.5.9-sasl.patch
@@ -0,0 +1,40 @@
+--- mutt-1.5.9/configure.in.sasl 2005-08-11 19:39:15.000000000 -0400
++++ mutt-1.5.9/configure.in 2005-08-11 19:39:41.499356683 -0400
+@@ -645,13 +645,13 @@
+
+ AC_ARG_WITH(sasl, AC_HELP_STRING([--with-sasl[=PFX]], [Use Cyrus SASL library for POP/IMAP authentication]),
+ [
+- if test "$need_socket" != "yes"
+- then
+- AC_MSG_ERROR([SASL support is only useful with POP or IMAP support])
+- fi
+-
+ if test "$with_sasl" != "no"
+ then
++ if test "$need_socket" != "yes"
++ then
++ AC_MSG_ERROR([SASL support is only useful with POP or IMAP support])
++ fi
++
+ if test "$with_sasl" != "yes"
+ then
+ CPPFLAGS="$CPPFLAGS -I$with_sasl/include"
+@@ -675,13 +675,13 @@
+
+ AC_ARG_WITH(sasl2, AC_HELP_STRING([--with-sasl2[=PFX]], [Use Cyrus SASL library version 2 for POP/IMAP authentication]),
+ [
+- if test "$need_socket" != "yes"
+- then
+- AC_MSG_ERROR([SASL support is only useful with POP or IMAP support])
+- fi
+-
+ if test "$with_sasl2" != "no"
+ then
++ if test "$need_socket" != "yes"
++ then
++ AC_MSG_ERROR([SASL support is only useful with POP or IMAP support])
++ fi
++
+ if test "$with_sasl2" != "yes"
+ then
+ CPPFLAGS="$CPPFLAGS -I$with_sasl2/include"
diff --git a/mail-client/mutt/mutt-1.5.9.ebuild b/mail-client/mutt/mutt-1.5.9.ebuild
index b457e92d927e..a3f3652d06cd 100644
--- a/mail-client/mutt/mutt-1.5.9.ebuild
+++ b/mail-client/mutt/mutt-1.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.5.9.ebuild,v 1.4 2005/08/11 23:28:28 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.5.9.ebuild,v 1.5 2005/08/11 23:46:31 agriffis Exp $
inherit eutils flag-o-matic
@@ -51,7 +51,8 @@ RDEPEND="nls? ( sys-devel/gettext )
gpgme? ( >=app-crypt/gpgme-0.9.0 )"
DEPEND="${RDEPEND}
net-mail/mailbase
- !vanilla? ( sys-devel/automake sys-devel/autoconf )"
+ sys-devel/autoconf
+ !vanilla? ( sys-devel/automake )"
pkg_setup() {
if ! use imap; then
@@ -65,6 +66,9 @@ pkg_setup() {
src_unpack() {
unpack ${P}i.tar.gz && cd ${S} || die "unpack failed"
+ # fix sasl support in configure.in
+ epatch ${FILESDIR}/mutt-1.5.9-sasl.patch
+
# disable sgml conversion since it fails with sgml2html
epatch ${FILESDIR}/mutt-1.5.9-nodoc.patch
@@ -85,8 +89,9 @@ src_unpack() {
autoheader || die "autoheader failed"
emake -C m4 -f Makefile.am.in || die "emake in m4 failed"
automake --foreign || die "automake failed"
- WANT_AUTOCONF=2.13 autoconf || die "autoconf failed"
fi
+
+ WANT_AUTOCONF=2.13 autoconf || die "autoconf failed"
}
src_compile() {