summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-11 19:21:26 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-11 19:21:26 +0000
commit3d43385926a13dc6881ba77fdc7763ad076aaf7a (patch)
tree51229c998c2b6f8fe1b3b51f1cc173a82d064369
parentChange ebuild to EAPI 4. (diff)
downloadgentoo-2-3d43385926a13dc6881ba77fdc7763ad076aaf7a.tar.gz
gentoo-2-3d43385926a13dc6881ba77fdc7763ad076aaf7a.tar.bz2
gentoo-2-3d43385926a13dc6881ba77fdc7763ad076aaf7a.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
-rw-r--r--net-p2p/gtk-gnutella/ChangeLog7
-rw-r--r--net-p2p/gtk-gnutella/gtk-gnutella-0.97.1.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/net-p2p/gtk-gnutella/ChangeLog b/net-p2p/gtk-gnutella/ChangeLog
index e424275d1ca8..7ca54f952111 100644
--- a/net-p2p/gtk-gnutella/ChangeLog
+++ b/net-p2p/gtk-gnutella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/gtk-gnutella
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/ChangeLog,v 1.114 2011/07/18 10:41:11 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/ChangeLog,v 1.115 2011/09/11 19:21:26 graaff Exp $
+
+*gtk-gnutella-0.97.1 (11 Sep 2011)
+
+ 11 Sep 2011; Hans de Graaff <graaff@gentoo.org> +gtk-gnutella-0.97.1.ebuild:
+ Version bump.
18 Jul 2011; Hans de Graaff <graaff@gentoo.org> gtk-gnutella-0.97.ebuild:
Drop libxml2 dependency, it is no longer needed.
diff --git a/net-p2p/gtk-gnutella/gtk-gnutella-0.97.1.ebuild b/net-p2p/gtk-gnutella/gtk-gnutella-0.97.1.ebuild
new file mode 100644
index 000000000000..ba1c0dd41421
--- /dev/null
+++ b/net-p2p/gtk-gnutella/gtk-gnutella-0.97.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/gtk-gnutella-0.97.1.ebuild,v 1.1 2011/09/11 19:21:26 graaff Exp $
+
+EAPI="2"
+
+inherit eutils
+
+IUSE="nls dbus ssl +gtk"
+
+DESCRIPTION="A GTK+ Gnutella client"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://gtk-gnutella.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ gtk? ( >=x11-libs/gtk+-2.2.1:2 )
+ dbus? ( >=sys-apps/dbus-0.35.2 )
+ ssl? ( >=net-libs/gnutls-1.0.16 )
+ nls? ( >=sys-devel/gettext-0.11.5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ # The build script does not support the equivalent --enable
+ # options so we must construct the configuration by hand.
+
+ local myconf
+
+ if ! use nls; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ if ! use dbus; then
+ myconf="${myconf} --disable-dbus"
+ fi
+
+ if ! use ssl; then
+ myconf="${myconf} --disable-gnutls"
+ fi
+
+ if use gtk; then
+ myconf="${myconf} --gtk2"
+ else
+ myconf="${myconf} --topless"
+ fi
+
+ ./build.sh --configure-only --prefix="/usr" ${myconf}
+}
+
+src_install() {
+ dodir /usr/bin
+ emake INSTALL_PREFIX="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog README TODO
+
+ # Touch the symbols file into the future to avoid warnings from
+ # gtk-gnutella later on, since we will most likely strip the binary.
+ touch --date="next minute" "${D}/usr/lib/gtk-gnutella/gtk-gnutella.nm" || die
+}