summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-11-06 13:14:27 +0000
committerRoy Marples <uberlord@gentoo.org>2006-11-06 13:14:27 +0000
commit3e4a9f3b7d54bf88c3e7c80868a03061b4e24c16 (patch)
tree3cbf5f309db2c63c1bb5dc5f727c3a9bdf9e0cc9
parentStable on ppc64; bug #153748 (diff)
downloadgentoo-2-3e4a9f3b7d54bf88c3e7c80868a03061b4e24c16.tar.gz
gentoo-2-3e4a9f3b7d54bf88c3e7c80868a03061b4e24c16.tar.bz2
gentoo-2-3e4a9f3b7d54bf88c3e7c80868a03061b4e24c16.zip
Fix a few key bugs regarding stage building on Linux and service ordering.
(Portage version: 2.1.2_rc1-r3)
-rw-r--r--sys-apps/baselayout/ChangeLog9
-rw-r--r--sys-apps/baselayout/baselayout-1.13.0_alpha5-r1.ebuild273
-rw-r--r--sys-apps/baselayout/files/baselayout-1.13.0_alpha5-2364.patch71
-rw-r--r--sys-apps/baselayout/files/digest-baselayout-1.13.0_alpha5-r13
4 files changed, 355 insertions, 1 deletions
diff --git a/sys-apps/baselayout/ChangeLog b/sys-apps/baselayout/ChangeLog
index 638f7d8f2d44..b1f5382008e6 100644
--- a/sys-apps/baselayout/ChangeLog
+++ b/sys-apps/baselayout/ChangeLog
@@ -1,10 +1,17 @@
# ChangeLog for sys-apps/baselayout
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.360 2006/11/02 16:45:49 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.361 2006/11/06 13:14:27 uberlord Exp $
# See the rc-scripts ChangeLog in subversion for release info:
# http://sources.gentoo.org/viewcvs.py/*checkout*/baselayout/trunk/ChangeLog
+*baselayout-1.13.0_alpha5-r1 (06 Nov 2006)
+
+ 06 Nov 2006; Roy Marples <uberlord@gentoo.org>
+ +files/baselayout-1.13.0_alpha5-2364.patch,
+ +baselayout-1.13.0_alpha5-r1.ebuild:
+ Fix a few key bugs regarding stage building on Linux and service ordering.
+
*baselayout-1.13.0_alpha5 (02 Nov 2006)
02 Nov 2006; Roy Marples <uberlord@gentoo.org>
diff --git a/sys-apps/baselayout/baselayout-1.13.0_alpha5-r1.ebuild b/sys-apps/baselayout/baselayout-1.13.0_alpha5-r1.ebuild
new file mode 100644
index 000000000000..c26b6284cc61
--- /dev/null
+++ b/sys-apps/baselayout/baselayout-1.13.0_alpha5-r1.ebuild
@@ -0,0 +1,273 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.13.0_alpha5-r1.ebuild,v 1.1 2006/11/06 13:14:27 uberlord Exp $
+
+inherit flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="Filesystem baselayout and init scripts"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~uberlord/baselayout/${P}.tar.bz2
+ http://dev.gentoo.org/~azarah/baselayout/${P}.tar.bz2
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="bootstrap build pam static unicode kernel_linux kernel_FreeBSD"
+
+# This version of baselayout needs awk in /bin, but as we do not have
+# a c++ compiler during bootstrap, we cannot depend on it if "bootstrap"
+# or "build" are in USE.
+RDEPEND="kernel_linux? ( >=sys-apps/sysvinit-2.86-r3 )
+ !build? (
+ !bootstrap? (
+ >=sys-libs/readline-5.0-r1
+ >=app-shells/bash-3.2_p3-r1
+ kernel_linux? (
+ >=sys-apps/coreutils-5.2.1
+ )
+ kernel_FreeBSD? (
+ sys-process/fuser-bsd
+ sys-process/pidof-bsd
+ )
+ )
+ )
+ pam? ( virtual/pam )
+ !<net-misc/dhcpcd-2.0.0"
+DEPEND="virtual/os-headers"
+PROVIDE="virtual/baselayout"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix a few key bugs
+ epatch "${FILESDIR}/${P}"-2364.patch
+
+ # Setup unicode defaults for silly unicode users
+ if use unicode ; then
+ sed -i -e '/^UNICODE=/s:no:yes:' etc/rc.conf
+ fi
+
+ # SPARC does not like stty, so we disable RC_INTERACTIVE which requires it
+ # see Gentoo bug #104067.
+ if use sparc ; then \
+ sed -i -e '/^KEYMAP=/s:us:sunkeymap:' etc/conf.d/keymaps || die
+ sed -i -e '/^RC_INTERACTIVE=/s:yes:no:' etc/conf.d/rc || die
+ fi
+}
+
+make_opts() {
+ # Standard options
+ local opts="DESTDIR=\"${ROOT}\" ARCH=\"$(tc-arch)\""
+ local libdir="lib"
+
+ [[ ${SYMLINK_LIB} == "yes" ]] && libdir=$(get_abi_LIBDIR "${DEFAULT_ABI}")
+
+ opts="${opts} LIB=${libdir}"
+
+ if use kernel_linux ; then
+ opts="${opts} OS=Linux"
+ else
+ opts="${opts} OS=BSD"
+ fi
+
+ use pam && opts="${opts} HAVE_PAM=1"
+
+ echo "${opts}"
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ emake $(make_opts) || die
+}
+
+# Support function for remapping old wireless dns vars
+remap_dns_vars() {
+ if [[ -f "${ROOT}/etc/conf.d/$1" ]]; then
+ sed -e 's/\<domain_/dns_domain_/g' \
+ -e 's/\<mac_domain_/mac_dns_domain_/g' \
+ -e 's/\<nameservers_/dns_servers_/g' \
+ -e 's/\<mac_nameservers_/mac_dns_servers_/g' \
+ -e 's/\<searchdomains_/dns_search_domains_/g' \
+ -e 's/\<mac_searchdomains_/mac_dns_search_domains_/g' \
+ "${ROOT}/etc/conf.d/$1" > "${IMAGE}/etc/conf.d/$1"
+ fi
+}
+
+pkg_preinst() {
+ # Move our makefiles to a temporay location
+ mv "${D}"/usr/share/baselayout/{Makefile,default.mk,runlevels}* "${T}"
+
+ # Change some vars introduced in baselayout-1.11.0 before we go stable
+ # The new names make more sense and allow nis_domain
+ # for use in baselayout-1.12.0
+ remap_dns_vars net
+ remap_dns_vars wireless
+}
+
+src_install() {
+ make $(make_opts) DESTDIR="${D}" install
+ dodoc ChangeLog COPYRIGHT
+
+ # Should this belong in another ebuild? Like say binutils?
+ # List all the multilib libdirs in /etc/env/04multilib (only if they're
+ # actually different from the normal
+ if has_multilib_profile || [[ $(get_libdir) != "lib" || -n ${CONF_MULTILIBDIR} ]]; then
+ local libdirs="$(get_all_libdirs)" libdirs_env=
+ : ${libdirs:=lib} # it isn't that we don't trust multilib.eclass...
+ for dir in ${libdirs}; do
+ libdirs_env=${libdirs_env:+$libdirs_env:}/${dir}:/usr/${dir}:/usr/local/${dir}
+ done
+
+ # Special-case uglyness... For people updating from lib32 -> lib amd64
+ # profiles, keep lib32 in the search path while it's around
+ if has_multilib_profile && [ -d /lib32 -o -d /usr/lib32 ] && ! hasq lib32 ${libdirs}; then
+ libdirs_env="${libdirs_env}:/lib32:/usr/lib32:/usr/local/lib32"
+ fi
+ echo "LDPATH=\"${libdirs_env}\"" > "${D}"/etc/env.d/04multilib
+ fi
+
+ # rc-scripts version for testing of features that *should* be present
+ echo "Gentoo Base System version ${PV}" > "${D}"/etc/gentoo-release
+
+ # Remove the installed runlevels, as we don't know about $ROOT yet
+ rm -rf "${D}/etc/runlevels"
+
+ # Copy the make files to /usr/share/baselayout so we can re-use them in
+ # postinst, otherwise binpkg will break.
+ insinto /usr/share/baselayout
+ doins -r Makefile default.mk runlevels*
+}
+
+pkg_postinst() {
+ # We need to install directories and maybe some dev nodes when building
+ # stages, but they cannot be in CONTENTS.
+ # Also, we cannot reference $S as binpkg will break so we do this.
+ if use build || use bootstrap ; then
+ make -C "${T}" $(make_opts) layout || die "failed to layout filesystem"
+ fi
+
+ # Make our runlevels if they don't exist
+ if [[ ! -e ${ROOT}etc/runlevels ]] ; then
+ einfo "Making default runlevels"
+ make -C "${T}" $(make_opts) runlevels_install >/dev/null
+ fi
+
+ if use kernel_linux ; then
+ if use build || use bootstrap ; then
+ # Create base directories
+ if [[ ! -e ${ROOT}/dev/.udev && ! -e ${ROOT}/dev/.devfsd ]] ; then
+ einfo "Creating dev nodes"
+ PATH="${ROOT}"/sbin:${PATH} make -C "${T}" $(make_opts) \
+ dev || die "failed to create /dev nodes"
+ fi
+ fi
+ fi
+
+ # We installed some files to /usr/share/baselayout instead of /etc to stop
+ # (1) overwriting the user's settings
+ # (2) screwing things up when attempting to merge files
+ # (3) accidentally packaging up personal files with quickpkg
+ # If they don't exist then we install them
+ for x in master.passwd passwd shadow group fstab ; do
+ [[ -e "${ROOT}etc/${x}" ]] && continue
+ [[ -e "${ROOT}usr/share/baselayout/${x}" ]] || continue
+ cp -p "${ROOT}usr/share/baselayout/${x}" ${ROOT}etc
+ done
+
+ # Reload init to fix unmounting problems of / on next reboot.
+ # This is really needed, as without the new version of init cause init
+ # not to quit properly on reboot, and causes a fsck of / on next reboot.
+ if [[ ${ROOT} == / ]] && ! use build && ! use bootstrap; then
+ # We need to copy svcdir if it's empty
+ if [[ ! -e ${ROOT}lib/rcscripts/init.d/deptree ]] ; then
+ (
+ source "${ROOT}etc/conf.d/rc"
+ svcdir="${svcdir:-/var/lib/init.d}"
+ if [[ -e ${ROOT}${svcdir}/deptree ]] ; then
+ cp -RPp "${ROOT}${svcdir}"/* ${ROOT}lib/rcscripts/init.d
+ fi
+ )
+ fi
+
+ # Regenerate init.d dependency tree
+ /sbin/depscan.sh --update >/dev/null
+
+ # Regenerate /etc/modules.conf, else it will fail at next boot
+ if [[ -x /sbin/modules-update ]] ; then
+ einfo "Updating module dependencies..."
+ /sbin/modules-update force >/dev/null
+ fi
+ else
+ rm -f "${ROOT}"/etc/modules.conf
+ fi
+
+ # This is also written in src_install (so it's in CONTENTS), but
+ # write it here so that the new version is immediately in the file
+ # (without waiting for the user to do etc-update)
+ rm -f "${ROOT}"/etc/._cfg????_gentoo-release
+ echo "Gentoo Base System version ${PV}" > "${ROOT}"/etc/gentoo-release
+
+ echo
+ einfo "Please be sure to update all pending '._cfg*' files in /etc,"
+ einfo "else things might break at your next reboot! You can use 'etc-update'"
+ einfo "to accomplish this:"
+ einfo
+ einfo " # etc-update"
+ echo
+
+ local lo="net.lo0"
+ use kernel_linux && lo="net.lo"
+ for f in ${ROOT}etc/init.d/net.*; do
+ [[ -L ${f} ]] && continue
+ echo
+ einfo "WARNING: You have older net.* files in ${ROOT}etc/init.d/"
+ einfo "They need to be converted to symlinks to ${lo}. If you haven't"
+ einfo "made personal changes to those files, you can update with the"
+ einfo "following command:"
+ einfo
+ einfo " /bin/ls ${ROOT}etc/init.d/net.* | grep -v '/${lo}$' | xargs -n1 ln -sfvn ${lo}"
+ echo
+ break
+ done
+
+ if sed -e 's/#.*//' "${ROOT}"etc/conf.d/{net,wireless} 2>/dev/null \
+ | egrep -q '\<(domain|nameservers|searchdomains)_' ; then
+ echo
+ ewarn "You have depreciated variables in ${ROOT}etc/conf.d/net"
+ ewarn "or ${ROOT}etc/conf.d/wireless"
+ ewarn
+ ewarn "domain_* -> dns_domain_*"
+ ewarn "nameservers_* -> dns_servers_*"
+ ewarn "searchdomains_* -> dns_search_domains_*"
+ ewarn
+ ewarn "They have been converted for you - ensure that you"
+ ewarn "update them via 'etc-update'"
+ echo
+ fi
+
+ if sed -e 's/#.*//' "${ROOT}"etc/conf.d/net 2>/dev/null \
+ | egrep -q '\<(ifconfig|aliases|broadcasts|netmasks|inet6|ipaddr|iproute)_'; then
+ echo
+ ewarn "You are using deprecated variables in ${ROOT}etc/conf.d/net"
+ ewarn
+ ewarn "You are advised to review the new configuration variables as"
+ ewarn "found in ${ROOT}etc/conf.d/net.example as there is no"
+ ewarn "guarantee that they will work in future versions."
+ echo
+ fi
+
+ # Remove old stuff that may cause problems.
+ if [[ -e "${ROOT}"/etc/env.d/01hostname ]] ; then
+ rm -f "${ROOT}"/etc/env.d/01hostname
+ fi
+ if [[ -e "${ROOT}"/etc/init.d/domainname ]] ; then
+ rm -f "${ROOT}"/etc/{conf.d,init.d}/domainname \
+ "${ROOT}"/etc/runlevels/*/domainname
+ ewarn "The domainname init script has been removed in this version."
+ ewarn "Consult ${ROOT}etc/conf.d/net.example for details about how"
+ ewarn "to apply dns/nis information to the loopback interface."
+ fi
+}
diff --git a/sys-apps/baselayout/files/baselayout-1.13.0_alpha5-2364.patch b/sys-apps/baselayout/files/baselayout-1.13.0_alpha5-2364.patch
new file mode 100644
index 000000000000..84ecf7d52e24
--- /dev/null
+++ b/sys-apps/baselayout/files/baselayout-1.13.0_alpha5-2364.patch
@@ -0,0 +1,71 @@
+Index: Makefile
+===================================================================
+--- Makefile (revision 2359)
++++ Makefile (working copy)
+@@ -23,7 +23,7 @@
+ /var/lock /var/run
+
+ ifeq ($(OS),Linux)
+- KEEP_DIRS += /dev /proc /sys
++ KEEP_DIRS += /dev /sys
+ NET_LO = net.lo
+ endif
+ ifneq ($(OS),Linux)
+Index: ChangeLog
+===================================================================
+--- ChangeLog (revision 2359)
++++ ChangeLog (working copy)
+@@ -1,6 +1,11 @@
+ # ChangeLog for Gentoo System Intialization ("rc") scripts
+ # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPLv2
+
++ 05 Nov 2006; Roy Marples <uberlord@gentoo.org>:
++
++ Don't create /proc on Linux as build scripts like to handle it now.
++ Fixes #154126.
++
+ * baselayout-1.13.0_alpha5 (02 Nov 2006)
+
+ 02 Nov 2006; Roy Marples <uberlord@gentoo.org>:
+Index: sbin/rc
+===================================================================
+--- sbin/rc (revision 2359)
++++ sbin/rc (working copy)
+@@ -267,7 +267,7 @@
+
+ for x in $(dolisting "${svcdir}/inactive/") \
+ $(dolisting "${svcdir}/started/") ; do
+- list="${list} ${x##*/}"
++ list="${x##*/} ${list}"
+ done
+
+ [[ -n ${list} ]] && reverse_list $(rc-depend -ineed -iuse -iafter ${list})
+@@ -442,7 +442,7 @@
+ rm -rf "${svcdir}/failed" &>/dev/null
+
+ # If $svcdir is mounted in ram, save it back to disk and unmount
+-if [[ $'\n'$(get_mounts) =~ $'\n'"${svcdir} " ]] ; then
++if [[ $'\n'$(get_mounts) =~ $'\n'${svcdir}\ ]] ; then
+ # Function to show the timeout message
+ timeout=
+ do_timeout() {
+Index: sbin/depscan.sh
+===================================================================
+--- sbin/depscan.sh (revision 2359)
++++ sbin/depscan.sh (working copy)
+@@ -149,6 +149,7 @@
+ if [[ ${retval} == "0" ]] ; then
+ DEPTREE="deptree"
+ export DEPTREE
++ cd /etc/init.d
+ bash "${mysvcdir}/depcache" | \
+ awk \
+ -f /lib/rcscripts/awk/functions.awk \
+@@ -187,6 +188,7 @@
+ if [[ ${retval} == "0" ]] ; then
+ DEPTREE="netdeptree"
+ export DEPTREE
++ cd "${svclib}/net"
+ bash "${mysvcdir}/netdepcache" | \
+ awk \
+ -f /lib/rcscripts/awk/functions.awk \
diff --git a/sys-apps/baselayout/files/digest-baselayout-1.13.0_alpha5-r1 b/sys-apps/baselayout/files/digest-baselayout-1.13.0_alpha5-r1
new file mode 100644
index 000000000000..1cb36c05fbb1
--- /dev/null
+++ b/sys-apps/baselayout/files/digest-baselayout-1.13.0_alpha5-r1
@@ -0,0 +1,3 @@
+MD5 2e6ef285409b00b435121f9326eab2d1 baselayout-1.13.0_alpha5.tar.bz2 255507
+RMD160 bd0d391abd8cee745dfdce502d3ca78bdb7013f3 baselayout-1.13.0_alpha5.tar.bz2 255507
+SHA256 987e378072608480f956ff32a6c5851e98ac7c2c6653d18148bd66681592a23e baselayout-1.13.0_alpha5.tar.bz2 255507