summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2002-10-05 14:01:08 +0000
committerMichael Imhof <tantive@gentoo.org>2002-10-05 14:01:08 +0000
commit41dc77c4cbfc658da2b1c94855fbdcc2733d5c0d (patch)
treeeb82c0378ef8966792b2d1b6ff15c143b842d146
parentMasked usermode-sources-2.4.19-r9 and openmosix-sources-2.4.19-r6 (diff)
downloadgentoo-2-41dc77c4cbfc658da2b1c94855fbdcc2733d5c0d.tar.gz
gentoo-2-41dc77c4cbfc658da2b1c94855fbdcc2733d5c0d.tar.bz2
gentoo-2-41dc77c4cbfc658da2b1c94855fbdcc2733d5c0d.zip
Version bumped
-rw-r--r--sys-kernel/usermode-sources/ChangeLog9
-rw-r--r--sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r92
-rw-r--r--sys-kernel/usermode-sources/usermode-sources-2.4.19-r9.ebuild63
3 files changed, 71 insertions, 3 deletions
diff --git a/sys-kernel/usermode-sources/ChangeLog b/sys-kernel/usermode-sources/ChangeLog
index afc7d6c1bff8..bb017f30728b 100644
--- a/sys-kernel/usermode-sources/ChangeLog
+++ b/sys-kernel/usermode-sources/ChangeLog
@@ -1,18 +1,21 @@
# ChangeLog for sys-kernel/usermode-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/usermode-sources/ChangeLog,v 1.4 2002/09/10 21:14:21 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/usermode-sources/ChangeLog,v 1.5 2002/10/05 14:01:08 tantive Exp $
+*usermode-sources-2.4.19-rX (05 Oct2002)
+ 05 Oct 2002; Michael Imhof <tantive@gentoo.org>
+ Version bumped, -rX contains uml-patch-2.4.19-rX
*usermode-sources-2.4.19-r2 (10 Sep 2002)
10 Sep 2002; Michael Imhof <tantive@gentoo.org>
- Version bumped, including um-patch-2.4.19-2
+ Version bumped, including uml-patch-2.4.19-2
*usermode-sources-2.4.19-r1 (10 Sep 2002)
10 Sep 2002; Michael Imhof <tantive@gentoo.org>
- Version bumped, including um-patch-2.4.19-1
+ Version bumped, including uml-patch-2.4.19-1
*usermode-sources-2.4.18-r2 (23 Jul 2002)
diff --git a/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r9 b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r9
new file mode 100644
index 000000000000..a485eef34616
--- /dev/null
+++ b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r9
@@ -0,0 +1,2 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 b9b9b1f0af29e2db3bda43a47d772b27 uml-patch-2.4.19-9.bz2 144622
diff --git a/sys-kernel/usermode-sources/usermode-sources-2.4.19-r9.ebuild b/sys-kernel/usermode-sources/usermode-sources-2.4.19-r9.ebuild
new file mode 100644
index 000000000000..922460574570
--- /dev/null
+++ b/sys-kernel/usermode-sources/usermode-sources-2.4.19-r9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/usermode-sources/usermode-sources-2.4.19-r9.ebuild,v 1.1 2002/10/05 14:01:08 tantive Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=${PV}
+KV=${PVR}
+UML_PATCH="uml-patch-${PV}-`echo ${PR}|sed -e 's:r\+:\1:'`"
+S=${WORKDIR}/linux-${KV}
+
+# What's in this kernel?
+
+# INCLUDED:
+# User mode linux patch
+# http://user-mode-linux.sourceforge.net
+# UML clashes with the current Gentoo patch, so I've ignored it for now.
+
+DESCRIPTION="Full (vanilla) sources for the User Mode Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://uml-pub.ists.dartmouth.edu/uml/${UML_PATCH}.bz2"
+HOMEPAGE="http://www.kernel.org/ http://user-mode-linux.sourceforge.net"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64 -alpha"
+
+#console-tools is needed to solve the loadkeys fiasco.
+#binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+DEPEND=">=sys-devel/binutils-2.11.90.0.31 sys-devel/perl"
+RDEPEND=">=sys-libs/ncurses-5.2"
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${S}
+ bzcat ${DISTDIR}/${UML_PATCH}.bz2 | patch -d ${S} -p1
+ echo "Preparing for compilation..."
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+}
+
+src_compile() {
+ echo "Nothing to compile. That's up to the user"
+}
+
+src_install() {
+ dodir /usr/src/uml
+ cd ${S}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src/uml
+ cd ${D}/usr/src/uml
+ ln -sf linux-${KV} linux
+}
+
+