summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-05-04 07:30:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-05-04 07:30:16 +0000
commit427de80428da4dbac646452ee29f50ebbac4e789 (patch)
tree95dfb5d4c8f1b8ab3292b69760325086290c4c22
parentdev-util/pkgconfig -> virtual/pkgconfig (diff)
downloadgentoo-2-427de80428da4dbac646452ee29f50ebbac4e789.tar.gz
gentoo-2-427de80428da4dbac646452ee29f50ebbac4e789.tar.bz2
gentoo-2-427de80428da4dbac646452ee29f50ebbac4e789.zip
Fix building with dev-libs/glib >= 2.31 wrt #412365 by Daniel Kuehn and Elis Axelsson.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
-rw-r--r--x11-misc/parcellite/ChangeLog9
-rw-r--r--x11-misc/parcellite/files/parcellite-1.0.2_rc5-glib-2.31.patch13
-rw-r--r--x11-misc/parcellite/parcellite-1.0.2_rc5.ebuild28
3 files changed, 34 insertions, 16 deletions
diff --git a/x11-misc/parcellite/ChangeLog b/x11-misc/parcellite/ChangeLog
index 551a6e3d2538..e1ce2f9abb0f 100644
--- a/x11-misc/parcellite/ChangeLog
+++ b/x11-misc/parcellite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/parcellite
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/ChangeLog,v 1.16 2011/09/10 09:50:53 hwoarang Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/ChangeLog,v 1.17 2012/05/04 07:30:16 ssuominen Exp $
+
+ 04 May 2012; Samuli Suominen <ssuominen@gentoo.org>
+ parcellite-1.0.2_rc5.ebuild, +files/parcellite-1.0.2_rc5-glib-2.31.patch:
+ Fix building with dev-libs/glib >= 2.31 wrt #412365 by Daniel Kuehn and Elis
+ Axelsson.
*parcellite-1.0.2_rc5 (10 Sep 2011)
diff --git a/x11-misc/parcellite/files/parcellite-1.0.2_rc5-glib-2.31.patch b/x11-misc/parcellite/files/parcellite-1.0.2_rc5-glib-2.31.patch
new file mode 100644
index 000000000000..7d1e8e6f7dd9
--- /dev/null
+++ b/x11-misc/parcellite/files/parcellite-1.0.2_rc5-glib-2.31.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/412365
+
+--- src/keybinder.h
++++ src/keybinder.h
+@@ -20,7 +20,7 @@
+ #ifndef __KEY_BINDER_H__
+ #define __KEY_BINDER_H__
+
+-#include <glib/gtypes.h>
++#include <glib.h>
+
+ G_BEGIN_DECLS
+
diff --git a/x11-misc/parcellite/parcellite-1.0.2_rc5.ebuild b/x11-misc/parcellite/parcellite-1.0.2_rc5.ebuild
index 3e3ef65a930d..9890078b4cd2 100644
--- a/x11-misc/parcellite/parcellite-1.0.2_rc5.ebuild
+++ b/x11-misc/parcellite/parcellite-1.0.2_rc5.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/parcellite-1.0.2_rc5.ebuild,v 1.1 2011/09/10 09:50:53 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/parcellite-1.0.2_rc5.ebuild,v 1.2 2012/05/04 07:30:16 ssuominen Exp $
EAPI=4
-inherit fdo-mime autotools
+inherit autotools eutils fdo-mime
-MY_PV="${PV/_/}"
-MY_P="${PN}-${MY_PV}"
+MY_P=${PN}-${PV/_}
DESCRIPTION="A lightweight GTK+ based clipboard manager."
HOMEPAGE="http://parcellite.sourceforge.net/"
@@ -17,25 +16,26 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="nls"
-RDEPEND=">=x11-libs/gtk+-2.10:2
- >=dev-libs/glib-2.14:2"
+RDEPEND=">=dev-libs/glib-2.14
+ >=x11-libs/gtk+-2.10:2"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
- nls? ( sys-devel/gettext
- dev-util/intltool )"
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )"
-S="${WORKDIR}"/${MY_P}
+S=${WORKDIR}/${MY_P}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-glib-2.31.patch
# Doh! Tarballs contains compiled target
emake clean
eautoreconf
}
src_configure() {
- econf \
- --disable-dependency-tracking \
- $(use_enable nls)
+ econf $(use_enable nls)
}
pkg_postinst() {