summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-04-30 18:20:50 +0000
committerPeter Volkov <pva@gentoo.org>2011-04-30 18:20:50 +0000
commit43154573a23ec1707239562e8ef827f48f088707 (patch)
tree24ecfa9c6d77d39b9cf91fdfc84c24eda0ddf781
parentDrop sparc keywords (diff)
downloadgentoo-2-43154573a23ec1707239562e8ef827f48f088707.tar.gz
gentoo-2-43154573a23ec1707239562e8ef827f48f088707.tar.bz2
gentoo-2-43154573a23ec1707239562e8ef827f48f088707.zip
Fix ldap linkage yet again, bug #362551, thank Joshua Rich for report.
(Portage version: 2.1.9.46/cvs/Linux x86_64)
-rw-r--r--net-fs/autofs/ChangeLog8
-rw-r--r--net-fs/autofs/autofs-5.0.5-r3.ebuild (renamed from net-fs/autofs/autofs-5.0.5-r2.ebuild)2
-rw-r--r--net-fs/autofs/files/autofs-5.0.5-fix-building-without-ldap.patch42
3 files changed, 38 insertions, 14 deletions
diff --git a/net-fs/autofs/ChangeLog b/net-fs/autofs/ChangeLog
index a1b4afbb34eb..9b1cb44afb67 100644
--- a/net-fs/autofs/ChangeLog
+++ b/net-fs/autofs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/autofs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.103 2011/04/06 15:03:01 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.104 2011/04/30 18:20:50 pva Exp $
+
+*autofs-5.0.5-r3 (30 Apr 2011)
+
+ 30 Apr 2011; Peter Volkov <pva@gentoo.org> -autofs-5.0.5-r2.ebuild,
+ +autofs-5.0.5-r3.ebuild, files/autofs-5.0.5-fix-building-without-ldap.patch:
+ Fix ldap linkage yet again, bug #362551, thank Joshua Rich for report.
06 Apr 2011; Peter Volkov <pva@gentoo.org> autofs-5.0.5-r2.ebuild,
+files/autofs-5.0.5-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patc
diff --git a/net-fs/autofs/autofs-5.0.5-r2.ebuild b/net-fs/autofs/autofs-5.0.5-r3.ebuild
index 96f4ce112b3a..983bf1be3d42 100644
--- a/net-fs/autofs/autofs-5.0.5-r2.ebuild
+++ b/net-fs/autofs/autofs-5.0.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.5-r2.ebuild,v 1.2 2011/04/06 15:03:01 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.5-r3.ebuild,v 1.1 2011/04/30 18:20:50 pva Exp $
EAPI="4"
inherit eutils multilib autotools linux-info
diff --git a/net-fs/autofs/files/autofs-5.0.5-fix-building-without-ldap.patch b/net-fs/autofs/files/autofs-5.0.5-fix-building-without-ldap.patch
index d90ef94fcc55..3429b6f05893 100644
--- a/net-fs/autofs/files/autofs-5.0.5-fix-building-without-ldap.patch
+++ b/net-fs/autofs/files/autofs-5.0.5-fix-building-without-ldap.patch
@@ -1,24 +1,41 @@
---- lib/defaults.c.orig
-+++ lib/defaults.c
-@@ -19,7 +19,9 @@
+=== modified file 'Makefile.rules'
+--- Makefile.rules 2011-04-30 18:13:36 +0000
++++ Makefile.rules 2011-04-30 18:12:37 +0000
+@@ -42,6 +42,10 @@
+ AUTOFS_LDFLAGS += $(DMALLOCLIB)
+ endif
+
++ifdef SASL
++CFLAGS += $(XML_FLAGS)
++endif
++
+ # Standard rules
+
+ .SUFFIXES: .c .o .s .so
+
+=== modified file 'lib/defaults.c'
+--- lib/defaults.c 2011-04-30 18:13:36 +0000
++++ lib/defaults.c 2011-04-30 18:12:37 +0000
+@@ -19,7 +19,10 @@
#include "list.h"
#include "defaults.h"
-+#ifdef HAVE_LDAP
++#include "config.h"
++#ifdef WITH_LDAP
#include "lookup_ldap.h"
+#endif
#include "log.h"
#include "automount.h"
-@@ -197,6 +199,7 @@ static int parse_line(char *line, char *
+@@ -197,6 +200,7 @@
return 1;
}
-+#ifdef HAVE_LDAP
++#ifdef WITH_LDAP
void defaults_free_uris(struct list_head *list)
{
struct list_head *next;
-@@ -252,9 +255,11 @@ static unsigned int add_uris(char *value
+@@ -252,9 +256,11 @@
return 1;
}
@@ -26,11 +43,11 @@
struct list_head *defaults_get_uris(void)
{
-+#ifdef HAVE_LDAP
++#ifdef WITH_LDAP
FILE *f;
char buf[MAX_LINE_LEN];
char *res;
-@@ -288,6 +292,9 @@ struct list_head *defaults_get_uris(void
+@@ -288,6 +294,9 @@
fclose(f);
return list;
@@ -40,15 +57,15 @@
}
/*
-@@ -450,6 +457,7 @@ unsigned int defaults_get_ldap_network_t
+@@ -450,6 +459,7 @@
return res;
}
-+#ifdef HAVE_LDAP
++#ifdef WITH_LDAP
struct ldap_schema *defaults_get_default_schema(void)
{
struct ldap_schema *schema;
-@@ -645,6 +653,7 @@ struct ldap_schema *defaults_get_schema(
+@@ -645,6 +655,7 @@
return schema;
}
@@ -56,3 +73,4 @@
unsigned int defaults_get_mount_nfs_default_proto(void)
{
+