summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-02-10 07:22:01 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-02-10 07:22:01 +0000
commit43f844409d2ea63dc63cf067436a4b883a02af37 (patch)
tree4d13d7750e89536c4e109335fba36b916b578b89
parentsed expression fix (diff)
downloadgentoo-2-43f844409d2ea63dc63cf067436a4b883a02af37.tar.gz
gentoo-2-43f844409d2ea63dc63cf067436a4b883a02af37.tar.bz2
gentoo-2-43f844409d2ea63dc63cf067436a4b883a02af37.zip
sed expression fix
-rw-r--r--sys-devel/spython/ChangeLog12
-rw-r--r--sys-devel/spython/spython-2.0-r7.ebuild97
-rw-r--r--sys-devel/spython/spython-2.0-r8.ebuild67
-rw-r--r--sys-devel/spython/spython-2.0-r9.ebuild66
4 files changed, 128 insertions, 114 deletions
diff --git a/sys-devel/spython/ChangeLog b/sys-devel/spython/ChangeLog
index 53717c161802..c4fbbc17128e 100644
--- a/sys-devel/spython/ChangeLog
+++ b/sys-devel/spython/ChangeLog
@@ -1,11 +1,17 @@
# ChangeLog for sys-devel/spython
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/ChangeLog,v 1.5 2002/12/13 11:00:39 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/ChangeLog,v 1.6 2003/02/10 07:22:01 seemant Exp $
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
*spython-2.0-r9 (14 Mar 2002)
+ 09 Feb 2003; Seemant Kulleen <seemant@gentoo.org> *.ebuild :
+
+ Formatting changes (try -> || die; also spaces -> tabs). And sed
+ expression delimiters from / to :, closing bug #15006 by Blu3
+ <david+gentoo.org@blue-labs.org>
+
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+
23 Oct 2002; Mike Frysinger <vapier@gentoo.org> :
Removed bootcd USE flag
diff --git a/sys-devel/spython/spython-2.0-r7.ebuild b/sys-devel/spython/spython-2.0-r7.ebuild
index 33745a4dd266..5102a76ff25c 100644
--- a/sys-devel/spython/spython-2.0-r7.ebuild
+++ b/sys-devel/spython/spython-2.0-r7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r7.ebuild,v 1.16 2002/12/09 04:37:28 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r7.ebuild,v 1.17 2003/02/10 07:22:01 seemant Exp $
IUSE="readline build"
@@ -11,69 +11,70 @@ SRC_URI="http://www.python.org/ftp/python/2.0/BeOpen-Python-2.0.tar.bz2
http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
-LICENSE="PYTHON"
SLOT="0"
-KEYWORDS="x86 sparc "
+LICENSE="PYTHON"
+KEYWORDS="x86 sparc"
-DEPEND=">=sys-devel/autoconf-2.13 >=sys-libs/zlib-1.1.3 readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )"
+DEPEND=">=sys-devel/autoconf-2.13
+ >=sys-libs/zlib-1.1.3
+ readline? ( >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2 )"
-RDEPEND="virtual/glibc"
PROVIDE="virtual/python"
src_unpack() {
- unpack BeOpen-Python-2.0.tar.bz2
- cd ${S}
- patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
- autoconf
+ unpack BeOpen-Python-2.0.tar.bz2
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
+ autoconf
- cd ${S}/Modules
+ cd ${S}/Modules
- cp -a ${FILESDIR}/pfconfig.h .
- unpack python-fchksum-1.1.tar.gz
+ cp -a ${FILESDIR}/pfconfig.h .
+ unpack python-fchksum-1.1.tar.gz
- echo '*static*' >> Setup.local
+ echo '*static*' >> Setup.local
- echo "zlib zlibmodule.c -lz" >> Setup.local
- if [ "`use readline`" ]
- then
- echo "readline readline.c -lreadline -lncurses" >> Setup.local
- fi
+ echo "zlib zlibmodule.c -lz" >> Setup.local
+ if [ "`use readline`" ]
+ then
+ echo "readline readline.c -lreadline -lncurses" >> Setup.local
+ fi
- echo "fchksum fchksum.c md5_2.c" >> Setup.local
+ echo "fchksum fchksum.c md5_2.c" >> Setup.local
- cd python-fchksum-1.1
- cp -a md5.h ../md5_2.h
- sed -e 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
- sed -e 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
+ cd python-fchksum-1.1
+ cp -a md5.h ../md5_2.h
+ sed -e 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
+ sed -e 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
}
src_compile() {
- export LDFLAGS=-static
-
- ./configure --prefix=/usr --without-libdb || die
+ export LDFLAGS=-static
- #libdb3 support is available from http://pybsddb.sourceforge.net/; the one
- #included with python is for db 1.85 only.
+ ./configure --prefix=/usr --without-libdb || die
- cp Makefile Makefile.orig
- sed -e "s/-g -O2/${CFLAGS}/" Makefile.orig > Makefile
- cd ${S}/Modules
- cp Makefile.pre Makefile.orig
- sed -e "s:MODOBJS=:MODOBJS=fchksum.o md5_2.o:" \
- Makefile.orig > Makefile.pre
+ #libdb3 support is available from http://pybsddb.sourceforge.net/; the one
+ #included with python is for db 1.85 only.
- # Parallel make does not work
- cd ${S}
- try make
+ cp Makefile Makefile.orig
+ sed -e "s:-g -O2:${CFLAGS}:" Makefile.orig > Makefile
+ cd ${S}/Modules
+ cp Makefile.pre Makefile.orig
+ sed -e "s:MODOBJS=:MODOBJS=fchksum.o md5_2.o:" \
+ Makefile.orig > Makefile.pre
+ # Parallel make does not work
+ cd ${S}
+ make || die
}
src_install() {
- dodir /usr/share/man
- make install prefix=${D}/usr MANDIR=${D}/usr/share/man || die
+ dodir /usr/share/man
+ make install prefix=${D}/usr MANDIR=${D}/usr/share/man || die
dosym spython /usr/bin/python
rm -rf ${D}/usr/include
@@ -83,14 +84,14 @@ src_install() {
rm -rf ${D}/usr/lib/spython${PV}/site-packages
dosym ../python${PV}/site-packages /usr/lib/spython${PV}/site-packages
- if [ "`use build`" ]
- then
- rm -rf ${D}/usr/share/man
+ if [ "`use build`" ]
+ then
+ rm -rf ${D}/usr/share/man
rm -rf ${D}/usr/include
- cd ${D}/usr/lib/spython2.0
+ cd ${D}/usr/lib/spython2.0
#remove test and lib-tk directory; we can do much more cleaning too.
rm -rf test lib-tk
- #clean out byte-compiled stuff. They aren't required, and doing so saves space
+ #clean out byte-compiled stuff. They aren't required, and doing so saves space
#cd to root so "find" works properly.
cd ${D}
local x
@@ -105,8 +106,8 @@ pkg_preinst() {
# keep portage from breaking from this move
for file in ${ROOT}/usr/lib/python2.0/{xpak,portage}.py
do
- [ -f ${file} ] || continue
- cp -a ${file} ${ROOT}/usr/lib/python2.0/site-packages
- rm -f ${file}* #remove .pyc stuff too
+ [ -f ${file} ] || continue
+ cp -a ${file} ${ROOT}/usr/lib/python2.0/site-packages
+ rm -f ${file}* #remove .pyc stuff too
done
}
diff --git a/sys-devel/spython/spython-2.0-r8.ebuild b/sys-devel/spython/spython-2.0-r8.ebuild
index e7b70bff6078..1ca7e38b0c4b 100644
--- a/sys-devel/spython/spython-2.0-r8.ebuild
+++ b/sys-devel/spython/spython-2.0-r8.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r8.ebuild,v 1.10 2002/12/09 04:37:28 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r8.ebuild,v 1.11 2003/02/10 07:22:01 seemant Exp $
+
+inherit eutils
IUSE="readline build"
@@ -11,13 +13,14 @@ SRC_URI="http://www.python.org/ftp/python/2.0/BeOpen-Python-2.0.tar.bz2
http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
-LICENSE="PYTHON"
SLOT="0"
-KEYWORDS="x86 sparc "
-
-DEPEND=">=sys-devel/autoconf-2.13 >=sys-libs/zlib-1.1.3 readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )"
+LICENSE="PYTHON"
+KEYWORDS="x86 sparc"
-RDEPEND="virtual/glibc"
+DEPEND=">=sys-devel/autoconf-2.13
+ >=sys-libs/zlib-1.1.3
+ readline? ( >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2 )"
# spython can't provide python anymore, since it is missing important services like crypt.
# upgrades from spython to python can cause things like mailman's authentication system to break.
@@ -28,8 +31,8 @@ src_unpack() {
unpack BeOpen-Python-2.0.tar.bz2
cd ${S}
- patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
- autoconf
+ epatch ${FILESDIR}/${PF}-gentoo.diff
+ autoconf || die
cd ${S}/Modules
@@ -55,29 +58,29 @@ src_unpack() {
src_compile() {
- export LDFLAGS=-static
+ export LDFLAGS=-static
- ./configure --prefix=/usr --without-libdb || die
+ ./configure --prefix=/usr --without-libdb || die
- #libdb3 support is available from http://pybsddb.sourceforge.net/; the one
- #included with python is for db 1.85 only.
+ #libdb3 support is available from http://pybsddb.sourceforge.net/; the one
+ #included with python is for db 1.85 only.
- cp Makefile Makefile.orig
- sed -e "s/-g -O2/${CFLAGS}/" Makefile.orig > Makefile
- cd ${S}/Modules
- cp Makefile.pre Makefile.orig
- sed -e "s:MODOBJS=:MODOBJS=fchksum.o md5_2.o:" \
- Makefile.orig > Makefile.pre
+ cp Makefile Makefile.orig
+ sed -e "s:-g -O2:${CFLAGS}:" Makefile.orig > Makefile
+ cd ${S}/Modules
+ cp Makefile.pre Makefile.orig
+ sed -e "s:MODOBJS=:MODOBJS=fchksum.o md5_2.o:" \
+ Makefile.orig > Makefile.pre
- # Parallel make does not work
- cd ${S}
- try make
+ # Parallel make does not work
+ cd ${S}
+ make || die
}
src_install() {
- dodir /usr/share/man
- make install prefix=${D}/usr MANDIR=${D}/usr/share/man || die
+ dodir /usr/share/man
+ make install prefix=${D}/usr MANDIR=${D}/usr/share/man || die
rm -rf ${D}/usr/include
rm -rf ${D}/usr/lib/${PN}${PV}/config
@@ -86,14 +89,14 @@ src_install() {
rm -rf ${D}/usr/lib/spython${PV}/site-packages
dosym ../python${PV}/site-packages /usr/lib/spython${PV}/site-packages
- if [ "`use build`" ]
- then
- rm -rf ${D}/usr/share/man
+ if [ "`use build`" ]
+ then
+ rm -rf ${D}/usr/share/man
rm -rf ${D}/usr/include
- cd ${D}/usr/lib/spython2.0
+ cd ${D}/usr/lib/spython2.0
#remove test and lib-tk directory; we can do much more cleaning too.
rm -rf test lib-tk
- #clean out byte-compiled stuff. They aren't required, and doing so saves space
+ #clean out byte-compiled stuff. They aren't required, and doing so saves space
#cd to root so "find" works properly.
cd ${D}
local x
@@ -108,8 +111,8 @@ pkg_preinst() {
# keep portage from breaking from this move
for file in ${ROOT}/usr/lib/python2.0/{xpak,portage}.py
do
- [ -f ${file} ] || continue
- cp -a ${file} ${ROOT}/usr/lib/python2.0/site-packages
- rm -f ${file}* #remove .pyc stuff too
+ [ -f ${file} ] || continue
+ cp -a ${file} ${ROOT}/usr/lib/python2.0/site-packages
+ rm -f ${file}* #remove .pyc stuff too
done
}
diff --git a/sys-devel/spython/spython-2.0-r9.ebuild b/sys-devel/spython/spython-2.0-r9.ebuild
index c03aaa088661..0945c9035e22 100644
--- a/sys-devel/spython/spython-2.0-r9.ebuild
+++ b/sys-devel/spython/spython-2.0-r9.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r9.ebuild,v 1.10 2002/12/09 04:37:28 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r9.ebuild,v 1.11 2003/02/10 07:22:01 seemant Exp $
+
+inherit eutils
IUSE="readline build"
@@ -11,13 +13,15 @@ SRC_URI="http://www.python.org/ftp/python/2.0/BeOpen-Python-2.0.tar.bz2
http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
-LICENSE="PYTHON"
-KEYWORDS="x86 sparc "
-SLOT="0"
-DEPEND=">=sys-devel/autoconf-2.13 >=sys-libs/zlib-1.1.4 readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )"
+SLOT="0"
+LICENSE="PYTHON"
+KEYWORDS="x86 sparc"
-RDEPEND="virtual/glibc"
+DEPEND=">=sys-devel/autoconf-2.13
+ >=sys-libs/zlib-1.1.4
+ readline? ( >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2 )"
# spython can't provide python anymore, since it is missing important services like crypt.
# upgrades from spython to python can cause things like mailman's authentication system to break.
@@ -28,7 +32,7 @@ src_unpack() {
unpack BeOpen-Python-2.0.tar.bz2
cd ${S}
- patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
+ epatch ${FILESDIR}/${PF}-gentoo.diff
autoconf
cd ${S}/Modules
@@ -55,29 +59,29 @@ src_unpack() {
src_compile() {
- export LDFLAGS=-static
+ export LDFLAGS=-static
- ./configure --prefix=/usr --without-libdb || die
+ ./configure --prefix=/usr --without-libdb || die
- #libdb3 support is available from http://pybsddb.sourceforge.net/; the one
- #included with python is for db 1.85 only.
+ #libdb3 support is available from http://pybsddb.sourceforge.net/; the one
+ #included with python is for db 1.85 only.
- cp Makefile Makefile.orig
- sed -e "s/-g -O2/${CFLAGS}/" Makefile.orig > Makefile
- cd ${S}/Modules
- cp Makefile.pre Makefile.orig
- sed -e "s:MODOBJS=:MODOBJS=fchksum.o md5_2.o:" \
- Makefile.orig > Makefile.pre
+ cp Makefile Makefile.orig
+ sed -e "s:-g -O2:${CFLAGS}:" Makefile.orig > Makefile
+ cd ${S}/Modules
+ cp Makefile.pre Makefile.orig
+ sed -e "s:MODOBJS=:MODOBJS=fchksum.o md5_2.o:" \
+ Makefile.orig > Makefile.pre
- # Parallel make does not work
- cd ${S}
- try make
+ # Parallel make does not work
+ cd ${S}
+ make || die
}
src_install() {
- dodir /usr/share/man
- make install prefix=${D}/usr MANDIR=${D}/usr/share/man || die
+ dodir /usr/share/man
+ make install prefix=${D}/usr MANDIR=${D}/usr/share/man || die
rm -rf ${D}/usr/include
rm -rf ${D}/usr/lib/${PN}${PV}/config
@@ -86,14 +90,14 @@ src_install() {
rm -rf ${D}/usr/lib/spython${PV}/site-packages
dosym ../python${PV}/site-packages /usr/lib/spython${PV}/site-packages
- if [ "`use build`" ]
- then
- rm -rf ${D}/usr/share/man
+ if [ "`use build`" ]
+ then
+ rm -rf ${D}/usr/share/man
rm -rf ${D}/usr/include
- cd ${D}/usr/lib/spython2.0
+ cd ${D}/usr/lib/spython2.0
#remove test and lib-tk directory; we can do much more cleaning too.
rm -rf test lib-tk
- #clean out byte-compiled stuff. They aren't required, and doing so saves space
+ #clean out byte-compiled stuff. They aren't required, and doing so saves space
#cd to root so "find" works properly.
cd ${D}
local x
@@ -108,8 +112,8 @@ pkg_preinst() {
# keep portage from breaking from this move
for file in ${ROOT}/usr/lib/python2.0/{xpak,portage}.py
do
- [ -f ${file} ] || continue
- cp -a ${file} ${ROOT}/usr/lib/python2.0/site-packages
- rm -f ${file}* #remove .pyc stuff too
+ [ -f ${file} ] || continue
+ cp -a ${file} ${ROOT}/usr/lib/python2.0/site-packages
+ rm -f ${file}* #remove .pyc stuff too
done
}