summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-06-02 06:23:41 +0000
committerMike Frysinger <vapier@gentoo.org>2012-06-02 06:23:41 +0000
commit4c476fb637073f47e92434b374bab8b2df5286eb (patch)
treefc1636bb1627db2177e3c8ae59f28d93767e2068
parentAdd ~ppc keyword (diff)
downloadgentoo-2-4c476fb637073f47e92434b374bab8b2df5286eb.tar.gz
gentoo-2-4c476fb637073f47e92434b374bab8b2df5286eb.tar.bz2
gentoo-2-4c476fb637073f47e92434b374bab8b2df5286eb.zip
Version bump.
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
-rw-r--r--sys-devel/automake/ChangeLog7
-rw-r--r--sys-devel/automake/automake-1.12.1.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/sys-devel/automake/ChangeLog b/sys-devel/automake/ChangeLog
index a78ef36b65ea..de316e7224c2 100644
--- a/sys-devel/automake/ChangeLog
+++ b/sys-devel/automake/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/automake
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.164 2012/05/09 15:38:15 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.165 2012/06/02 06:23:41 vapier Exp $
+
+*automake-1.12.1 (02 Jun 2012)
+
+ 02 Jun 2012; Mike Frysinger <vapier@gentoo.org> +automake-1.12.1.ebuild:
+ Version bump.
09 May 2012; Alexis Ballier <aballier@gentoo.org> automake-1.10.3.ebuild:
keyword ~amd64-fbsd
diff --git a/sys-devel/automake/automake-1.12.1.ebuild b/sys-devel/automake/automake-1.12.1.ebuild
new file mode 100644
index 000000000000..ede7a2a1fa6b
--- /dev/null
+++ b/sys-devel/automake/automake-1.12.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.12.1.ebuild,v 1.1 2012/06/02 06:23:41 vapier Exp $
+
+inherit eutils versionator unpacker
+
+if [[ ${PV/_beta} == ${PV} ]]; then
+ MY_P=${P}
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz"
+else
+ MY_PV="$(get_major_version).$(($(get_version_component_range 2)-1))b"
+ MY_P="${PN}-${MY_PV}"
+
+ # Alpha/beta releases are not distributed on the usual mirrors.
+ SRC_URI="ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz"
+fi
+
+DESCRIPTION="Used to generate Makefile.in from Makefile.am"
+HOMEPAGE="http://www.gnu.org/software/automake/"
+
+LICENSE="GPL-2"
+# Use Gentoo versioning for slotting.
+SLOT="${PV:0:4}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ >=sys-devel/automake-wrapper-7
+ >=sys-devel/autoconf-2.62
+ >=sys-apps/texinfo-4.7
+ sys-devel/gnuconfig"
+DEPEND="${RDEPEND}
+ sys-apps/help2man"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpacker_src_unpack
+ cd "${S}"
+ sed -i \
+ -e "s|: (automake)| v${SLOT}: (automake${SLOT})|" \
+ doc/automake.texi || die
+ local f
+ for f in doc/automake.{texi,info*} ; do
+ mv ${f} ${f%.*}${SLOT}.${f#*.} || die
+ done
+ touch -r configure doc/*.{texi,info}*
+ sed -i -r \
+ -e "s:(automake)(.info|.texi):\1${SLOT}\2:g" \
+ Makefile.in || die
+ export WANT_AUTOCONF=2.5
+}
+
+src_compile() {
+ econf --docdir=/usr/share/doc/${PF} HELP2MAN=true || die
+ emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install \
+ APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+
+ rm \
+ "${D}"/usr/bin/{aclocal,automake} \
+ "${D}"/usr/share/man/man1/{aclocal,automake}.1 || die
+
+ # remove all config.guess and config.sub files replacing them
+ # w/a symlink to a specific gnuconfig version
+ local x
+ for x in guess sub ; do
+ dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
+ done
+}