summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-10-15 03:50:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-10-15 03:50:52 +0000
commit4c83e92be1e5decf962ad943d47830bd29f41587 (patch)
treeb363d70d99feda7b4da06a1f801e250715663bc1
parentreturn to RDEPEND noted by Arfrever (diff)
downloadgentoo-2-4c83e92be1e5decf962ad943d47830bd29f41587.tar.gz
gentoo-2-4c83e92be1e5decf962ad943d47830bd29f41587.tar.bz2
gentoo-2-4c83e92be1e5decf962ad943d47830bd29f41587.zip
version bump (bug #437894)
(Portage version: 2.2.8-r2/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--games-emulation/virtualjaguar/ChangeLog9
-rw-r--r--games-emulation/virtualjaguar/virtualjaguar-2.1.2.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/games-emulation/virtualjaguar/ChangeLog b/games-emulation/virtualjaguar/ChangeLog
index 8ea0cd80ee55..392b66eda96f 100644
--- a/games-emulation/virtualjaguar/ChangeLog
+++ b/games-emulation/virtualjaguar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/virtualjaguar
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/virtualjaguar/ChangeLog,v 1.15 2014/05/15 16:40:58 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/virtualjaguar/ChangeLog,v 1.16 2014/10/15 03:50:52 mr_bones_ Exp $
+
+*virtualjaguar-2.1.2 (15 Oct 2014)
+
+ 15 Oct 2014; Michael Sterrett <mr_bones_@gentoo.org>
+ +virtualjaguar-2.1.2.ebuild, metadata.xml:
+ version bump (bug #437894)
15 May 2014; Ulrich Müller <ulm@gentoo.org> virtualjaguar-1.0.7.ebuild:
Fix USE dependency on media-libs/libsdl, "audio" USE flag was renamed to
@@ -62,4 +68,3 @@
12 Sep 2003; Michael Sterrett <msterret@gentoo.org>
virtualjaguar-1.0.5.ebuild, files/virtualjaguar:
initial commit
-
diff --git a/games-emulation/virtualjaguar/virtualjaguar-2.1.2.ebuild b/games-emulation/virtualjaguar/virtualjaguar-2.1.2.ebuild
new file mode 100644
index 000000000000..00c0114cb4d1
--- /dev/null
+++ b/games-emulation/virtualjaguar/virtualjaguar-2.1.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/virtualjaguar/virtualjaguar-2.1.2.ebuild,v 1.1 2014/10/15 03:50:52 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils qt4-r2 games
+
+DESCRIPTION="an Atari Jaguar emulator"
+HOMEPAGE="http://www.icculus.org/virtualjaguar/"
+SRC_URI="http://www.icculus.org/virtualjaguar/tarballs/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[joystick,opengl,sound,video]
+ sys-libs/zlib
+ virtual/opengl
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ dev-libs/libcdio"
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-4.4"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ eqmake4 virtualjaguar.pro -o makefile-qt
+}
+
+src_compile() {
+ emake -j1 libs
+ emake
+}
+
+src_install() {
+ dogamesbin ${PN}
+ dodoc README docs/{TODO,WHATSNEW}
+ doman docs/virtualjaguar.1
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "The ${PN} ROM path is no-longer hardcoded, "
+ elog "set it from within, the ${PN} GUI."
+ elog
+ elog "The ROM extension supported by ${PN} is .j64, "
+ elog ".jag files will be interpreted as Jaguar Server executables."
+}