summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-03-20 13:25:03 +0000
committerRoy Marples <uberlord@gentoo.org>2006-03-20 13:25:03 +0000
commit4d2e10213768746ba5a262ca65111e25f55f1351 (patch)
tree3cbd78a6ebb987c2e75676de855ae3e4243f6ad4
parentRework metric patch for non bash versions (diff)
downloadgentoo-2-4d2e10213768746ba5a262ca65111e25f55f1351.tar.gz
gentoo-2-4d2e10213768746ba5a262ca65111e25f55f1351.tar.bz2
gentoo-2-4d2e10213768746ba5a262ca65111e25f55f1351.zip
punt old versions
(Portage version: 2.1_pre6-r4)
-rw-r--r--net-misc/dhcp/dhcp-3.0.3-r5.ebuild180
-rw-r--r--net-misc/dhcp/dhcp-3.0.4_beta2-r2.ebuild178
-rw-r--r--net-misc/dhcp/dhcp-3.0.4_beta3.ebuild186
-rw-r--r--net-misc/dhcp/files/digest-dhcp-3.0.3-r53
-rw-r--r--net-misc/dhcp/files/digest-dhcp-3.0.4_beta2-r23
-rw-r--r--net-misc/dhcp/files/digest-dhcp-3.0.4_beta33
6 files changed, 0 insertions, 553 deletions
diff --git a/net-misc/dhcp/dhcp-3.0.3-r5.ebuild b/net-misc/dhcp/dhcp-3.0.3-r5.ebuild
deleted file mode 100644
index e78975f9ed7e..000000000000
--- a/net-misc/dhcp/dhcp-3.0.3-r5.ebuild
+++ /dev/null
@@ -1,180 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0.3-r5.ebuild,v 1.3 2006/03/10 11:09:23 uberlord Exp $
-
-inherit eutils flag-o-matic multilib toolchain-funcs
-
-MY_PV="${PV//_beta/b}"
-MY_P="${PN}-${MY_PV}"
-DESCRIPTION="ISC Dynamic Host Configuration Protocol"
-HOMEPAGE="http://www.isc.org/products/DHCP"
-SRC_URI="ftp://ftp.isc.org/isc/dhcp/${MY_P}.tar.gz"
-
-LICENSE="isc-dhcp"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="static selinux"
-
-RDEPEND="selinux? ( sec-policy/selinux-dhcp )"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
-PROVIDE="virtual/dhcpc"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack "${A}"
- cd "${S}"
-
- # Gentoo patches - these will probably never be accepted upstream
- # Enable chroot support
- epatch "${FILESDIR}/${PN}-3.0-paranoia.patch"
- # Fix some permission issues
- epatch "${FILESDIR}/${PN}-3.0-fix-perms.patch"
- # Enable dhclient to equery NTP servers, fixed #63868
- epatch "${FILESDIR}/${PN}-3.0.3-dhclient-ntp.patch"
- # Quiet the isc blurb
- epatch "${FILESDIR}/${PN}-3.0.3-no_isc_blurb.patch"
- # Enable dhclient to get extra configuration from stdin
- epatch "${FILESDIR}/${P}-dhclient-stdin-conf.patch"
-
- # General fixes which will probably be accepted upstream eventually
- # Fix token ring compiling, #102473
- epatch "${FILESDIR}/${P}-tr.patch"
- # Install libdst, #75544
- epatch "${FILESDIR}/${PN}-3.0.3-libdst.patch"
- # Fix building on Gentoo/FreeBSD
- epatch "${FILESDIR}/${PN}-3.0.2-gmake.patch"
-
- # Brand the version with Gentoo
- # include revision if >0
- local newver="${MY_PV}-Gentoo"
- [[ ${PR} != "r0" ]] && newver="${newver}-${PR}"
- sed -i -e '/^#define DHCP_VERSION[ \t]\+/ s/'"${MY_PV}/${newver}/g" \
- includes/version.h
-
- # Tart up the scripts for Gentoo baselayout
- local comment="# This script is not called by Gentoo net scripts\n"
- comment="${comment}# and is inluded purely for reference.\n"
- comment="${comment}# We do however call /etc/dhcp/dhclient-exit-hooks\n"
- sed -i -e '1 a '"${comment}" \
- -e 's,/etc/dhclient-exit-hooks,/etc/dhcp/dhclient-exit-hooks,g' \
- client/scripts/*
-
- # Remove these options from the sample config as they conflict
- # with baselayout network scripts
- sed -i -e "/\(script\|host-name\|domain-name\) / d" client/dhclient.conf
-
- # Only install different man pages if we don't have en
- if [[ " ${LINGUAS} " != *" en "* ]]; then
- # Install Japanese man pages
- if [[ " ${LINGUAS} " == *" ja "* && -d doc/ja_JP.eucJP ]]; then
- einfo "Installing Japanese documention"
- cp doc/ja_JP.eucJP/dhclient* client
- cp doc/ja_JP.eucJP/dhcp* common
- fi
- fi
-
- # Now remove the non-english docs so there are no errors later
- [[ -d doc/ja_JP.eucJP ]] && rm -rf doc/ja_JP.eucJP
-}
-
-src_compile() {
- # 01/Mar/2003: Fix for bug #11960 by Jason Wever <weeve@gentoo.org>
- [[ ${ARCH} == "sparc" ]] && filter-flags -O3 -O2 -O
-
- use static && append-ldflags -static
-
- cat <<-END >> includes/site.h
- #define _PATH_DHCPD_CONF "/etc/dhcp/dhcpd.conf"
- #define _PATH_DHCPD_PID "/var/run/dhcp/dhcpd.pid"
- #define _PATH_DHCPD_DB "/var/lib/dhcp/dhcpd.leases"
- #define _PATH_DHCLIENT_DB "/var/lib/dhcp/dhclient.leases"
- #define DHCPD_LOG_FACILITY LOG_LOCAL1
- END
-
- cat <<-END > site.conf
- CC = $(tc-getCC)
- LFLAGS = ${LDFLAGS}
- LIBDIR = /usr/$(get_libdir)
- INCDIR = /usr/include
- ETC = /etc/dhcp
- VARDB = /var/lib/dhcp
- VARRUN = /var/run/dhcp
- ADMMANDIR = /usr/share/man/man8
- FFMANDIR = /usr/share/man/man5
- LIBMANDIR = /usr/share/man/man3
- USRMANDIR = /usr/share/man/man1
- END
-
- ./configure --copts "-DPARANOIA -DEARLY_CHROOT ${CFLAGS}" \
- || die "configure failed"
-
- emake || die "compile problem"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die
-
- insinto /etc/dhcp
- newins server/dhcpd.conf dhcpd.conf.sample
- newins client/dhclient.conf dhclient.conf.sample
-
- dodoc README RELNOTES doc/*
- newdoc client/dhclient.conf dhclient.conf.sample
- newdoc client/scripts/linux dhclient-script.sample
- newdoc server/dhcpd.conf dhcpd.conf.sample
-
- newinitd "${FILESDIR}/dhcp.init" dhcp
- newinitd "${FILESDIR}/dhcrelay.init" dhcrelay
- insinto /etc/conf.d
- newins "${FILESDIR}/dhcp.conf" dhcp
- newins "${FILESDIR}/dhcrelay.conf" dhcrelay
-
- keepdir /var/{lib,run}/dhcp
-}
-
-pkg_preinst() {
- enewgroup dhcp
- enewuser dhcp -1 -1 /var/lib/dhcp dhcp
-}
-
-pkg_postinst() {
- chown dhcp:dhcp "${ROOT}"/var/{lib,run}/dhcp
-
- einfo "You can edit /etc/conf.d/dhcp to customize dhcp settings."
- einfo
- einfo "The DHCP ebuild now includes chroot support."
- einfo "If you would like to run dhcpd in a chroot, simply configure the"
- einfo "CHROOT directory in /etc/conf.d/dhcp and then run:"
- einfo " emerge --config =${PF}"
-}
-
-pkg_config() {
- CHROOT="$(
- sed -n 's/^[[:blank:]]\?CHROOT="*\([^#"]\+\)"*/\1/p' \
- /etc/conf.d/dhcp
- )"
-
- if [[ -z ${CHROOT} ]]; then
- eerror "CHROOT not defined in /etc/conf.d/dhcp"
- return 1
- fi
-
- if [[ -d ${CHROOT} ]] ; then
- ewarn "${CHROOT} already exists - aborting"
- return 0
- fi
-
- ebegin "Setting up the chroot directory"
- mkdir -m 0755 -p "${CHROOT}/"{dev,etc,var/lib,var/run/dhcp}
- cp /etc/{localtime,resolv.conf} "${CHROOT}/etc"
- cp -R /etc/dhcp "${CHROOT}/etc/"
- cp -R /var/lib/dhcp "${CHROOT}/var/lib"
- chown -R dhcp:dhcp "${CHROOT}"/var/{lib,run}/dhcp
- eend
-
- local logger="$(best_version virtual/logger)"
- einfo "To enable logging from the DHCP server, configure your"
- einfo "logger (${logger}) to listen on ${CHROOT}/dev/log"
-}
diff --git a/net-misc/dhcp/dhcp-3.0.4_beta2-r2.ebuild b/net-misc/dhcp/dhcp-3.0.4_beta2-r2.ebuild
deleted file mode 100644
index a6df89f12fea..000000000000
--- a/net-misc/dhcp/dhcp-3.0.4_beta2-r2.ebuild
+++ /dev/null
@@ -1,178 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0.4_beta2-r2.ebuild,v 1.3 2006/03/10 11:09:23 uberlord Exp $
-
-inherit eutils flag-o-matic multilib toolchain-funcs
-
-MY_PV="${PV//_beta/b}"
-MY_P="${PN}-${MY_PV}"
-DESCRIPTION="ISC Dynamic Host Configuration Protocol"
-HOMEPAGE="http://www.isc.org/products/DHCP"
-SRC_URI="ftp://ftp.isc.org/isc/dhcp/${MY_P}.tar.gz"
-
-LICENSE="isc-dhcp"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="static selinux"
-
-RDEPEND="selinux? ( sec-policy/selinux-dhcp )"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
-PROVIDE="virtual/dhcpc"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack "${A}"
- cd "${S}"
-
- # Gentoo patches - these will probably never be accepted upstream
- # Enable chroot support
- epatch "${FILESDIR}/${PN}-3.0-paranoia.patch"
- # Fix some permission issues
- epatch "${FILESDIR}/${PN}-3.0-fix-perms.patch"
- # Enable dhclient to equery NTP servers, fixed #63868
- epatch "${FILESDIR}/${PN}-3.0.3-dhclient-ntp.patch"
- # Quiet the isc blurb
- epatch "${FILESDIR}/${PN}-3.0.3-no_isc_blurb.patch"
- # Enable dhclient to get extra configuration from stdin
- epatch "${FILESDIR}/${P}-dhclient-stdin-conf.patch"
-
- # General fixes which will probably be accepted upstream eventually
- # Install libdst, #75544
- epatch "${FILESDIR}/${PN}-3.0.3-libdst.patch"
- # Fix building on Gentoo/FreeBSD
- epatch "${FILESDIR}/${PN}-3.0.2-gmake.patch"
-
- # Brand the version with Gentoo
- # include revision if >0
- local newver="${MY_PV}-Gentoo"
- [[ ${PR} != "r0" ]] && newver="${newver}-${PR}"
- sed -i -e '/^#define DHCP_VERSION[ \t]\+/ s/'"${MY_PV}/${newver}/g" \
- includes/version.h
-
- # Tart up the scripts for Gentoo baselayout
- local comment="# This script is not called by Gentoo net scripts\n"
- comment="${comment}# and is inluded purely for reference.\n"
- comment="${comment}# We do however call /etc/dhcp/dhclient-exit-hooks\n"
- sed -i -e '1 a '"${comment}" \
- -e 's,/etc/dhclient-exit-hooks,/etc/dhcp/dhclient-exit-hooks,g' \
- client/scripts/*
-
- # Remove these options from the sample config as they conflict
- # with baselayout network scripts
- sed -i -e "/\(script\|host-name\|domain-name\) / d" client/dhclient.conf
-
- # Only install different man pages if we don't have en
- if [[ " ${LINGUAS} " != *" en "* ]]; then
- # Install Japanese man pages
- if [[ " ${LINGUAS} " == *" ja "* && -d doc/ja_JP.eucJP ]]; then
- einfo "Installing Japanese documention"
- cp doc/ja_JP.eucJP/dhclient* client
- cp doc/ja_JP.eucJP/dhcp* common
- fi
- fi
-
- # Now remove the non-english docs so there are no errors later
- [[ -d doc/ja_JP.eucJP ]] && rm -rf doc/ja_JP.eucJP
-}
-
-src_compile() {
- # 01/Mar/2003: Fix for bug #11960 by Jason Wever <weeve@gentoo.org>
- [[ ${ARCH} == "sparc" ]] && filter-flags -O3 -O2 -O
-
- use static && append-ldflags -static
-
- cat <<-END >> includes/site.h
- #define _PATH_DHCPD_CONF "/etc/dhcp/dhcpd.conf"
- #define _PATH_DHCPD_PID "/var/run/dhcp/dhcpd.pid"
- #define _PATH_DHCPD_DB "/var/lib/dhcp/dhcpd.leases"
- #define _PATH_DHCLIENT_DB "/var/lib/dhcp/dhclient.leases"
- #define DHCPD_LOG_FACILITY LOG_LOCAL1
- END
-
- cat <<-END > site.conf
- CC = $(tc-getCC)
- LFLAGS = ${LDFLAGS}
- LIBDIR = /usr/$(get_libdir)
- INCDIR = /usr/include
- ETC = /etc/dhcp
- VARDB = /var/lib/dhcp
- VARRUN = /var/run/dhcp
- ADMMANDIR = /usr/share/man/man8
- FFMANDIR = /usr/share/man/man5
- LIBMANDIR = /usr/share/man/man3
- USRMANDIR = /usr/share/man/man1
- END
-
- ./configure --copts "-DPARANOIA -DEARLY_CHROOT ${CFLAGS}" \
- || die "configure failed"
-
- emake || die "compile problem"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die
-
- insinto /etc/dhcp
- newins server/dhcpd.conf dhcpd.conf.sample
- newins client/dhclient.conf dhclient.conf.sample
-
- dodoc README RELNOTES doc/*
- newdoc client/dhclient.conf dhclient.conf.sample
- newdoc client/scripts/linux dhclient-script.sample
- newdoc server/dhcpd.conf dhcpd.conf.sample
-
- newinitd "${FILESDIR}/dhcp.init" dhcp
- newinitd "${FILESDIR}/dhcrelay.init" dhcrelay
- insinto /etc/conf.d
- newins "${FILESDIR}/dhcp.conf" dhcp
- newins "${FILESDIR}/dhcrelay.conf" dhcrelay
-
- keepdir /var/{lib,run}/dhcp
-}
-
-pkg_preinst() {
- enewgroup dhcp
- enewuser dhcp -1 -1 /var/lib/dhcp dhcp
-}
-
-pkg_postinst() {
- chown dhcp:dhcp "${ROOT}"/var/{lib,run}/dhcp
-
- einfo "You can edit /etc/conf.d/dhcp to customize dhcp settings."
- einfo
- einfo "The DHCP ebuild now includes chroot support."
- einfo "If you would like to run dhcpd in a chroot, simply configure the"
- einfo "CHROOT directory in /etc/conf.d/dhcp and then run:"
- einfo " emerge --config =${PF}"
-}
-
-pkg_config() {
- CHROOT="$(
- sed -n 's/^[[:blank:]]\?CHROOT="*\([^#"]\+\)"*/\1/p' \
- /etc/conf.d/dhcp
- )"
-
- if [[ -z ${CHROOT} ]]; then
- eerror "CHROOT not defined in /etc/conf.d/dhcp"
- return 1
- fi
-
- if [[ -d ${CHROOT} ]] ; then
- ewarn "${CHROOT} already exists - aborting"
- return 0
- fi
-
- ebegin "Setting up the chroot directory"
- mkdir -m 0755 -p "${CHROOT}/"{dev,etc,var/lib,var/run/dhcp}
- cp /etc/{localtime,resolv.conf} "${CHROOT}/etc"
- cp -R /etc/dhcp "${CHROOT}/etc/"
- cp -R /var/lib/dhcp "${CHROOT}/var/lib"
- chown -R dhcp:dhcp "${CHROOT}"/var/{lib,run}/dhcp
- eend
-
- local logger="$(best_version virtual/logger)"
- einfo "To enable logging from the DHCP server, configure your"
- einfo "logger (${logger}) to listen on ${CHROOT}/dev/log"
-}
diff --git a/net-misc/dhcp/dhcp-3.0.4_beta3.ebuild b/net-misc/dhcp/dhcp-3.0.4_beta3.ebuild
deleted file mode 100644
index 9b62a893e3d4..000000000000
--- a/net-misc/dhcp/dhcp-3.0.4_beta3.ebuild
+++ /dev/null
@@ -1,186 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0.4_beta3.ebuild,v 1.2 2006/03/10 11:09:23 uberlord Exp $
-
-inherit eutils flag-o-matic multilib toolchain-funcs
-
-MY_PV="${PV//_beta/b}"
-MY_P="${PN}-${MY_PV}"
-DESCRIPTION="ISC Dynamic Host Configuration Protocol"
-HOMEPAGE="http://www.isc.org/products/DHCP"
-SRC_URI="ftp://ftp.isc.org/isc/dhcp/${MY_P}.tar.gz"
-
-LICENSE="isc-dhcp"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="static selinux"
-
-RDEPEND="selinux? ( sec-policy/selinux-dhcp )"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
-
-PROVIDE="virtual/dhcpc"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack "${A}"
- cd "${S}"
-
- # Gentoo patches - these will probably never be accepted upstream
- # Enable chroot support
- epatch "${FILESDIR}/${PN}-3.0-paranoia.patch"
- # Fix some permission issues
- epatch "${FILESDIR}/${PN}-3.0-fix-perms.patch"
- # Enable dhclient to equery NTP servers, fixed #63868
- epatch "${FILESDIR}/${PN}-3.0.3-dhclient-ntp.patch"
- # Quiet the isc blurb
- epatch "${FILESDIR}/${PN}-3.0.3-no_isc_blurb.patch"
- # Enable dhclient to get extra configuration from stdin
- epatch "${FILESDIR}/${PN}-3.0.4_beta2-dhclient-stdin-conf.patch"
-
- # General fixes which will probably be accepted upstream eventually
- # Install libdst, #75544
- epatch "${FILESDIR}/${PN}-3.0.3-libdst.patch"
- # Fix building on Gentoo/FreeBSD
- epatch "${FILESDIR}/${PN}-3.0.2-gmake.patch"
-
- # Brand the version with Gentoo
- # include revision if >0
- local newver="${MY_PV}-Gentoo"
- [[ ${PR} != "r0" ]] && newver="${newver}-${PR}"
- sed -i -e '/^#define DHCP_VERSION[ \t]\+/ s/'"${MY_PV}/${newver}/g" \
- includes/version.h
-
- # Tart up the scripts for Gentoo baselayout
- local comment="# This script is not called by Gentoo net scripts\n"
- comment="${comment}# and is inluded purely for reference.\n"
- comment="${comment}# We do however call /etc/dhcp/dhclient-exit-hooks\n"
- sed -i -e '1 a '"${comment}" \
- -e 's,/etc/dhclient-exit-hooks,/etc/dhcp/dhclient-exit-hooks,g' \
- client/scripts/*
-
- # Remove these options from the sample config as they conflict
- # with baselayout network scripts
- sed -i -e "/\(script\|host-name\|domain-name\) / d" client/dhclient.conf
-
- # Only install different man pages if we don't have en
- if [[ " ${LINGUAS} " != *" en "* ]]; then
- # Install Japanese man pages
- if [[ " ${LINGUAS} " == *" ja "* && -d doc/ja_JP.eucJP ]]; then
- einfo "Installing Japanese documention"
- cp doc/ja_JP.eucJP/dhclient* client
- cp doc/ja_JP.eucJP/dhcp* common
- fi
- fi
-
- # Now remove the non-english docs so there are no errors later
- [[ -d doc/ja_JP.eucJP ]] && rm -rf doc/ja_JP.eucJP
-}
-
-src_compile() {
- # 01/Mar/2003: Fix for bug #11960 by Jason Wever <weeve@gentoo.org>
- [[ ${ARCH} == "sparc" ]] && filter-flags -O3 -O2 -O
-
- use static && append-ldflags -static
-
- cat <<-END >> includes/site.h
- #define _PATH_DHCPD_CONF "/etc/dhcp/dhcpd.conf"
- #define _PATH_DHCPD_PID "/var/run/dhcp/dhcpd.pid"
- #define _PATH_DHCPD_DB "/var/lib/dhcp/dhcpd.leases"
- #define _PATH_DHCLIENT_DB "/var/lib/dhcp/dhclient.leases"
- #define DHCPD_LOG_FACILITY LOG_LOCAL1
- END
-
- cat <<-END > site.conf
- CC = $(tc-getCC)
- LFLAGS = ${LDFLAGS}
- LIBDIR = /usr/$(get_libdir)
- INCDIR = /usr/include
- ETC = /etc/dhcp
- VARDB = /var/lib/dhcp
- VARRUN = /var/run/dhcp
- ADMMANDIR = /usr/share/man/man8
- FFMANDIR = /usr/share/man/man5
- LIBMANDIR = /usr/share/man/man3
- USRMANDIR = /usr/share/man/man1
- END
-
- ./configure --copts "-DPARANOIA -DEARLY_CHROOT ${CFLAGS}" \
- || die "configure failed"
-
- emake || die "compile problem"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die
-
- insinto /etc/dhcp
- newins server/dhcpd.conf dhcpd.conf.sample
- newins client/dhclient.conf dhclient.conf.sample
-
- dodoc README RELNOTES doc/*
- newdoc client/dhclient.conf dhclient.conf.sample
- newdoc client/scripts/linux dhclient-script.sample
- newdoc server/dhcpd.conf dhcpd.conf.sample
-
- newinitd "${FILESDIR}/dhcpd.init" dhcpd
- newinitd "${FILESDIR}/dhcrelay.init" dhcrelay
- insinto /etc/conf.d
- newins "${FILESDIR}/dhcpd.conf" dhcpd
- newins "${FILESDIR}/dhcrelay.conf" dhcrelay
-
- keepdir /var/{lib,run}/dhcp
-}
-
-pkg_preinst() {
- enewgroup dhcp
- enewuser dhcp -1 -1 /var/lib/dhcp dhcp
-}
-
-pkg_postinst() {
- chown dhcp:dhcp "${ROOT}"/var/{lib,run}/dhcp
-
- if [[ -e "${ROOT}/etc/init.d/dhcp" ]] ; then
- ewarn
- ewarn "WARNING: The dhcp init script has been renamed to dhcpd"
- ewarn "/etc/init.d/dhcp and /etc/conf.d/dhcp need to be removed and"
- ewarn "and dhcp should be removed from the default runlevel"
- ewarn
- fi
-
- einfo "You can edit /etc/conf.d/dhcpd to customize dhcp settings."
- einfo
- einfo "If you would like to run dhcpd in a chroot, simply configure the"
- einfo "DHCPD_CHROOT directory in /etc/conf.d/dhcpd and then run:"
- einfo " emerge --config =${PF}"
-}
-
-pkg_config() {
- local CHROOT="$(
- sed -n 's/^[[:blank:]]\?DHCPD_CHROOT="*\([^#"]\+\)"*/\1/p' \
- /etc/conf.d/dhcpd
- )"
-
- if [[ -z ${CHROOT} ]]; then
- eerror "CHROOT not defined in /etc/conf.d/dhcpd"
- return 1
- fi
-
- if [[ -d ${CHROOT} ]] ; then
- ewarn "${CHROOT} already exists - aborting"
- return 0
- fi
-
- ebegin "Setting up the chroot directory"
- mkdir -m 0755 -p "${CHROOT}/"{dev,etc,var/lib,var/run/dhcp}
- cp /etc/{localtime,resolv.conf} "${CHROOT}/etc"
- cp -R /etc/dhcp "${CHROOT}/etc/"
- cp -R /var/lib/dhcp "${CHROOT}/var/lib"
- chown -R dhcp:dhcp "${CHROOT}"/var/{lib,run}/dhcp
- eend
-
- local logger="$(best_version virtual/logger)"
- einfo "To enable logging from the dhcpd server, configure your"
- einfo "logger (${logger}) to listen on ${CHROOT}/dev/log"
-}
diff --git a/net-misc/dhcp/files/digest-dhcp-3.0.3-r5 b/net-misc/dhcp/files/digest-dhcp-3.0.3-r5
deleted file mode 100644
index bfdf4cb56303..000000000000
--- a/net-misc/dhcp/files/digest-dhcp-3.0.3-r5
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 f91416a0b8ed3fd0601688cf0b7df58f dhcp-3.0.3.tar.gz 870240
-RMD160 bcbd1f8b49f17809a3473103a7b5e096c45855d7 dhcp-3.0.3.tar.gz 870240
-SHA256 c96bcd884dde06c22a709cfb9e84f7e32f6577dcd52aa7f12186aa22b5e63afe dhcp-3.0.3.tar.gz 870240
diff --git a/net-misc/dhcp/files/digest-dhcp-3.0.4_beta2-r2 b/net-misc/dhcp/files/digest-dhcp-3.0.4_beta2-r2
deleted file mode 100644
index 267960b1b5e8..000000000000
--- a/net-misc/dhcp/files/digest-dhcp-3.0.4_beta2-r2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 b82565e091832a4d16fb713c4ab48412 dhcp-3.0.4b2.tar.gz 879844
-RMD160 5a5026d0dfe697406f369ccb8509309b4eaf1f4c dhcp-3.0.4b2.tar.gz 879844
-SHA256 e1d207047b5f9c17bbe13653a3ec28b2b91347446ee2bffd9db6876a976eeb4b dhcp-3.0.4b2.tar.gz 879844
diff --git a/net-misc/dhcp/files/digest-dhcp-3.0.4_beta3 b/net-misc/dhcp/files/digest-dhcp-3.0.4_beta3
deleted file mode 100644
index f896f9d1f882..000000000000
--- a/net-misc/dhcp/files/digest-dhcp-3.0.4_beta3
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 560bd40eae9577eeacbdf2751651f4af dhcp-3.0.4b3.tar.gz 881727
-RMD160 2a696a2d83f89731481a94a0e569650ef069651e dhcp-3.0.4b3.tar.gz 881727
-SHA256 2e0b79b6dfbb2b686ccef0d48340865de7e4fea09286b097911639a922d289bc dhcp-3.0.4b3.tar.gz 881727