summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-09-15 15:51:44 +0000
committerAlin Năstac <mrness@gentoo.org>2006-09-15 15:51:44 +0000
commit4d6d947342cada644aaa99d2cc72fa1227819c22 (patch)
tree0054f72de98b1f43df91e71c4becabcab0817935
parentFixed bug #143906. (diff)
downloadgentoo-2-4d6d947342cada644aaa99d2cc72fa1227819c22.tar.gz
gentoo-2-4d6d947342cada644aaa99d2cc72fa1227819c22.tar.bz2
gentoo-2-4d6d947342cada644aaa99d2cc72fa1227819c22.zip
Remove obsolete versions, including the latest stable on x86 (#135321). Version bump, which appears to also solve 'crash on exit' bug (#130914).
(Portage version: 2.1.1)
-rw-r--r--app-mobilephone/bitpim/ChangeLog11
-rw-r--r--app-mobilephone/bitpim/bitpim-0.9.07.ebuild163
-rw-r--r--app-mobilephone/bitpim/files/bitpim-0.9.07-gentoo.patch63
-rw-r--r--app-mobilephone/bitpim/files/digest-bitpim-0.9.002
-rw-r--r--app-mobilephone/bitpim/files/digest-bitpim-0.9.073
5 files changed, 241 insertions, 1 deletions
diff --git a/app-mobilephone/bitpim/ChangeLog b/app-mobilephone/bitpim/ChangeLog
index c730790b9677..7abc93c739bf 100644
--- a/app-mobilephone/bitpim/ChangeLog
+++ b/app-mobilephone/bitpim/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-mobilephone/bitpim
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bitpim/ChangeLog,v 1.13 2006/06/02 20:19:53 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bitpim/ChangeLog,v 1.14 2006/09/15 15:51:44 mrness Exp $
+
+*bitpim-0.9.07 (15 Sep 2006)
+
+ 15 Sep 2006; Alin Nastac <mrness@gentoo.org>
+ -files/bitpim-0.8.12-gentoo.patch, -files/bitpim-0.8.13-gentoo.patch,
+ +files/bitpim-0.9.07-gentoo.patch, -bitpim-0.8.08.ebuild,
+ -bitpim-0.8.13.ebuild, +bitpim-0.9.07.ebuild:
+ Remove obsolete versions, including the latest stable on x86 (#135321).
+ Version bump, which appears to also solve 'crash on exit' bug (#130914).
*bitpim-0.9.00 (02 Jun 2006)
diff --git a/app-mobilephone/bitpim/bitpim-0.9.07.ebuild b/app-mobilephone/bitpim/bitpim-0.9.07.ebuild
new file mode 100644
index 000000000000..1ae5fe5c1718
--- /dev/null
+++ b/app-mobilephone/bitpim/bitpim-0.9.07.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bitpim/bitpim-0.9.07.ebuild,v 1.1 2006/09/15 15:51:44 mrness Exp $
+
+inherit distutils
+
+DESCRIPTION="This program allows you to view and manipulate data on LG VX4400/VX6000 and many Sanyo Sprint mobile phones"
+HOMEPAGE="http://www.bitpim.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crypt usb evo"
+
+DEPEND=">=dev-python/wxpython-2.6.3.2
+ >=dev-python/apsw-3
+ >=dev-python/python-dsv-1.4.0
+ >=dev-python/pyserial-2.0
+ crypt? ( >=dev-python/paramiko-1.5.4 )
+ usb? ( >=dev-lang/swig-1.3.21 >=dev-libs/libusb-0.1.10a )"
+RDEPEND="${DEPEND}
+ media-video/ffmpeg
+ media-libs/netpbm"
+
+#For Gentoo devs only: uncomment this line when you want to make the tarball
+#then COMMENT IT BACK!
+#pkg_setup() { maketarball; }
+maketarball() { #For building the tarball. To be used only by ebuild maintainers
+ local x svnrev
+ svnrev=$(svn log -q --limit 1 https://svn.sourceforge.net/svnroot/${PN}/releases/${PV} | sed -r '/^[^r]/d;s/^r([0-9]+) .*$/\1/')
+ [ $? = 0 ] || return 1
+
+ #Fetch the source (only those directories that are needed)
+ cd "${DISTDIR}" && mkdir ${P} || return 1
+ for x in resources packaging src ; do
+ svn export https://svn.sourceforge.net/svnroot/${PN}/releases/${PV}/${x} ${P}/${x} || return 1
+ done
+
+ #Remove unneeded stuff
+ rm ${P}/resources/*.chm ${P}/src/package.py
+
+ #Freeze version and set vendor name to Gentoo
+ sed -i -e 's/\(^__FROZEN__="[$]Id: \).*\( $"\)/\1'${svnrev}'\2/' \
+ -e 's/^vendor=".*"/vendor="Gentoo"/' \
+ ${P}/src/version.py || return 1
+
+ #Make the tarball
+ tar -cjf ${P}.tar.bz2 ${P}
+ rm -r ${P}
+}
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ sed -i "s/python2.3/${python}/" "${S}/src/native/usb/build.sh"
+}
+
+src_compile() {
+ # USB stuff
+ if use usb; then
+ cd "${S}/src/native/usb" || die "compilation of native/usb failed"
+ sh ./build.sh
+ fi
+
+ # strings
+ cd "${S}/src/native/strings"
+ ${python} setup.py build || die "compilation of native/strings failed"
+
+ # bmp2avi
+ cd "${S}/src/native/av/bmp2avi"
+ PLATFORM=linux make || die "compilation of native/bmp2avi failed"
+}
+
+src_install() {
+ cd "${S}"
+
+ # Install files into right place
+ #
+ # BitPim is a self-contained app, so jamming it into
+ # Python's site-packages might not be worthwhile. We'll
+ # Put it in its own home, and add the PYTHONPATH in the
+ # wrapper executables below.
+ distutils_python_version
+ local RLOC=/usr/lib/${P}
+
+ # Main Python source
+ insinto ${RLOC}
+ doins src/*.py
+
+ # Phone specifics
+ insinto ${RLOC}/phones
+ doins src/phones/*.py
+
+ # Native products
+ insinto ${RLOC}/native
+ doins src/native/*.py
+ insinto ${RLOC}/native/qtopiadesktop
+ doins src/native/qtopiadesktop/*.py
+ insinto ${RLOC}/native/outlook
+ doins src/native/outlook/*.py
+ insinto ${RLOC}/native/egroupware
+ doins src/native/egroupware/*.py
+ if use evo ; then
+ insinto ${RLOC}/native/evolution
+ doins src/native/evolution/*.py
+ fi
+
+ # strings
+ cd "${S}/src/native/strings"
+ ${python} setup.py install --root="${D}" --no-compile "$@" || die "install of native/strings failed"
+ cd "${S}"
+ insinto $RLOC/native/strings
+ doins src/native/strings/__init__.py src/native/strings/jarowpy.py
+
+ # usb
+ if use usb; then
+ insinto ${RLOC}/native/usb
+ doins src/native/usb/*.py
+ doins src/native/usb/*.so
+ fi
+
+ # Helpers and resources
+ dobin src/native/av/bmp2avi/bmp2avi
+ insinto ${RLOC}/resources
+ doins resources/*
+
+ # Bitfling
+ if use crypt; then
+ FLINGDIR="${RLOC}/bitfling"
+ insinto $FLINGDIR
+ cd "${S}/src/bitfling"
+ doins *.py
+ cd "${S}"
+ fi
+
+ # Creating scripts
+ echo '#!/bin/sh' > "${T}/bitpim"
+ echo "exec python ${RLOC}/bp.py bitpim" >> "${T}/bitpim"
+ dobin "${T}/bitpim"
+ if use crypt; then
+ echo '#!/bin/sh' > "${T}/bitfling"
+ echo "exec python ${RLOC}/bp.py bitfling" >> "${T}/bitfling"
+ dobin "${T}/bitfling"
+ fi
+
+ # Desktop file
+ insinto /usr/share/applications
+ sed -i -e "s|%%INSTALLBINDIR%%|/usr/bin|" -e "s|%%INSTALLLIBDIR%%|${RLOC}|" \
+ packaging/bitpim.desktop
+ doins packaging/bitpim.desktop
+}
+
+pkg_postinst() {
+ # Optimize in installed directory
+ python_mod_optimize "${ROOT}/usr/lib/${P}"
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup "${ROOT}/usr/lib/${P}"
+}
diff --git a/app-mobilephone/bitpim/files/bitpim-0.9.07-gentoo.patch b/app-mobilephone/bitpim/files/bitpim-0.9.07-gentoo.patch
new file mode 100644
index 000000000000..569b6b847e26
--- /dev/null
+++ b/app-mobilephone/bitpim/files/bitpim-0.9.07-gentoo.patch
@@ -0,0 +1,63 @@
+diff -Nru bitpim-0.9.07.orig/src/common.py bitpim-0.9.07/src/common.py
+--- bitpim-0.9.07.orig/src/common.py 2006-09-15 18:41:32.734807000 +0300
++++ bitpim-0.9.07/src/common.py 2006-09-15 18:41:12.801561250 +0300
+@@ -854,4 +854,4 @@
+ # windows running from exe, return as is
+ return os.path.abspath(os.path.dirname(sys.executable))
+ # running from src, up one
+- return os.path.split(os.path.abspath(os.path.dirname(sys.argv[0])))[0]
++ return os.path.abspath(os.path.dirname(sys.argv[0]))
+diff -Nru bitpim-0.9.07.orig/src/conversions.py bitpim-0.9.07/src/conversions.py
+--- bitpim-0.9.07.orig/src/conversions.py 2006-09-15 18:41:32.734807000 +0300
++++ bitpim-0.9.07/src/conversions.py 2006-09-15 18:41:12.801561250 +0300
+@@ -20,11 +20,11 @@
+
+ class ConversionFailed(Exception): pass
+
+-helperdir=os.path.join(common.get_main_dir(), "helpers")
++helperdir="/usr/bin"
+
+ osext={'win32': '.exe',
+ 'darwin': '.mbin',
+- 'linux2': '.lbin'} \
++ 'linux2': ''} \
+ [sys.platform]
+
+ # This shortname crap is needed because Windows programs (including ffmpeg)
+@@ -125,14 +125,14 @@
+ p=sys.path[0]
+ if os.path.isfile(p):
+ p=os.path.dirname(p)
+- helpersdirectory=os.path.abspath(os.path.join(p, 'helpers'))
++ helpersdirectory="/usr/bin"
+ print "Helper Directory: "+helpersdirectory
+ if sys.platform=='win32':
+ osext=".exe"
+ if sys.platform=='darwin':
+ osext=".mbin"
+ if sys.platform=='linux2':
+- osext=".lbin"
++ osext=""
+
+ pngtopnmbin=gethelperbinary('pngtopnm')
+ ppmquantbin=gethelperbinary('ppmquant')
+diff -Nru bitpim-0.9.07.orig/src/native/av/bmp2avi/Makefile bitpim-0.9.07/src/native/av/bmp2avi/Makefile
+--- bitpim-0.9.07.orig/src/native/av/bmp2avi/Makefile 2006-09-15 18:41:32.734807000 +0300
++++ bitpim-0.9.07/src/native/av/bmp2avi/Makefile 2006-09-15 18:41:12.801561250 +0300
+@@ -13,6 +13,6 @@
+
+ SRC=avi_file.cxx bmp_file.cxx b2a.cxx
+
+-bmp2avi.lbin bmp2avi.mbin bmp2avi.exe: $(SRC)
++bmp2avi bmp2avi.mbin bmp2avi.exe: $(SRC)
+ $(CXX) $(EXTRADEFINES) -O2 -o $@ $(SRC)
+
+diff -Nru bitpim-0.9.07.orig/src/native/usb/build.sh bitpim-0.9.07/src/native/usb/build.sh
+--- bitpim-0.9.07.orig/src/native/usb/build.sh 2006-09-15 18:41:12.000000000 +0300
++++ bitpim-0.9.07/src/native/usb/build.sh 2006-09-15 18:42:03.296717000 +0300
+@@ -4,4 +4,4 @@
+ swig -python -I/usr/include libusb.i
+
+ gcc -fPIC -Wall -fno-strict-aliasing -O2 -g -shared -I $INCLUDEDIR -o _libusb.so libusb_wrap.c -lusb
+-strip _libusb.so
++#strip _libusb.so
diff --git a/app-mobilephone/bitpim/files/digest-bitpim-0.9.00 b/app-mobilephone/bitpim/files/digest-bitpim-0.9.00
index 1f76ed2af7f0..5655ee2a56ee 100644
--- a/app-mobilephone/bitpim/files/digest-bitpim-0.9.00
+++ b/app-mobilephone/bitpim/files/digest-bitpim-0.9.00
@@ -1 +1,3 @@
MD5 5ebb17b25b0cf96402f6a9a367c92935 bitpim-0.9.00.tar.bz2 3795414
+RMD160 757797ebe7a595e30fc64321675aeb0cd797bcf7 bitpim-0.9.00.tar.bz2 3795414
+SHA256 b5452e2ac7397f44b0c9db7a20f766aa4d7dc417ba16a5fa3bd3c0b7ae8fff9f bitpim-0.9.00.tar.bz2 3795414
diff --git a/app-mobilephone/bitpim/files/digest-bitpim-0.9.07 b/app-mobilephone/bitpim/files/digest-bitpim-0.9.07
new file mode 100644
index 000000000000..54dff5798fa1
--- /dev/null
+++ b/app-mobilephone/bitpim/files/digest-bitpim-0.9.07
@@ -0,0 +1,3 @@
+MD5 cfe1cdeeb955582c746fd5c8ceb05ece bitpim-0.9.07.tar.bz2 3833224
+RMD160 fcee72015ada5623185e145f8b1703e29409c7fd bitpim-0.9.07.tar.bz2 3833224
+SHA256 159faac3ebb0685a30207b592c631b53ad83843a6a8103d5dca9d95a78e5f0df bitpim-0.9.07.tar.bz2 3833224