summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-10-20 01:22:57 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-10-20 01:22:57 +0000
commit508998c568d90653ec1019be4b4b27b9ba6a6330 (patch)
tree970320b1d73b72e3f913c451efc837042eb57443
parentMasking upcoming packages "dev-libs/maloc" and "sci-chemistry/apbs". (diff)
downloadgentoo-2-508998c568d90653ec1019be4b4b27b9ba6a6330.tar.gz
gentoo-2-508998c568d90653ec1019be4b4b27b9ba6a6330.tar.bz2
gentoo-2-508998c568d90653ec1019be4b4b27b9ba6a6330.zip
Initial import
(Portage version: 2.0.51.22-r3)
-rw-r--r--dev-libs/maloc/ChangeLog10
-rw-r--r--dev-libs/maloc/Manifest2
-rw-r--r--dev-libs/maloc/files/digest-maloc-0.1.21
-rw-r--r--dev-libs/maloc/maloc-0.1.2.ebuild45
-rw-r--r--dev-libs/maloc/metadata.xml5
-rw-r--r--sci-chemistry/apbs/ChangeLog10
-rw-r--r--sci-chemistry/apbs/Manifest3
-rw-r--r--sci-chemistry/apbs/apbs-0.3.2.ebuild61
-rw-r--r--sci-chemistry/apbs/files/digest-apbs-0.3.21
-rw-r--r--sci-chemistry/apbs/metadata.xml5
10 files changed, 143 insertions, 0 deletions
diff --git a/dev-libs/maloc/ChangeLog b/dev-libs/maloc/ChangeLog
new file mode 100644
index 000000000000..88dbf9f64323
--- /dev/null
+++ b/dev-libs/maloc/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-libs/maloc
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/maloc/ChangeLog,v 1.1 2005/10/20 01:20:05 ribosome Exp $
+
+*maloc-0.1.2 (20 Oct 2005)
+
+ 20 Oct 2005; Olivier Fisette <ribosome@gentoo.org> +metadata.xml,
+ +maloc-0.1.2.ebuild:
+ Initial import. Thanks to Markus Dittrich <markusle@gmail.com> for his work.
+
diff --git a/dev-libs/maloc/Manifest b/dev-libs/maloc/Manifest
new file mode 100644
index 000000000000..cff77a55b238
--- /dev/null
+++ b/dev-libs/maloc/Manifest
@@ -0,0 +1,2 @@
+MD5 6d381f2e3bc82054f61647e80e61e32a maloc-0.1.2.ebuild 1056
+MD5 7cf1ba71e8e07e331598eef5e214e297 files/digest-maloc-0.1.2 63
diff --git a/dev-libs/maloc/files/digest-maloc-0.1.2 b/dev-libs/maloc/files/digest-maloc-0.1.2
new file mode 100644
index 000000000000..2539a9f3b057
--- /dev/null
+++ b/dev-libs/maloc/files/digest-maloc-0.1.2
@@ -0,0 +1 @@
+MD5 4eb2a2788ab52118775227014db834cc maloc-0.1-2.tar.gz 897057
diff --git a/dev-libs/maloc/maloc-0.1.2.ebuild b/dev-libs/maloc/maloc-0.1.2.ebuild
new file mode 100644
index 000000000000..86fb9c8fcc05
--- /dev/null
+++ b/dev-libs/maloc/maloc-0.1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/maloc/maloc-0.1.2.ebuild,v 1.1 2005/10/20 01:20:05 ribosome Exp $
+
+inherit eutils
+
+MY_PV="0.1-2"
+
+DESCRIPTION="MALOC is a small, portable, abstract C environment library for object-oriented C programming"
+LICENSE="GPL-2"
+HOMEPAGE="http://scicomp.ucsd.edu/~mholst/codes/maloc/index.html#overview"
+SRC_URI=" http://cam.ucsd.edu/~mholst/codes/${PN}/${PN}-${MY_PV}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86"
+
+DEPEND="sys-libs/readline"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ # do not build blas
+ local myconf="--disable-blas"
+
+ # configure
+ econf ${myconf} || die "configure failed"
+
+ # fix install location of libs in Makefile
+ sed -e "s|libdir = \${prefix}/lib/\${fetk_cpu_vendor_os}|libdir = \${prefix}/lib/|" \
+ -i src/aaa_lib/Makefile || \
+ die "failed to patch lib Makefile"
+
+ # build
+ make || die "make failed"
+}
+
+src_install() {
+
+ # install libs and headers
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # install doc
+ dohtml doc/index.html || die "failed to install html docs"
+}
diff --git a/dev-libs/maloc/metadata.xml b/dev-libs/maloc/metadata.xml
new file mode 100644
index 000000000000..d369d068ffb8
--- /dev/null
+++ b/dev-libs/maloc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+</pkgmetadata>
diff --git a/sci-chemistry/apbs/ChangeLog b/sci-chemistry/apbs/ChangeLog
new file mode 100644
index 000000000000..c0b8c2b62a0f
--- /dev/null
+++ b/sci-chemistry/apbs/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/apbs
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.1 2005/10/20 01:22:57 ribosome Exp $
+
+*apbs-0.3.2 (20 Oct 2005)
+
+ 20 Oct 2005; Olivier Fisette <ribosome@gentoo.org> +metadata.xml,
+ +apbs-0.3.2.ebuild:
+ Initial import. Thanks to Markus Dittrich <markusle@gmail.com> for his work.
+
diff --git a/sci-chemistry/apbs/Manifest b/sci-chemistry/apbs/Manifest
new file mode 100644
index 000000000000..03305ff7c091
--- /dev/null
+++ b/sci-chemistry/apbs/Manifest
@@ -0,0 +1,3 @@
+MD5 0ffcd41aa96cf1bcffd8b539c27957db metadata.xml 157
+MD5 8bed6066f1d818f8de3abce7f9b96911 apbs-0.3.2.ebuild 1493
+MD5 fe78d29b43ac5fd73de88376a5db2855 files/digest-apbs-0.3.2 63
diff --git a/sci-chemistry/apbs/apbs-0.3.2.ebuild b/sci-chemistry/apbs/apbs-0.3.2.ebuild
new file mode 100644
index 000000000000..2111417a608b
--- /dev/null
+++ b/sci-chemistry/apbs/apbs-0.3.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-0.3.2.ebuild,v 1.1 2005/10/20 01:22:57 ribosome Exp $
+
+inherit eutils fortran
+
+DESCRIPTION=" Software for evaluating the electrostatic properties of nanoscale biomolecular systems"
+LICENSE="GPL-2"
+HOMEPAGE="http://agave.wustl.edu/apbs/"
+SRC_URI="http://agave.wustl.edu/apbs/download/dist/${P}.tar.gz"
+
+SLOT="0"
+IUSE="blas"
+KEYWORDS="~x86"
+
+DEPEND="blas? ( virtual/blas )
+ sys-libs/readline
+ dev-libs/maloc"
+
+pkg_setup() {
+ need_fortran g77
+}
+
+src_compile() {
+ # use blas
+ use blas && local myconf="--with-blas=-lblas"
+
+ # configure
+ econf ${myconf} || die "configure failed"
+
+ # build
+ make || die "make failed"
+}
+
+src_install() {
+
+ # install apbs binary
+ dobin bin/apbs || die "failed to install apbs binary"
+
+ # fix up and install examples
+ sed -e "s|\${bindir}|/usr/bin|" \
+ -i examples/ion-pmf/runme || \
+ die "failed fixing ion-pmf/runme file"
+
+ sed -e "s|bindir=''|bindir=/usr/bin|" \
+ -i examples/point-pmf/runme.sh || \
+ die "failed fixing point-pmf/runme.sh"
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || die "failed to install examples"
+
+ # install docs
+ insinto /usr/share/doc/${PF}/html/programmer
+ doins doc/html/programmer/* || die "failed to install html docs"
+
+ insinto /usr/share/doc/${PF}/html/tutorial
+ doins doc/html/tutorial/* || die "failed to install html docs"
+
+ insinto /usr/share/doc/${PF}/html/user-guide
+ doins doc/html/user-guide/* || die "failed to install html docs"
+}
diff --git a/sci-chemistry/apbs/files/digest-apbs-0.3.2 b/sci-chemistry/apbs/files/digest-apbs-0.3.2
new file mode 100644
index 000000000000..4659f3d3c792
--- /dev/null
+++ b/sci-chemistry/apbs/files/digest-apbs-0.3.2
@@ -0,0 +1 @@
+MD5 b2a417c1d9c102157f45cf00fd0ae196 apbs-0.3.2.tar.gz 6560956
diff --git a/sci-chemistry/apbs/metadata.xml b/sci-chemistry/apbs/metadata.xml
new file mode 100644
index 000000000000..d369d068ffb8
--- /dev/null
+++ b/sci-chemistry/apbs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+</pkgmetadata>