summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Laue <brad@gentoo.org>2005-10-01 19:25:31 +0000
committerBrad Laue <brad@gentoo.org>2005-10-01 19:25:31 +0000
commit53d1bd81c69267367fbbbc3c35dd5546fb6429cc (patch)
tree1bc0b9f9c7639dc2dd9aab1c968e39d876e06e8c
parentUsing tomcat servelet classpath. (diff)
downloadgentoo-2-53d1bd81c69267367fbbbc3c35dd5546fb6429cc.tar.gz
gentoo-2-53d1bd81c69267367fbbbc3c35dd5546fb6429cc.tar.bz2
gentoo-2-53d1bd81c69267367fbbbc3c35dd5546fb6429cc.zip
Version bump. Security fixes.
(Portage version: 2.0.51.22-r2)
-rw-r--r--mail-client/mozilla-thunderbird/ChangeLog9
-rw-r--r--mail-client/mozilla-thunderbird/files/digest-mozilla-thunderbird-1.0.74
-rw-r--r--mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.7.ebuild174
3 files changed, 186 insertions, 1 deletions
diff --git a/mail-client/mozilla-thunderbird/ChangeLog b/mail-client/mozilla-thunderbird/ChangeLog
index 9f43910f384b..80ecdc563565 100644
--- a/mail-client/mozilla-thunderbird/ChangeLog
+++ b/mail-client/mozilla-thunderbird/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-client/mozilla-thunderbird
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/ChangeLog,v 1.82 2005/08/19 05:24:51 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/ChangeLog,v 1.83 2005/10/01 19:25:31 brad Exp $
+
+*mozilla-thunderbird-1.0.7 (01 Oct 2005)
+
+ 01 Oct 2005; Brad Laue <brad@gentoo.org>
+ +mozilla-thunderbird-1.0.7.ebuild:
+ New version 1.0.7. Includes security fixes such as
+ http://secunia.com/advisories/16901/.
*mozilla-thunderbird-1.0.6-r5 (15 Aug 2005)
diff --git a/mail-client/mozilla-thunderbird/files/digest-mozilla-thunderbird-1.0.7 b/mail-client/mozilla-thunderbird/files/digest-mozilla-thunderbird-1.0.7
new file mode 100644
index 000000000000..e33379b7e616
--- /dev/null
+++ b/mail-client/mozilla-thunderbird/files/digest-mozilla-thunderbird-1.0.7
@@ -0,0 +1,4 @@
+MD5 e6388feb0ffcd189af779f165c124b4d thunderbird-1.0.7-source.tar.bz2 33385665
+MD5 1d6205bf7449fcdcae08cc1db524760d mozilla-firefox-1.0-4ft2.patch.bz2 5601
+MD5 7960994910bda4c14a52bc119f9ceefc mozilla-jslibmath-alpha.patch 625
+MD5 a120cd14ade242622387f76875ca9c39 mozilla-1.7.10-nsplugins-v2.patch 1968
diff --git a/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.7.ebuild b/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.7.ebuild
new file mode 100644
index 000000000000..1d0af479538c
--- /dev/null
+++ b/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.7.ebuild
@@ -0,0 +1,174 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.7.ebuild,v 1.1 2005/10/01 19:25:31 brad Exp $
+
+unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
+inherit flag-o-matic toolchain-funcs eutils mozconfig mozilla-launcher makeedit multilib
+
+DESCRIPTION="Thunderbird Mail Client"
+HOMEPAGE="http://www.mozilla.org/projects/thunderbird/"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${PV}/source/thunderbird-${PV}-source.tar.bz2
+ mirror://gentoo/mozilla-firefox-1.0-4ft2.patch.bz2
+ mirror://gentoo/mozilla-jslibmath-alpha.patch
+ http://dev.gentoo.org/~agriffis/dist/mozilla-1.7.10-nsplugins-v2.patch"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+IUSE="mozcalendar ldap"
+
+RDEPEND=">=www-client/mozilla-launcher-1.39"
+
+S=${WORKDIR}/mozilla
+
+# Needed by src_compile() and src_install().
+# Would do in pkg_setup but that loses the export attribute, they
+# become pure shell variables.
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+export MOZ_THUNDERBIRD=1
+
+src_unpack() {
+ declare x
+
+ for x in ${A}; do
+ [[ $x == *.tar.* ]] || continue
+ unpack $x || die "unpack failed"
+ done
+ cd ${S} || die "cd failed"
+
+ ####################################
+ #
+ # architecture patches
+ #
+ ####################################
+
+ if [[ $(gcc-major-version) -eq 3 ]]; then
+ # ABI Patch for alpha/xpcom for gcc-3.x
+ if [[ ${ARCH} == alpha ]]; then
+ epatch ${FILESDIR}/mozilla-alpha-xpcom-subs-fix.patch
+ fi
+ fi
+
+ # patch to fix math operations on alpha, makes maps.google.com work!
+ epatch ${DISTDIR}/mozilla-jslibmath-alpha.patch
+
+ ####################################
+ #
+ # general compilation and run-time fixes
+ #
+ ####################################
+
+ # GCC4 compile fix, bug #87800
+ epatch ${FILESDIR}/${PN}-1.0.6-gcc4.patch
+
+ # patch out ft caching code since the API changed between releases of
+ # freetype; this enables freetype-2.1.8+ compat.
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=234035#c65
+ epatch ${DISTDIR}/mozilla-firefox-1.0-4ft2.patch.bz2
+
+ # look in /usr/lib/nsplugins for plugins, in addition to the usual places
+ epatch ${DISTDIR}/mozilla-1.7.10-nsplugins-v2.patch
+}
+
+src_compile() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+
+ ####################################
+ #
+ # mozconfig, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+
+ mozconfig_init
+
+ # tb-specific settings
+ mozconfig_use_enable ldap
+ mozconfig_use_enable ldap ldap-experimental
+ mozconfig_use_enable mozcalendar calendar
+ mozconfig_annotate '' --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME}
+ mozconfig_annotate '' --with-user-appdir=.thunderbird
+
+ # Finalize and report settings
+ mozconfig_final
+
+ # hardened GCC uses -fstack-protector-all by default, which breaks us
+ has_hardened && append-flags -fno-stack-protector-all
+ replace-flags -fstack-protector-all -fstack-protector
+
+ ####################################
+ #
+ # Configure and build
+ #
+ ####################################
+
+ CPPFLAGS="${CPPFLAGS} -DARON_WAS_HERE" \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
+ econf || die
+
+ # It would be great if we could pass these in via CPPFLAGS or CFLAGS prior
+ # to econf, but the quotes cause configure to fail.
+ grep -Flre -DARON_WAS_HERE --exclude=config.\* . | xargs sed -i -e \
+ 's|-DARON_WAS_HERE|-DGENTOO_NSPLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsplugins\\\" -DGENTOO_NSBROWSER_PLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsbrowser/plugins\\\"|'
+
+ # This removes extraneous CFLAGS from the Makefiles to reduce RAM
+ # requirements while compiling
+ edit_makefiles
+
+ emake || die
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+
+ # Most of the installation happens here
+ dodir ${MOZILLA_FIVE_HOME}
+ cp -RL --no-preserve=links ${S}/dist/bin/* ${D}${MOZILLA_FIVE_HOME}
+
+ # Create directory structure to support portage-installed extensions.
+ # See update_chrome() in mozilla-launcher
+ keepdir ${MOZILLA_FIVE_HOME}/chrome.d
+ keepdir ${MOZILLA_FIVE_HOME}/extensions.d
+ cp ${D}${MOZILLA_FIVE_HOME}/chrome/installed-chrome.txt \
+ ${D}${MOZILLA_FIVE_HOME}/chrome.d/0_base-chrome.txt
+
+ # Create /usr/bin/thunderbird
+ install_mozilla_launcher_stub thunderbird ${MOZILLA_FIVE_HOME}
+
+ # Install icon and .desktop for menu entry
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/icon/thunderbird-icon.png
+
+ # Fix bug 54179: Install .desktop file into /usr/share/applications
+ # instead of /usr/share/gnome/apps/Internet (18 Jun 2004 agriffis)
+ insinto /usr/share/applications
+ doins ${FILESDIR}/icon/mozillathunderbird.desktop
+}
+
+pkg_postinst() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+
+ # Update the component registry
+ MOZILLA_LIBDIR=${ROOT}${MOZILLA_FIVE_HOME} MOZILLA_LAUNCHER=thunderbird \
+ /usr/libexec/mozilla-launcher -register
+
+ # This should be called in the postinst and postrm of all the
+ # mozilla, mozilla-bin, firefox, firefox-bin, thunderbird and
+ # thunderbird-bin ebuilds.
+ update_mozilla_launcher_symlinks
+
+ ewarn "Enigmail Support has been dropped since it doesn't work on fresh install."
+ ewarn "The Gentoo Mozilla team is working on making enigmail its own build,"
+ ewarn "sorry for the inconvenience. For now, you can download enigmail from"
+ ewarn "http://enigmail.mozdev.org"
+}
+
+pkg_postrm() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+
+ # Update the component registry
+ MOZILLA_LIBDIR=${ROOT}${MOZILLA_FIVE_HOME} MOZILLA_LAUNCHER=thunderbird \
+ /usr/libexec/mozilla-launcher -register
+
+ update_mozilla_launcher_symlinks
+}