summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-02-25 17:07:49 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-02-25 17:07:49 +0000
commit577ed4c51eba20bcfc8a2ff9972d0d96af7306e8 (patch)
tree968189b4078f76d26002e458dd3366c0600bfa6c
parentVersion bumped. (diff)
downloadgentoo-2-577ed4c51eba20bcfc8a2ff9972d0d96af7306e8.tar.gz
gentoo-2-577ed4c51eba20bcfc8a2ff9972d0d96af7306e8.tar.bz2
gentoo-2-577ed4c51eba20bcfc8a2ff9972d0d96af7306e8.zip
Version bumped.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
-rw-r--r--app-i18n/ibus-pinyin/ChangeLog8
-rw-r--r--app-i18n/ibus-pinyin/ibus-pinyin-1.1.0.20090225.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/app-i18n/ibus-pinyin/ChangeLog b/app-i18n/ibus-pinyin/ChangeLog
index 440cf2fbee95..9fe72d45fcba 100644
--- a/app-i18n/ibus-pinyin/ChangeLog
+++ b/app-i18n/ibus-pinyin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-pinyin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-pinyin/ChangeLog,v 1.5 2009/02/12 15:11:39 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-pinyin/ChangeLog,v 1.6 2009/02/25 17:07:49 matsuu Exp $
+
+*ibus-pinyin-1.1.0.20090225 (25 Feb 2009)
+
+ 25 Feb 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-pinyin-1.1.0.20090225.ebuild:
+ Version bumped.
*ibus-pinyin-1.1.0.20090211 (12 Feb 2009)
diff --git a/app-i18n/ibus-pinyin/ibus-pinyin-1.1.0.20090225.ebuild b/app-i18n/ibus-pinyin/ibus-pinyin-1.1.0.20090225.ebuild
new file mode 100644
index 000000000000..5b3f5ae4558e
--- /dev/null
+++ b/app-i18n/ibus-pinyin/ibus-pinyin-1.1.0.20090225.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-pinyin/ibus-pinyin-1.1.0.20090225.ebuild,v 1.1 2009/02/25 17:07:49 matsuu Exp $
+
+inherit eutils python
+
+PYDB_TAR="pinyin-database-0.1.10.6.tar.bz2"
+DESCRIPTION="Chinese PinYin IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz
+ http://ibus.googlecode.com/files/${PYDB_TAR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.1.0
+ >=dev-lang/python-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+pkg_setup() {
+ if ! built_with_use '>=dev-lang/python-2.5' sqlite; then
+ eerror "To use ibus-pinyin you have to build dev-lang/python with \"sqlite\" USE flag!"
+ die "To use ibus-pinyin you have to build dev-lang/python
+ with \"sqlite\" USE flag!"
+ fi
+}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+ cp "${DISTDIR}/${PYDB_TAR}" "${S}"/engine
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}