summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-28 23:20:33 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-28 23:20:33 +0000
commit58843fec9444eaabfb44ed84802d914d9393dcb0 (patch)
tree65c3f0c6913800059154463aa7204fe7b786f697
parentversion bump as per bug #259018 patch thanks to Arfrever Frehtes Taifersar Ar... (diff)
downloadgentoo-2-58843fec9444eaabfb44ed84802d914d9393dcb0.tar.gz
gentoo-2-58843fec9444eaabfb44ed84802d914d9393dcb0.tar.bz2
gentoo-2-58843fec9444eaabfb44ed84802d914d9393dcb0.zip
Fixing 0.4 and 9999 ebuild deps with dev-db/sqlite[threadsafe] to fix #260485
(Portage version: 2.2_rc23/cvs/Linux x86_64)
-rw-r--r--net-irc/quassel/ChangeLog9
-rw-r--r--net-irc/quassel/quassel-0.4.0-r2.ebuild124
-rw-r--r--net-irc/quassel/quassel-9999.ebuild4
3 files changed, 135 insertions, 2 deletions
diff --git a/net-irc/quassel/ChangeLog b/net-irc/quassel/ChangeLog
index 421906c845d1..a4a54a274017 100644
--- a/net-irc/quassel/ChangeLog
+++ b/net-irc/quassel/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/quassel
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.45 2009/02/20 20:02:08 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.46 2009/02/28 23:20:33 patrick Exp $
+
+*quassel-0.4.0-r2 (28 Feb 2009)
+
+ 28 Feb 2009; Patrick Lauer <patrick@gentoo.org> +quassel-0.4.0-r2.ebuild,
+ quassel-9999.ebuild:
+ Fixing 0.4 and 9999 ebuild deps with dev-db/sqlite[threadsafe] to fix
+ #260485
*quassel-0.4.0-r1 (20 Feb 2009)
diff --git a/net-irc/quassel/quassel-0.4.0-r2.ebuild b/net-irc/quassel/quassel-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..e1aa72c2faf9
--- /dev/null
+++ b/net-irc/quassel/quassel-0.4.0-r2.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.4.0-r2.ebuild,v 1.1 2009/02/28 23:20:33 patrick Exp $
+
+EAPI="2"
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Qt4/KDE4 IRC client suppporting a remote daemon for 24/7 connectivity."
+HOMEPAGE="http://quassel-irc.org/"
+SRC_URI="http://quassel-irc.org/pub/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="dbus debug kde monolithic +oxygen phonon +server +ssl webkit +X"
+
+LANGS="cs da de fr hu nb_NO ru sl tr"
+for l in ${LANGS}; do
+ IUSE="${IUSE} linguas_${l}"
+done
+
+RDEPEND="
+ x11-libs/qt-core:4
+ dbus? ( x11-libs/qt-dbus:4 )
+ monolithic? (
+ dev-db/sqlite[threadsafe]
+ x11-libs/qt-sql:4[sqlite]
+ x11-libs/qt-script:4
+ x11-libs/qt-gui:4
+ kde? ( >=kde-base/kdelibs-4.1 )
+ phonon? ( || ( media-sound/phonon x11-libs/qt-phonon ) )
+ webkit? ( x11-libs/qt-webkit:4 )
+ )
+ !monolithic? (
+ server? (
+ dev-db/sqlite[threadsafe]
+ x11-libs/qt-sql:4[sqlite]
+ x11-libs/qt-script:4
+ )
+ X? (
+ x11-libs/qt-gui:4
+ kde? ( >=kde-base/kdelibs-4.1 )
+ phonon? ( || ( media-sound/phonon x11-libs/qt-phonon ) )
+ webkit? ( x11-libs/qt-webkit:4 )
+ )
+ )
+ ssl? (
+ dev-libs/openssl
+ x11-libs/qt-core:4[ssl]
+ )
+ "
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.6"
+
+DOCS="AUTHORS ChangeLog README"
+
+pkg_setup() {
+ if ! use monolithic && ! use server && ! use X ; then
+ eerror "You have to build at least one of the monolithic client (USE=monolithic),"
+ eerror "the quasselclient (USE=X) or the quasselcore (USE=server)."
+ die "monolithic, server and X flag unset."
+ fi
+}
+
+src_configure() {
+ local MY_LANGUAGES=""
+ for i in ${LINGUAS}; do
+ MY_LANGUAGES="${i},${MY_LANGUAGES}"
+ done
+
+ local mycmakeargs="
+ $(cmake-utils_use_want X QTCLIENT)
+ $(cmake-utils_use_want server CORE)
+ $(cmake-utils_use_want monolithic MONO)
+ $(cmake-utils_use_with webkit WEBKIT)
+ $(cmake-utils_use_with phonon PHONON)
+ $(cmake-utils_use_with kde KDE)
+ $(cmake-utils_use_with dbus DBUS)
+ $(cmake-utils_use_with ssl OPENSSL)
+ $(cmake-utils_use_with oxygen OXYGEN)
+ -DEMBED_DATA=OFF
+ -DLINGUAS=${MY_LANGUAGES}
+ "
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use server ; then
+ newinitd "${FILESDIR}"/quasselcore-2.init quasselcore || die "newinitd failed"
+ newconfd "${FILESDIR}"/quasselcore-2.conf quasselcore || die "newconfd failed"
+
+ insinto /usr/share/doc/${PF}
+ doins "${S}"/scripts/manageusers.py || die "installing manageusers.py failed"
+ fi
+}
+
+pkg_postinst() {
+ if use server ; then
+ ewarn
+ ewarn "In order to use the quassel init script you must set the"
+ ewarn "QUASSEL_USER variable in /etc/conf.d/quasselcore to your username."
+ ewarn "Note: This is the user who runs the quasselcore and is independent"
+ ewarn "from the users you set up in the quasselclient."
+ elog
+ elog "Adding more than one user or changing username/password is not"
+ elog "possible via the quasselclient yet. If you need to do these things"
+ elog "you have to use the manageusers.py script, which has been installed in"
+ elog "/usr/share/doc/${PF}".
+ elog "http://bugs.quassel-irc.org/wiki/quassel-irc/Manage_core_users provides"
+ elog "some information on using the script."
+ elog "To be sure nothing bad will happen you need to stop the quasselcore"
+ elog "before adding more users."
+ fi
+
+ if ( use server || use monolithic ) && use ssl ; then
+ elog
+ elog "Information on how to enable SSL support for client/core connections"
+ elog "is available at http://bugs.quassel-irc.org/wiki/quassel-irc."
+ fi
+}
diff --git a/net-irc/quassel/quassel-9999.ebuild b/net-irc/quassel/quassel-9999.ebuild
index a3871922b449..4ea5ccf51aa0 100644
--- a/net-irc/quassel/quassel-9999.ebuild
+++ b/net-irc/quassel/quassel-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-9999.ebuild,v 1.19 2009/02/20 20:02:08 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-9999.ebuild,v 1.20 2009/02/28 23:20:33 patrick Exp $
EAPI="2"
@@ -26,6 +26,7 @@ RDEPEND="
x11-libs/qt-core:4
dbus? ( x11-libs/qt-dbus:4 )
monolithic? (
+ dev-db/sqlite[threadsafe]
x11-libs/qt-sql:4[sqlite]
x11-libs/qt-script:4
x11-libs/qt-gui:4
@@ -35,6 +36,7 @@ RDEPEND="
)
!monolithic? (
server? (
+ dev-db/sqlite[threadsafe]
x11-libs/qt-sql:4[sqlite]
x11-libs/qt-script:4
)