summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-10-25 07:16:37 +0000
committerIan Delaney <idella4@gentoo.org>2014-10-25 07:16:37 +0000
commit5a304085607c9a7b5dfc39c20546408a61767c9c (patch)
treefb169fc0020a32195292efb87b71aa152ed0ce3f
parentStable for HPPA (bug #525960). (diff)
downloadgentoo-2-5a304085607c9a7b5dfc39c20546408a61767c9c.tar.gz
gentoo-2-5a304085607c9a7b5dfc39c20546408a61767c9c.tar.bz2
gentoo-2-5a304085607c9a7b5dfc39c20546408a61767c9c.zip
bump; correction to deps, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
-rw-r--r--dev-python/datashape/ChangeLog8
-rw-r--r--dev-python/datashape/datashape-0.1.1.ebuild41
-rw-r--r--dev-python/datashape/datashape-0.2.0.ebuild42
-rw-r--r--dev-python/datashape/datashape-0.4.0.ebuild (renamed from dev-python/datashape/datashape-0.1.0.ebuild)27
4 files changed, 22 insertions, 96 deletions
diff --git a/dev-python/datashape/ChangeLog b/dev-python/datashape/ChangeLog
index 80f93fe58e27..d81b1757b963 100644
--- a/dev-python/datashape/ChangeLog
+++ b/dev-python/datashape/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/datashape
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/datashape/ChangeLog,v 1.5 2014/08/10 01:27:16 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/datashape/ChangeLog,v 1.6 2014/10/25 07:16:37 idella4 Exp $
+
+*datashape-0.4.0 (25 Oct 2014)
+
+ 25 Oct 2014; Ian Delaney <idella4@gentoo.org> +datashape-0.4.0.ebuild,
+ -datashape-0.1.0.ebuild, -datashape-0.1.1.ebuild, -datashape-0.2.0.ebuild:
+ bump; correction to deps, rm old
10 Aug 2014; Ian Delaney <idella4@gentoo.org> datashape-0.3.0.ebuild:
switch test dep to pytest, update test phase
diff --git a/dev-python/datashape/datashape-0.1.1.ebuild b/dev-python/datashape/datashape-0.1.1.ebuild
deleted file mode 100644
index 335177f708f9..000000000000
--- a/dev-python/datashape/datashape-0.1.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/datashape/datashape-0.1.1.ebuild,v 1.1 2014/02/23 00:02:51 bicatali Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Language defining a data description protocol"
-HOMEPAGE="https://github.com/ContinuumIO/datashape"
-SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/ply[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib* || die
- nosetests -v || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/datashape/datashape-0.2.0.ebuild b/dev-python/datashape/datashape-0.2.0.ebuild
deleted file mode 100644
index 5efdfb650de2..000000000000
--- a/dev-python/datashape/datashape-0.2.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/datashape/datashape-0.2.0.ebuild,v 1.1 2014/05/26 07:43:32 patrick Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_2,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Language defining a data description protocol"
-HOMEPAGE="https://github.com/ContinuumIO/datashape"
-SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/ply[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/multipledispatch[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib* || die
- nosetests -v || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/datashape/datashape-0.1.0.ebuild b/dev-python/datashape/datashape-0.4.0.ebuild
index 2999105e1c5f..655fbbfdc4fc 100644
--- a/dev-python/datashape/datashape-0.1.0.ebuild
+++ b/dev-python/datashape/datashape-0.4.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/datashape/datashape-0.1.0.ebuild,v 1.1 2014/02/10 20:28:50 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/datashape/datashape-0.4.0.ebuild,v 1.1 2014/10/25 07:16:37 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1
@@ -17,22 +17,25 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc test"
-RDEPEND="
- dev-python/ply[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/multipledispatch[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/'sphinx.ext.intersphinx', //" -i docs/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
python_compile_all() {
use doc && emake -C docs html
}
python_test() {
- cd "${BUILD_DIR}"/lib* || die
- nosetests -v || die
+ py.test -v || die "Tests failed under ${EPYTHON}"
}
python_install_all() {